Z-Stick Gen5+ not pairing with sensors and switches

Installed Z-Wave JS with Z-Stick Gen5+ (ZW090-C) but I cant connect or pair any devices.

I have a Z-Wave network already with Tellstick that I want to migrate to Z-Wave JS. I’ve tried with devices that has not been connected to the old Z-wave network and I’ve tried to exclude devices from the old and connect to Z-wave JS.

I should also notice that the USB-stick is blinking blue, yellow and red. I’ve read somewhere that this was normal but the sequence is not mentioned in the manual for the Z-wave.

Settings page

Drivrutin-version: 10.17.0
Serverversion: 1.28.0
Hem ID: [numbers]
Server-URL: ws://core-zwave-js:3000

only thing I find strange from the log is 2nd line, but how to fix?

Starting server on


2023-05-17T18:24:23.878Z DRIVER   driver ready
Starting server on
2023-05-17T18:24:23.994Z CNTRLR   [Node 001] The node is alive.
2023-05-17T18:24:23.999Z CNTRLR   [Node 001] The node is ready to be used
2023-05-17T18:24:24.006Z CNTRLR   All nodes are ready to be used
ZwaveJS server listening on
New client
Client disconnected
Code 1000: 
New client
2023-05-17T18:26:38.919Z CNTRLR   Starting inclusion process with strategy Default...
2023-05-17T18:26:39.092Z SERIAL » 0x0105004ac10170                                                     (7 bytes)
2023-05-17T18:26:39.106Z DRIVER » [REQ] [AddNodeToNetwork]
                                    node type:    Any
                                    high power:   true
                                    network wide: true
                                    callback id:  1
2023-05-17T18:26:39.134Z SERIAL « [ACK]                                                                   (0x06)
2023-05-17T18:26:39.152Z SERIAL « 0x0107004a01010000b2                                                 (9 bytes)
2023-05-17T18:26:39.162Z SERIAL » [ACK]                                                                   (0x06)
2023-05-17T18:26:39.172Z DRIVER « [REQ] [AddNodeToNetwork]
                                    status:      Ready
                                    callback id: 1
2023-05-17T18:26:39.227Z CNTRLR   The controller is now ready to add nodes
2023-05-17T18:27:58.064Z CNTRLR   stopping inclusion process...
2023-05-17T18:27:58.170Z SERIAL » 0x0105004ac50277                                                     (7 bytes)
2023-05-17T18:27:58.175Z DRIVER » [REQ] [AddNodeToNetwork]
                                    action:       Stop
                                    high power:   true
                                    network wide: true
                                    callback id:  2
2023-05-17T18:27:58.203Z SERIAL « [ACK]                                                                   (0x06)
2023-05-17T18:27:58.268Z SERIAL « 0x0107004a02060000b6                                                 (9 bytes)
2023-05-17T18:27:58.276Z SERIAL » [ACK]                                                                   (0x06)
2023-05-17T18:27:58.285Z DRIVER « [REQ] [AddNodeToNetwork]
                                    status:      Done
                                    callback id: 2
2023-05-17T18:27:58.327Z CNTRLR   The inclusion process was stopped
Client disconnected
Code 1000: 
New client
New client
Client disconnected
Code 1000: 

How is your USB Zwave stick connected to the Pi’s USB? Directly, or using an extended USB cable?

Radio controllers connected directly in to the Pi’s USB are known for having problems with interference…

I’m using an extended USB cable, so the USB-stick is outside my rack cabinet.

I should also notice that the USB-stick is blinking blue, yellow and red. I’ve read somewhere that this was normal but the sequence is not mentioned in the manual for the Z-wave.

Thanks for the question @BebeMischa

1 Like

If it’s a new Aoetec stick, I’d try a factory reset. Someone may have had it before you and returned it.

I was hopeful for your idea @PeteRage it sounded plausible but it was not the one.

Got some more out of the log. even if you download full log it does not show more than what is shown on the page…

· SetSUCNodeId (0x54)
                                    · DeleteSUCReturnRoute (0x55)
                                    · GetSUCNodeId (0x56)
                                    · UNKNOWN_FUNC_SEND_SUC_ID (0x57)
                                    · FUNC_ID_ZW_EXPLORE_REQUEST_INCLUSION (0x5e)
                                    · RequestNodeInfo (0x60)
                                    · RemoveFailedNode (0x61)
                                    · IsFailedNode (0x62)
                                    · ReplaceFailedNode (0x63)
                                    · UNKNOWN_FUNC_UNKNOWN_0x66 (0x66)
                                    · UNKNOWN_FUNC_UNKNOWN_0x67 (0x67)
                                    · GetRoutingInfo (0x80)
                                    · UNKNOWN_FUNC_LOCK_ROUTE_RESPONSE (0x90)
                                    · GetPriorityRoute (0x92)
                                    · SetPriorityRoute (0x93)
                                    · UNKNOWN_FUNC_UNKNOWN_0x98 (0x98)
                                    · UNKNOWN_FUNC_UNKNOWN_0xB4 (0xb4)
                                    · UNKNOWN_FUNC_WATCH_DOG_ENABLE (0xb6)
                                    · UNKNOWN_FUNC_WATCH_DOG_DISABLE (0xb7)
                                    · UNKNOWN_FUNC_WATCH_DOG_KICK (0xb8)
                                    · UNKNOWN_FUNC_UNKNOWN_0xB9 (0xb9)
                                    · UNKNOWN_FUNC_RF_POWERLEVEL_GET (0xba)
                                    · UNKNOWN_FUNC_GET_LIBRARY_TYPE (0xbd)
                                    · UNKNOWN_FUNC_SEND_TEST_FRAME (0xbe)
                                    · UNKNOWN_FUNC_GET_PROTOCOL_STATUS (0xbf)
                                    · UNKNOWN_FUNC_UNKNOWN_0xD2 (0xd2)
                                    · UNKNOWN_FUNC_UNKNOWN_0xD3 (0xd3)
                                    · UNKNOWN_FUNC_UNKNOWN_0xD4 (0xd4)
                                    · undefined (0xee)
                                    · UNKNOWN_FUNC_UNKNOWN_0xEF (0xef)
2023-05-24T15:57:06.397Z DRIVER   Soft reset is enabled through config, but this stick does not support it.
2023-05-24T15:57:06.463Z CNTRLR   querying version info...
2023-05-24T15:57:06.673Z CNTRLR   received version info:
                                    controller type: Static Controller
                                    library version: Z-Wave 4.54
2023-05-24T15:57:06.681Z CNTRLR   querying protocol version info...
2023-05-24T15:57:06.873Z CNTRLR   received protocol version info:
                                    protocol type:             Z-Wave
                                    protocol version:          4.54.0
2023-05-24T15:57:06.889Z CNTRLR   supported Z-Wave features: 
2023-05-24T15:57:06.891Z CNTRLR   querying controller capabilities...
2023-05-24T15:57:07.087Z CNTRLR   received controller capabilities:
                                    controller role:      primary
                                    is the SUC:           false
                                    started this network: true
                                    SIS is present:       false
                                    was real primary:     true
2023-05-24T15:57:07.089Z CNTRLR   finding SUC...
2023-05-24T15:57:07.270Z CNTRLR   No SUC present in the network
2023-05-24T15:57:07.272Z CNTRLR   There is no SUC/SIS in the network - promoting ourselves...
2023-05-24T15:57:07.524Z CNTRLR   Promotion to SUC/SIS succeeded.
2023-05-24T15:57:07.528Z CNTRLR   querying additional controller information...
2023-05-24T15:57:07.759Z CNTRLR   received additional controller information:
                                    Z-Wave API version:         5 (legacy)
                                    Z-Wave chip type:           ZW050x
                                    node type                   Controller
                                    controller role:            primary
                                    controller is the SIS:      true
                                    controller supports timers: false
                                    nodes in the network:       1
2023-05-24T15:57:07.981Z CNTRLR   setting serial API timeouts: ack = 1000 ms, byte = 150 ms
2023-05-24T15:57:08.152Z CNTRLR   serial API timeouts overwritten. The old values were: ack = 1500 ms, byte = 15
                                  0 ms
2023-05-24T15:57:08.155Z CNTRLR   Interview completed
Starting server on
2023-05-24T15:57:08.445Z CNTRLR   [Node 001] Beginning interview - last completed stage: None
2023-05-24T15:57:08.452Z CNTRLR   [Node 001] new node, doing a full interview...
2023-05-24T15:57:08.461Z CNTRLR » [Node 001] querying protocol info...
ZwaveJS server listening on
2023-05-24T15:57:09.419Z CNTRLR « [Node 001] received response for protocol info:
                                  basic device class:    Static Controller
                                  generic device class:  Static Controller
                                  specific device class: PC Controller
                                  node type:             Controller
                                  is always listening:   true
                                  is frequent listening: false
                                  can route messages:    false
                                  supports security:     false
                                  supports beaming:      true
                                  maximum data rate:     100000 kbps
                                  protocol version:      3
2023-05-24T15:57:09.430Z CNTRLR   [Node 001] Interview stage completed: ProtocolInfo
2023-05-24T15:57:10.403Z CNTRLR   [Node 001] Embedded device config loaded
2023-05-24T15:57:10.408Z CNTRLR   [Node 001] Interview stage completed: OverwriteConfig
2023-05-24T15:57:10.410Z CNTRLR   [Node 001] Interview completed
2023-05-24T15:57:10.416Z CNTRLR   [Node 001] The node is ready to be used
2023-05-24T15:57:10.420Z CNTRLR   All nodes are ready to be used
2023-05-24T15:57:10.439Z CNTRLR   [Node 001] The node is alive.
New client
Client disconnected
Code 1000: 
New client
2023-05-24T16:24:25.711Z CNTRLR   Starting inclusion process with strategy Default...
2023-05-24T16:24:26.198Z CNTRLR   The controller is now ready to add nodes
2023-05-24T16:25:55.676Z CNTRLR   stopping inclusion process...
2023-05-24T16:25:55.916Z CNTRLR   The inclusion process was stopped
2023-05-24T16:35:25.256Z CNTRLR   Starting inclusion process with strategy Default...
2023-05-24T16:35:25.412Z CNTRLR   The controller is now ready to add nodes
2023-05-24T16:36:08.652Z CNTRLR   stopping inclusion process...
2023-05-24T16:36:08.848Z CNTRLR   The inclusion process was stopped

I would try using the Z-Wave PC Controller Software. It’s made by the people who own the Z-Wave protocol. The software is free and is an easy way to tell if the problem is a home assistant problem or something else.

The next thing I’d try is factory resetting one of the nodes and then try to include it.

@cornellrwilliams I’ve followed your suggestion to install Z-Wave PC Controller. Looks like same, cant find anything that could give me more information than the log from HA.

21:58:23.473 Add Node started
21:59:30.844 Add Node completed in 00:01:07.370

I’ve ordered a new z-wave device (I need a switch anyway) from another brand, hope it arrive on Monday.

@PeteRage, I have factory reset both the stick and device.

Is the stick broken?

My guess is that you do not have the correct region setup in the settings.

Transmitter settings is not enabled :frowning:
Z-Wave Gen5+ ZW090-C is for the EU market. Do you need have the correct country?
I have also followed the guide from the Aeotec (manufacturer of Z-wave stick)

Yes you need to have the correct county set. So the only thing that prevents a device from using another frequency is the saw filter. They are usually only installed on the end devices and not the controllers. This means on controllers you can actually change what region to use.

I looked at the fccid internal photos and the Z-Stick does not have a saw filter. So the only difference between the eu version and the us version is likely different firmware and the region setting.

I changed my region to test out other devices and when I tried to add devices from a different region I would get the same symptoms you were having. This is why I assumed it was a region problem.

I’ve never seen the transmit settings greyed out. If you go to the network management page what device.type does it have the controller listed as? Is it listed as a PC CONTROLLER?

Thank you for your help and support @cornellrwilliams
Here is a picture of the network management page. It is listed as a PC Controller…

Click the set as sis button. Also have you tried updating the firmware of the stick?

The “sis” button didnt change anything except adding it to the Network Role.

I’ve tried to update to 1.02 but I’m getting error message… I’ve send ticket to Aeotec.

After I tried update I cant connect to it with PC Controller.
I hope Aeotec comes back soon.

Hi @cornellrwilliams and @PeteRage
Thank you for your support! I found the issue! It’s me… I thought I could exclude a node from my previous z-wave network by just simply click 3 time on the switch, as it says in the manual. No, I needed to first exclude in the old controller then click 3 times on the switch.

Now it works!

Still strange is that the magnet sensor has never been included in any network and there I did a factory reset. This was the unit I worked most with since it not build in or previous connected to a controller. I still not have it in the new Aeotec controller.

I figured this out due to the new wall plugg arrived today.

Sorry that I took your time and once again thanks for the support.