Z-wave commands stopped working for a long time today (but states were correct)

Today, all of my z-wave devices stopped responding to commands… until I was 90% of the way through writing this message.
The UI was correctly showing the state of each device.
E.g., I could see which lights are on/off but I couldn’t turn them on/off without physically using the light switch.
All (30+) of my z-wave devices were acting this way, regardless of manufacturer or type of device.

Things I tried which did not work:

  • Reloading (on my http://homeassistant:8123/config/integrations/integration/zwave_js page). (I tried this about 10 times throughout the day)
  • Restarting Home assistant from developer tools → YAML → Restart (I tried this about 3 or 4 times throughout the day)
  • Powering off (hassio.host_shutdown), removing the z-wave dongle, powering back on, powering off again, putting the dongle back, and powering back on. (I tried this once about an hour ago)
  • Wishing real hard, swearing a bit, crying softly, and threatening it. (As needed)

The issue started early this morning, and I had been trying things throughout the day… and finally started digging in about an hour ago, and had just given up and started writing this message. As I was writing this I tried several more times, and nothing was working. Then, I went to copy something I had seen in the logs earlier ( at http://homeassistant:8123/config/zwave_js/logs?config_entry…) which had happened when I tried to turn on a light earlier (Something about dropping a packet with an invalid payload, or something like that)… except this time, the light just turned on. So… I just tried several others, and they work fine too.

So… now that it decided to start working again, I guess it is not sensible for me to ask for help… but instead I will ask:

  • Has anyone seen this kind of thing before?
  • If/when it happens again, what should I try?
  • If I end up back in this position again, and wanted to provide good logs here, which logs should I get? It seems like there are at least 3 log-like-things that I could look at, and I am sure there are more I don’t know about. Which one is the “right one” for this sort of issue?

I have had exactly the same symptoms for the last 3 days,

Personally, i rollback to the previous version.

There’s definitely something wrong with Z-Wave in 2023.9. Other people are having similar problems. Either restore a backup or deal with it until another update resolves the issue.

What problems are you referring to? 2023.9 was released less than an hour ago. The Docker images are not even built yet. Surely this post from 2 days ago is not one of these 2023.9 problems.

Looks in the zwavejs logfiles see if your controlled is reporting “jammed”. This is a problem that appeared on 2023.8.0

I also have these issues (see my post)
It started some time ago, after an update I think.
I’m on 2023.8.4

Yeah, I am seeing info about it being jammed, and then unjammed a few seconds later.
I also see messages with “invalid payload” occasionally. Though, the other day, it was acting badly for just about the entire day. At least 10 hours, probably more like 20.

I upgraded to 2023.9 just about an hour ago, but I was seeing this before the update when I was still on 2023.8.4.
My zwave js is also 0.1.89 now, but I also just upgraded it today. (Not sure what version I was on before though)

Do you really mean 2022.8.0? or 2023.8.0? Has it really been a problem for a year?

2023-09-07T04:51:15.241Z CNTRLR   The controller is jammed
2023-09-07T04:51:22.633Z CNTRLR   The controller is no longer jammed
2023-09-07T04:54:43.984Z CNTRLR « [Node 031] received wakeup notification
2023-09-07T04:54:43.990Z CNTRLR   [Node 031] The node is now awake.
2023-09-07T04:54:45.002Z CNTRLR » [Node 031] Sending node back to sleep...
2023-09-07T04:54:45.031Z CNTRLR   [Node 031] The node is now asleep.
2023-09-07T04:55:13.619Z DRIVER   Dropping message with invalid payload

The first beta was released a week ago but I skipped the August updates and it seems that’s around when the problem started for others.

Ok, so I think by now it’s clear that there is a problem with Zwave at the moment.
I see multiple posts from multiple people experiencing the same thing.

For what I know, the problem was not there 6 weeks ago, because I was 4 weeks on Holiday by then and everything worked perfect.

So, what caused this problem ? I hear some people say it’s a problem of HA, but… in the release notes of HA core I cannot find anything about zwave.
So, Is it in the add-on then maybe ? (I upgraded that one also I think twice) and if yes, would the following be possible/help ?

-Can I revert the add-on version to an older one somehow ?
-Does the Zwave community add-on have the same problem ?

Let me know your thoughts…

Maybe everyone with the issue can also share that here : Zwave · Issue #99736 · home-assistant/core (github.com)

That might help getting attention

There was a Z-Wave JS update (0.1.89) that preceded this issue on my system. If I knew how to revert just that update, I would. (I tried to restore the backup, and it was ugly.) I do not know that the update was the culprit, but it seems rather coincidental.

I’ll restore a snapshot I took just prior to the update. As a rule, I take snapshots before every update I do in Home Assistant.

I’m seeing the same issue. States appear to update correctly, but no actions (turning things on or off) are working.

I’m running 2023.9 and Z-Wave JS UI 1.15.9, and I’m going to try and roll-back a few days - lights, security, etc… this is a major problem :frowning:

I’ve just rolled Z-Wave JS UI back to 1.15.8 for now, and it seems to be working for now, but will give it time. I am now seeing this Zwave Repairs that won't go away · Issue #99491 · home-assistant/core · GitHub though, with constant prompts to update Z-Wave device configurations which do re-interviews and then prompt to do it again.

Because that’s a bug in the version of Z-Wave JS you downgraded to. You can just ignore it, or otherwise you would need to go all the way back to add-on v1.15.5 to avoid it.

2 Likes

Thanks @freshcoast . If I have stable Z-Wave I’m happy for now, will hold off going back to 1.15.9 while I watch for resolution.

This happens with the Z-Wave JS and Z-Wave JS UI addons. (I’ve tried both.)

Same problem here after installen z-wave 1.15.9 and 2023.9 (installed at then same time).
After setting back z-wave 1.15.8 and 2023.8.3 it seems working good again.

Same problems here, inbound OK, outbound not OK :frowning:
Reload of Z-Wave JS UI add-on fix it for a few hours.

Home Assistant 2023.9.1
Supervisor 2023.08.3
Operating System 10.5
Frontend 20230908.0
Z-Wave JS UI 1.15.9
100+ devices

problem seems to be resolved in z-wave js ui 15.9.11