Z-Wave devices stop reporting to HASS

I moved to Home Assistant from SmartThings probably 8 months or so ago. With SmartThings, the Z-Wave devices just worked, but I’ve had zero success getting them working correctly with HASS.

I have a RPi3 using the AIO installer and an Aeotec stick, with all my devices paired to it. I’ve got 1 GoControl Motion/Temp sensor, 2 GoControl Open/Close sensors and 1 EcoLink open/close sensor. The EcoLink sensor is the only one that’s giving me a clean on/off for a door open/close. The GoControl devices are instead giving me combinations of “alarm” codes, which it sounds like I need to create a template for in order to interpret as a binary sensor.

The more pressing issue though is reliability. Immediately after a restart of HASS, I see data pouring into the logbook from all the Z-wave devices. However, within about 24 hours, all Z-wave devices fall silent. I see no further data coming in via the logbook, and the automation I’m trying to have the EcoLink trigger never fires.

Anyone seen anything like this before? Do I have something misconfigured somewhere in my Z-wave setup?

I am seeing something similar… My GE switches will show direct updates for a while then just stop… Tailing the Zwave log I see they are still sending notices but home assistant is not responding.

I resorted to enabling polling for the switches, which at least keeps them in sync but is not fast enough to use for triggers.

Are @BlinkyLights and I alone on this? Anyone else seen this behavior?

I know I installed with the All-In-One installer ~6 months ago, and I’ve made no manual updates to OpenZwave install. Should I be updating that somehow?

@Fresh @BlinkyLights I too have experienced a change in recent HA updates. Some of my Z-wave switches no longer seem to show correctly. All automations and schedules work just fine. If a light is on and I know it is really off, I can flip the front end switch off and back on to manually control the light.

Still experiencing the same issues in .34.4
Haven’t yet had a zwave device continue to report for 24 hours after a HA restart

Same here - I see my zwave switches, I can toggle them on and off, but they don’t poll (i.e. if I turn on a switch manually, its state is not updated in HASS).

Seeing the same problem here.

Same here. The evolve switches report back status on vera perfectly but on home-assistant i can toggle them from UI and they work but when i manually toggle switches they don’t update the status on UI. Any solution. I am using the latest update of HA and all in one install.

did anyone find any solution for it ?

I am seeing instant updates again for the GE switches after my last few updates, I still have polling enabled as I discovered the remote switches in GE three way and a few others simply don’t report status so I need polling regardless.

However that is a different issue than if you previously saw instant updates then they stopped.

I am in process of shifting my devices from vera to HA. Still learning process. The evolve switches were working fine on vera and i was able to see the instant updates in Imperihome ( Software used on android) even if i toggle the switch manually but that’s not the case for HA. It works fine if i do it from HA interface but if i manually toggle it doesn’t update the interface.Am i missing something here. I am polling now at even 5000 and have added my config like -

  switch.evolve_guest_controls_lsm15_wall_switch_switch_5_0:
    friendly_name: Bedroom light
    icon: mdi:switch
    polling_intensity: 1

Anyone else facing issue. Can anyone guide where to look for the issue. I cannot find anything related to this in logs.

HASS 0.34.5 on RPI2B running Jessie light: My zwave devices have disappeared from HASS, I made no changes to the config and in OZWCP everything is up and running. Where do I start debugging this problem ?

I’m having the same issue with my Zwave light switches. They keep getting stuck on in HASS despite the switch being off. Toggling the on/off status in HASS fixes it for a while until the switch is turned on again.

Same issue. Mainly leviton wall switches and a couple aeotec smart switches. Automations work fine, although some lights/switches are reporting on when I know they are off and off when I know they are on. Manually toggling in the front end seems to fix the front end.

I normally use Alexa to control things so this hasn’t really bugged me enough to look into.

Did you just update to 0.34.5? I recently came from 0.29.X up to 0.34.5 and had the same issue. Looked back and it looks like there were some z-wave breaking changes that happened in 0.31.1. The entitiy id’s of all the z-wave items changed slightly and need to be updated in your config, groups, and automations if that is the case.

There is a bug open for this issue #4867

I wonder if this is at all related to the Z-wave issues on the most recent Hassbian install.

On my RPi 2 B+, when installing Hassbian, all appears to be well until you attempt to add zwave to the config file. Surely wasn’t a syntax issue but everything done produced the same bulletin on HASS front-end: zwave config incorrect or what have you.

I’ve given up on Hassbian for the time being as I encountered a couple others experiencing the same issue.

I couldn’t even get the AIO installed on my B+; hit issue after issue, and even after reading a few threads that mentioned fixes, they didn’t help me any, but I was pretty tired at that point and possibly overlooking something simple.

My logging:

16-12-16 15:37:23 homeassistant.components.zwave: Starting ZWave network.
16-12-16 15:37:23 openzwave: Start Openzwave network.
16-12-16 15:37:23 homeassistant.core: Bus:Handling <Event zwave.network_start[L]>
16-12-16 15:37:23 openzwave: Driver ready using library Static Controller version Z-Wave 3.95
16-12-16 15:37:23 openzwave: home_id 0xed7a2023, controller node id is 1
16-12-16 15:37:53 homeassistant.components.zwave: zwave not ready after 30 seconds, continuing anyway
16-12-16 15:37:53 homeassistant.components.zwave: final network state: 5 Driver initialised
16-12-16 15:37:53 homeassistant.components.zwave: zwave polling interval set to 60000 ms

As mentioned before: no problems in OZWCP.

Same issue here. HASS not showing state changes for GE z-wave dimmer switches. If an automation or some external controller (like Alexa) changes the state, HASS dashboard does not reflect the changes. RP3 AOI 0.35.2.