Z-Wave graph (without the python)

I have this bookmarked.

1 Like

Hello, I have downloaded the raw zwavegraph2.html file and put it in my config/panels directory and added the panel_custom lines to my configuration.yaml file but cannot get anything to show up when I click on the Z-wave Graph link in the sidebar of my HASSio instance in Chrome. It works in firefox. Any ideas?

You need to run a network heal or just wait till all zwave devices report.

All the devices have reported. There are just 3 battery devices that are in sleeping mode.

These are aeotec devices. Do I need to change configuration for the reporting?

Came across this thread. Very quick and simple. Took a little while for it to update and get the lines to show up, but worked fine.

I see some people have their graph showing the friendly name. Mine is not. How can I get mine to show them?

Playing around with the panel… new version is now available:

  • you can now pan the graph by dragging it
  • you can now zoom the graph with your mouse wheel
  • the graph initially is scaled to fill the fullscreen width
  • added minimap to visualize which part of the graph you can see at the moment on the screen
  • added 2 more tree layouts (click on the top-legend) - they didn’t necessarily help me make the graph more manageable for me, but may be useful to others in their topology
  • added the ability to show all node connections if someone wants to see the full picture of their Z-Wave mesh
  • fixed the broken new line in the node tooltips
  • you can now click on the node to see the entity dialog

I hope you find this update worthy.


You need to provide a friendly name in Home Assistant… or edit them in the ZW config xml - which is my preferred way.

Hi Adam, where can I get this new version?
Found the link above, https://gist.github.com/AdamNaj/cbf4d792a22f443fe9d354e4dca4de00
Pasted the content into zwavegraph2.html, no new goodies…

1 Like

You need to clear your browser cache.
Assuming you’re using Chrome - Ctrl+Shift+Delete shows the dialog where you can do exactly that.

That helped, thank you! Looks great!

i also updates the html file … cleared brwoser cache completely but no new result… still old pic

Amazing work! I just found this and had it installed in less than 5 minutes. Thanks for putting this together!

If you could try it in the Incognito Mode and:

  • you see the new stuff - that means something went wrong with the cache purging
  • you don’t see the new stuff - which means that something went wrong with the upgrade.

Thank you for the update! This is still my most useful Home Assistant add-on.

I just replaced the HTML file… that’s it right ? Still seeing old graphs

This is SO awesome now! Thank you :grin:

All my z-wave devices have friendly names already.

If I edit the name in the zwconfig will it mess anything up on my devices or will the name just change and everything else in my HA stay the same?

They should stay the same in HA as they are only taken from OZW config if you don’t specify them explicitly.

I’ve checked and I’m already taking the “friendly_name” attribute for the graph. Is it possible that you have provided the names for the sensor entities but not for the z-wave devices themselves?

All of my devices definitely have friendly names. I set them through the UI. Does that make a difference vs setting them in the config yaml?

Very nice, however I’m a z-wave lightweight and have only 4 devices. How can I disable the mini map for now? I have it in a lovelace iframe card and it overlays the main tree.