Z-Wave group association not providing robustness if automation also used

One of my lighting automation goals is for three-way switching to work even of the controller is offline, but also to allow each switch to trigger or react to automations. That way the basic functionality will work almost all the time (hardware fails), while the “fancy” functionality will work most of the time. So I associated an Aeotech WallMote (ZWA022) to an Aeotech illumino dimmer (ZWA037) using Z-Wave JS UI. I am able to turn the dimmer on/off and adjust the brightness by manipulating the dimmer. So far, so good.

Both switches are at the latest firmware. Z-Wave JS UI is at 8.8.4. Z-Wave JS is at 10.7.0. HA is at 2023.2.2. The controller is Zooz ZS10-700 at the latest firmware.

I powered off the computer running Z-Wave JS UI, and I was no longer able to reliably control the dimmer with the WallMote. Sometimes, after a long delay (maybe 30 seconds), the dimmer responded. Often either I lost patience, or it never responded. Aeotech’s support (which has been great, by the way) told me that the behavior is to be expected. The WallMote sends commands to the controller first. Once the controller responds, it sends commands to the group-associated device. More precisely, the WallMote has two associations. The first listed is to the controller. The second is to the dimmer. They suggested that I remove the association with the dimmer. That’s a poor fix for me, since I want to use the WallMote to control other devices via Home Assistant (not via direct association, as that is not always possible).

So I deleted the association with the controller and added it back in, hoping it would appear as the second association. But it displayed first. And the WallMote wouldn’t communicate with the dimmer or the controller (it flashed red when pressed).

My next step was to remove the association with the controller. At that point, the WallMote controlled the dimmer as suggested by Aeotech support.

I’m hoping that someone can tell me either:

  1. That’s just how Z-Wave associations work. You can’t have both robust behavior and automations with the same switch.
  2. This is a limitation of the Aeotech switches. Other switches send commands to all associated devices before waiting for responses.
  3. Here’s how to get both robust behavior and automations with the Aeotech switches.

Thanks in advance for any information or suggestions!
Larry

What group are you assigning the dimmer to? If Group 1, that is the lifeline group, which is typically dedicated to controller communication.

1 Like

This is not my experience with direct association. I have two Zooz ZEN32 remotes, one associated with two Zooz ZEN73 switches and the other associated with a Jasco switch-- in my testing both are instantaneous when Home Assistant is turned off. I’m using the Zooz ZST10 500 series controller.

Maybe worth mentioning both are set for Group 2 on/off. I have not used the Group 3 dimmer control.

1 Like

The dimmer is assigned to Group 1 (Lifeline in the UI). Must I also assign it to something else? My (very possible incorrect) understanding is that only the controlling device, the WallMote in this case, must be assigned to a different group.

You shouldn’t assign the dimmer to Group 1, that seems to be the crux of your problem. In general, only the controller should be assigned to that group (older devices don’t standardize on the groups). In fact, if you had an older version of a WallMote (non 700), it only supports 1 node in that group.

You should assign the dimmer to the appropriate groups, which are 2 through 7. Groups 3, 5 and 7 are dedicated for multilevel switch (dimmer) control.

However, whether this works well or not depends on whether the device still waits for confirmation from the controller, then sends the commands to the other groups.

1 Like

Mine are set for Group 9, which is ca combination of on/off and dimmer control.

Is control instantaneous if the computer running HA is powered off? I ask because if I stop HA and Z-Wave JS UI, but do not remove power from the Zooz controller, control remains responsive. I assume the controller is able to acknowledge the message by itself.

I won’t swear to it, but I think control is faster now that the WallMote has no association with the controller. There was a very small, but noticeable, delay previously.

According to the Z-Wave JS UI’s UI (two UI’s in a row, huh), all of my devices are assigned to the lifeline group. I think if I assign the dimmer to a different group, then won’t the controller ignore dimmer state changes (keypress, 2x, etc.)? If so, then I cannot trigger automations base on pressing the dimmer paddle in various ways.

No. But since you removed the controller from the lifeline, it won’t receive those events.

1 Like

This doesn’t make any sense. Do you have a screenshot of what you are referring to?

Sorry, I don’t understand. I didn’t remove the controller (the Zooz Z-Wave controller) from Group 1. I removed the WallMote from Group 1. I didn’t want to do that, but it seemed like the only way it would controller the dimmer in the absence of a working controller.

Screen shots below. Weirdly, there’s no indication that the controlled device is the dimmer.

I included a screenshot in a different reply. Thanks BTW!!

For node 100 you should have:

  • Node 1 in the Lifeline group
  • Node 103 in the Multilevel set groups. I am guessing you want “Top/Bottom Button Multilevel Set”, but the Aeotec docs are useless in describing these.

There’s no reason to have node 1 in group “Top/Bottom Button Multilevel Set”. The lifeline takes care of all messages for the controller.

1 Like

I want to say that’s exactly the configuration I had before I removed the association between Node 103 and the Lifeline group. The UI is showing, for node 100:
Endpoint=“Root Endpoint”
Group=“Top/Bottom Button Multilevel Set”
Node=“NodeID_1”
Target Endpoint=“None”

I wonder if there’s a UI bug, since the node I configured to control is node 103. But it shows Node=“NodeID_1”, not Node=“NodeID_103”. You wrote:

There’s no reason to have node 1 in group “Top/Bottom Button Multilevel Set”. The lifeline takes care of all messages for the controller.

Is that because you saw Node=“NodeID_1” in the screenshot?
Thanks,
Larry

I am assuming “NodeID_1” is your controller, in 99% of cases this correct. Is that the case? Controller automations can be done with Central Scene events, as long as it’s associated with the Lifeline group. If you disable central scene (set param 1 to value 0) then you could associate the controller to the Multilevel groups instead and automate with the Multilevel Switch commands instead. Most people use Central Scene.

As the WallMote is a battery device. Be sure to wake it up (7x tap on the “action button”) to apply any group assignments.

NodeID_1 is the controller, but the association I created was to node 103, not node 1. So I don’t know why Z-Wave JS UI is reporting that the association is with node 1. Also, if the association were with node 1, then node 100 would not be controlling node 103 – but it is!

I did do the 7x tap to wake up the WallMote.

BTW, I just tried associating the dimmer with another dimmer. In that case, the Node column gave me the correct ID (actually, the correct name) for the other dimmer. So something is amiss. As I wrote above, I have no idea how node 100 can be controlling node 103 if it’s not associated with node 103.

I’m going to factory reset the WallMote and start over.

Thanks again for your help.

I excluded and reset the WallMote. Then I added an association with node 103:

This looks better (that is, correct). However, I am back to my original problem. If I remove power from the controller, then the WallMote (now node 112) no longer controls the dimmer (still node 103). So – is this the expected behavior or is it a problem with the Aeotec WallMote?

Thanks,
Larry

It seems like Aeotec already answered your question? It sounds like an intentional design, albeit very peculiar. Association is designed for hub-less usage, after all.

That doesn’t mean all Z-Wave devices act this way, as evidenced by the comment about the Zooz ZEN32.

Have you tried setting parameter 1 to “Group association only”?

1 Like

Aeotec did answer my question, but I am still not certain the answer applies only to the WallMote, all Aeotec devices, or all Z-Wave devices. The comment about the ZEN32 is not conclusive. We know that HA was not running, but we don’t know if the controller was powered on.

I have not tried setting parameter 1 to Group Association Only. I will try it (thanks), but I suspect that means double tapping and other actions won’t be handled by the controller – although the controller and the WallMote are associated. So maybe it will work.

I’m not confident there is a definitive answer. AFAIK, this behavior you are observing is not specified by the Z-Wave standard anywhere. My guess would be that it comes down to the individual device implementation.

True, that sure does depend on what was meant by “Home Assistant turned off”. Hopefully they will confirm.

You can also associate the controller to that group, and it will receive the Multilevel Switch commands as events, instead of Central Scene. But who knows how the device will act with two devices associated, will it have the same problem?

1 Like

Agreed on all points. I set parameter 1 to Group Association Only. As I am sure you expected, and as the parameter is documented, I could no longer send central scene commands. And when I powered off the controller, the WallMote no longer controlled the dimmer reliably (it was better than when parameter 1 was set to Both, but it took several seconds to change the state of the dimmer – if at all). For now, I removed the group association of the WallMote with the controller, as suggested by Aeotec. It works well, regardless of whether the controller is on or off.

Associating the controller with the group would help in some scenarios, but not this one. For example, I often want to control a different light with the same switch, and I don’t necessarily want both lights on at the same time.

In any case, I really appreciate the time you took to help me.
Larry