Z-Wave is driving me crazy: two issues, naming and graphs

Hi,

I got 2x Fibaro Motion Sensor and I added both of them as secure devices. This was working without issues. I can see both devices in home assistant.

Then I renamed the nodes in the Z-Wave Section of Home Assistant Frontend:

  1. One Sensor got the new name and all sensors were renamed
  2. The other sensor got also renamed, but all sensors stayed with the old name

image

image

image

The second issue I have is with the graphs. I added both temperature sensor to a group, but only one is shown as XY-Graph the other one only as a bar…

image

history_graph:
  dach:
    name: Temperatur Dachzimmer
    entities:
      - sensor.kinderzimmer_dominik_temperature
      - sensor.fibaro_system_fgms001zw5_motion_sensor_temperature
    hours_to_show: 72
    refresh: 300    

_

group_Dachfenster:
default_view:
  view: yes
  name: Dach
  entities:
    - group.group_Dachzimmer_Graphen
    - group.group_Dachfenster_All
    - group.group_Dachfenster_West
    - group.group_Dachfenster_Ost
    - group.group_Dachfenster_Mitte
    - group.group_Dachfenster_Automation

group_Dachzimmer_Graphen:
  name: Dachzimmer Temperatur
  view: no
  entities:
    - history_graph.temperatur_dachzimmer

One step ahead. Somehow the node entities in the Z-Wave config got now renamed, but the entities in Home-Assistant have still the old name…

Hi,

For renaming zwave devices us this:
https://www.home-assistant.io/docs/configuration/entity-registry/
Just edit entity-registry.yaml and restart HA.

Add units I your temperature sensor to get it to show as a graph.

unit_of_measurement: C

Add that to customization or the configuration itself. With out it, the graph is treating the result as a string instead of a number, which is why you get the bar and not a graph

Thanks, I have done this now.

But I am still wondering, why that worked automatically for one sensor, but not for the other one…

Br,
Johannes