Z-Wave JS UI: Home Assistant section: Server Host vs Server Port

I’m posting this to help anyone else who may be struggling with this. I was having a terrible time getting this to work and I read a ton of forum messages, and I hate to admit over several days but I finally had a breakthrough.

When I get to the step to configure the Z-Wave “Integration” I was careful to follow the step: UNCHECK “Use the Z-Wave JS Supervisor add-on” (!!!CRITICAL!!!) and the step to Enter ws://a0d7b954-zwavejs2mqtt:3000 as the URL (copy and paste the exact URL listed here, do not include any whitespace!) and click SUBMIT.

I tried a mess of different things but every time I would get the response Failed to Connect!

But the problem wasn’t here; It was elsewhere…
There are four fields in the Home Assistant section on the Z-Wave JS UI SETTINGS page: WS Server, Server Port, Server Host, and Disable DNS Discovery.

I don’t know why I didn’t see this until today but the Server Host field here is Optional! It’s not until you click the field that you see the comment that it’s Optional. I know I probably pasted “ws://a0d7b954-zwavejs2mqtt:3000” into this field a zillion times. But that’s for a later step, when you configure Z-Wave Integration. Leave it blank!

The Server Port field however is Required; Obviously it needs to be 3000.


You don’t need to configure anything, including the port, when using the add-on. Everything is setup for you, aside from the USB device path and security keys.