Z-Wave Unkown Device after update (Vera)

Hi all. I’ve been having an issue since updating to V0.54 and hass.io to 1.1. The values of the secondary sensors from an Aeotec 6 in 1 sensor show up as “Unknown” in the sensor bar at the top of the screen. The names of the sensors are correct. Humidity, temperature etc… however the values just show as unkown. They worked before the update. The motion sensor indication works from the same sensor.

I’m using a VeraLite for the Z-Wave devices currently.

I’ve tried:

  • Unpairing/reparing the sensor in Vera with HA restarts in between. The devices all disappear and reappear when they should, but no change.
  • Removing Vera module from ha config, restarting, adding Vera module, restarting. Same result

Any other suggestions? ta

2 Likes

I have the same problem. I had to downgrade to 0.53.1 to get my vera sensors working again. I think it is a bug in the 0.54 release - at least there are one reported on github https://github.com/home-assistant/home-assistant/issues/9577

Ahh. Thanks. Good to know I’m not crazy.

Is it possible to downgrade from hass.io?

I have the same problem on Ubuntu Server 16.X running hass in screen.

It is doing it with the multi sensor and the HE monitor. (both Aeotec)

image

image

Other devices are working fine. I dont see anything in the logs.

At this point upgrading to dev 0.55 did not fix it. Rolling back to 0.53.1 did.

Looks like this issue was introduced in the latest pyvera update, it’s being worked on here: https://github.com/pavoni/pyvera/issues/73

1 Like

Looks like this is mostly fixed in the latest update. All of my 6in1 sensors are back online except the UV which still says unknown.

I might have a quick fix for that. Would you be comfortable building homeassistant from a branch to test a change?

I haven’t looked into how to do this at all yet. Is it possible if running hass.io? Anyway, I’m not too concerned about the UV sensor anyway. Just thought it was worth noting. ta

I pushed a fix that should resolve it to dev, so you’ll see it in the next release.

I still have this Sensor issue not showing in Hass …running latest Hass and latest Vera firmware

https://hastebin.com/lohisegaya.json