Z2M on x86 problematic?

quick background: I have two devices running HA. One as a test system, that I use in my current apartment and one that I did a “clean” install on that I want to use in my house (being built).

The “test” unit is a Odroid N2+ with a Conbee II stick.
The “house” unit is an Lenovo ThinkCentre M625q with an AMD A9-9420e 7th Gen. CPU. This device uses a Sonoff Stick (P-edition). (I was operating under the impression that this setup would be better / more powerfull than the N2+ with the conbee 2 stick; wrong assumption?)
I’ve tried putting a USB extention cable between the computer and the stick - this did not impact the problem.

What’s the problem: I have a inwall dimmer unit . I had it connected to the “test”-device through ZHA. that worked like a charm.

I then wanted to repair it with my “house”-device through z2m. This did not work. I’ve tried repairing it multiple times. No luck. Essentially sometimes it does not recognize that a device is trying to pair. Othertimes it’s trying to interview the device but doesn’t succeed (sometimes it knows what device it’s interviewing, othertimes it just shows the device’s “name” alongside the zigbee-logo).

However, when I try to pair the dimmer with my “test”-unit (also using z2m) this works without any hickups.

I’m kinda at a loss here.

Right now my workaround is to use my N2+ with the conbee 2 stick as a mqtt server - run everything through there and point mqtt on my “house”-unit to the n2+'s mqtt/z2m addon.

That seems to work well. And that might bring an added layer of safety in case my Lenovo “house”-unit decides to die (then the zigbee network would still be up and running).
But it’s a hassle.

Anybody have any ideas?

I’d post code / log info, but I can’t find any log entries that seem to indicate anything with reference to this issue.

Thank you!

Sad to see that tou didn’t have any replies.

I was thinking of getting a Lenovo ThinkCentre M625q to run home assistant as well. Do you still believe its a problem with the mini PC or its CPU?

1 Like

Honestly, I have taken this and have decided to use this mistake to implement another “best practice”.

I’m just continuing to run the “workaround” (you know - the best temporary solutions become permanent).

I am keeping the sonoff stick just so that if in a pintch I could add a device through ZHA direct to the Lenovo-HA-instance.

1 Like