ZHA Blitzwolf SHP15 not showing up in Energy dashboard

Hey,

I have recently bought a Blitzwolf SHP15 as I was searching for a reliable and fast ZigBee smart plug, which gives me accurate readings for the Energy dashboard. After setting it up, the total_increasing kWh sensor was populated and contains the correct classes and properties:

However, i am still unable to select the device for the Energy dashboard after a few days.

Does anyone spot the issue or might have an idea, what I could try to fix it?
Thanks a lot in advance,
Cludch

Attributes are there and seem correct. Is the sensor included in your history/recorder (in case you have excludes defined)?

Does ZHA not expose a sensor itself for kWh?

1 Like

Oh my… thanks a lot!
I had a recorder exclusion rule for energy back from the days when I tried to exclude all battery stats.

And yes, the sensor itself is exposed from ZHA, which is why I wondered why it doesn’t work out of the box.

Ah there you go! :slight_smile:

Hello,

Another question about the ZHA and Blitzwolf SHP 15, all seems to be ok.
But if I turn the device on/off (on the device itself) Home Assistant wont register it. Other way around, switching in Home assistant, does turn the device on/off.

The Blitzwolf SHP 15 shows up as:
model": “TS011F
device_type”: "0x010a

“node_descriptor”: “NodeDescriptor(logical_type=<LogicalType.Router: 1>, complex_descriptor_available=0, user_descriptor_available=0, reserved=0, aps_flags=0, frequency_band=<FrequencyBand.Freq2400MHz: 8>, mac_capability_flags=<MACCapabilityFlags.AllocateAddress|RxOnWhenIdle|MainsPowered|FullFunctionDevice: 142>, manufacturer_code=4098, maximum_buffer_size=82, maximum_incoming_transfer_size=82, server_mask=11264, maximum_outgoing_transfer_size=82, descriptor_capability_field=<DescriptorCapability.NONE: 0>, *allocate_address=True, *is_alternate_pan_coordinator=False, *is_coordinator=False, *is_end_device=False, *is_full_function_device=True, *is_mains_powered=True, *is_receiver_on_when_idle=True, *is_router=True, *is_security_capable=False)”,
“endpoints”: {
“1”: {
“profile_id”: 260,
“device_type”: “0x010a”,
“in_clusters”: [
“0x0000”,
“0x0003”,
“0x0004”,
“0x0005”,
“0x0006”,
“0x0702”,
“0x0b04”,
“0xe000”,
“0xe001”
],
“out_clusters”: [
“0x000a”,
“0x0019”
]
}
},
“manufacturer”: “_TZ3000_u5u4cakc”,
“model”: “TS011F”,
“class”: “zhaquirks.tuya.ts011f_plug.Plug”
}

all my other devices Blitzwolf SHP 13 are working correct and show up as model: TS0121

Can somebody verify my findings? thanks in advance.
Regards Frank

Suggest that you repost question here too → https://github.com/zigpy/zha-device-handlers/issues/605

Read here → https://www.home-assistant.io/integrations/zha#zha-exception-and-deviation-handling

Hello Hedda

Thank you for your suggestion, post my question in the zha-device-handlers section and got an reaction already. They are investigating my issue…

Regards and Thanks,
Frank