ZHA integration radio device keeps reverting to Skyconnect after migrating from Skyconnect to Sonoff

Hello,
I had a ZHA integration setup that was created right after plugging Skyconnect using the device discovery prompt. Then later on for unrelated reasons, I bought another Zigbee dongle(Sonoff Dongle P) and executed migration on my existing ZHA integration. I also renamed my ZHA integration from Skyconnect 1.0 to something else. This setup (if left alone) is currently working fine.

The problem happens when I want to repurpose my Skyconnect and create a thread border router setup with it. After flashing the Skyconnect with thread only firmware and plugging it in I notice my existing ZHA integration radio device immediately reverting back to Skyconnect, causing my Zigbee devices to fail. Even if I configure open border router integration and reconfigure ZHA integration to use my Sonoff, it keeps reverting to Skyconnect right after restart. However it works when I:

  • reconfigure my ZHA integration with Sonoff as the radio device and select keep existing network settings option.Until the next restart it works fine ZHA with Sonoff and Thread with Skyconnect
  • unplug my Skyconnect reconfigure ZHA one last time.

So to summarize I cannot plug both Sonoff and Skyconnect at the same time because my existing ZHA integration(originally created using Skyconnect) radio device setting reverts to Skyconnect. This is rather inconvenient for me because I would like to use my Skyconnect as a thread radio and keep using Sonoff for ZHA, even after restart without doing reconfiguration

Anyone else experienced similar issue? I would like to fix this hopefully without deleting my current ZHA integration.

I’m having an identical problem only with a Sonoff Dongle E and Dongle P. I even got them to work in ZHA/Thread correctly but on restart ZHA reverts to trying the wrong one again (the E using OpenThread.) Did you ever find a solution? Did recreating your entire ZHA network from the ground up resolve the issue?

Did you try to flash your Skyconnect with Thread only firmware ?

I ended up redoing my entire Zigbee network and that solved the issue for me. I installed the zbdongle-p as the Zigbee coordinator, then the zbdongle-e as a Thread boarder router and then readded all my Zigbee devices to ZHA. There just seems to be some issue with ZHA remembering old coordinators and prioritizing them as the coordinator if you plug them in while a different coordinator is running, even if they are running incompatible firmware.

Yes I did.