ZHA radio_type: ti cc not working after restart

the new integration in home assistant, ZHA using the CC2531 radio_type: ti_cc, all works great, it discoveries de devices but then for some reason when you restart homeassistant all devices are gone from ZHA, any toughts?

i have found de falling errors

[homeassistant.config_entries] Error setting up entry /dev/ttyACM0 for zha
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/config_entries.py", line 215, in async_setup
    hass, self
  File "/usr/src/homeassistant/homeassistant/components/zha/__init__.py", line 103, in async_setup_entry
    await zha_gateway.async_initialize()
  File "/usr/src/homeassistant/homeassistant/components/zha/core/gateway.py", line 137, in async_initialize
    await self.application_controller.startup(auto_form=True)
  File "/usr/local/lib/python3.7/site-packages/zigpy_cc/zigbee/application.py", line 64, in startup
    self.version = await self._api.version()
  File "/usr/local/lib/python3.7/site-packages/zigpy_cc/api.py", line 206, in version
    version = await self._command(Subsystem.SYS, "version", {})
  File "/usr/local/lib/python3.7/site-packages/zigpy_cc/api.py", line 84, in _command
    return await self.request(subsystem, command, payload)
  File "/usr/local/lib/python3.7/site-packages/zigpy_cc/api.py", line 88, in request
    return await self.requolha
	st_raw(obj, expectedStatus)
  File "/usr/local/lib/python3.7/site-packages/zigpy_cc/api.py", line 105, in request_raw
    result = await waiter.wait()
  File "/usr/local/lib/python3.7/site-packages/zigpy_cc/api.py", line 35, in wait
    return await asyncio.wait_for(self.future, self.timeout / 1000)
  File "/usr/local/lib/python3.7/asyncio/tasks.py", line 449, in wait_for
    raise futures.TimeoutError()
concurrent.futures._base.TimeoutError
1 Like

Same here. Did you found a solution?

Seen that sanyatuning just released v0.2.2 of zigpy-cc which could potential have some fixes

https://github.com/sanyatuning/zigpy-cc/issues/19

That does not yet come with HA/HASSIO so you would have to manually update the package yourself.

PS: According to HA changelog there are also some other general ZHA fixes in upcoming 0.107 beta

Has anyone got the 0.4.0 release of zigpy-cc working?