ZHA Zigbee Tested Devices...Please add your device results


#544

hello, thanks for the answer . i checked the switch and it is in off position. it is very odd because like i said before the unit is recognized and paired but once an event is triggerd never go back to off

how this works for you? i mean , how offten temperatura and light levels are updated?

P.D. i use Elelabs Zigbee Raspberry Pi Shield


#545

it works great… All 3 sensors work correctly. The only problem I have with the sensor is how large it is.


#546

thank’s for your help … i will keep trying


#547

Does anyone know if there is a way to force a heal/rebuild of the zigbee network similar to how its done with zwave?

I moved a device and now I have a different device that keeps dropping off. Ironically it’s the closest device and had the strongest RSSI of all my zigbee devices…


#548

Pretty sure zigbee does this on its own.


#549

You need to take your controller offline for fifteen minutes to trigger path reselection.


#550

Was anyone able to get the zwave repeater added successfully for the Iris 3210-L Plug. I’ve been using them for zigbee for a while but did not realize they had a zwave repeater that required adding them as a node. They add for me, but show as

Unknown: id=0246 Unknown: type=0001, id=0001 (Node:124 Complete)

Might be working as a repeater, might not. Not sure? It does not show any entities, so I’m going to guess not working, but any info would be apprciated


#551

I’m getting Template sensor zigbee_offline has no entity ids configured to track nor were we able to extract the entities to track from the value template(s). This entity will only be able to be updated manually. in hass log, when I define zigbee_offline template sensor. Do you get your template sensor automatically updated? I’m on 0.82.1

BTW instead of defining a group of all zigbee devices you could get a list or iterate over states.zha eg something like {{states.zha|selectattr('state','eq','offline')|list }} just to keep less things needing updating.


#552

Did you add your zha. sensors? The error “This entity will only be able to be updated manually” is what happens when the sensor template does not have have an entiry to trigger an update?

That might be from iterating as you mention. If that’s the case you’ll need to define an entiity(s) in your sensor.

since you’re not listing the entities, maybe use

entity_id: sensor.time

#553

ah, nevermind. it’s a layer 8 problem. added zha entities, instead of state.zha_entity


#554

Can I add a new zigbee device myself?

I have a zigbee switch but I want to register it separately.


#555

I’m not sure what you are asking, can you provide more details?


#556

@ptdalen

I am not good at English, so please understand my words even if they are awkward.

When I use ZHA to pair Lights, there is no Level in my Light but a Level is created in Hass.io
And I paired Motion but did not get Binary Searsor.
The Zigbee equipment I use seems a little different from the one registered in ZHA, but I wonder if I can’t custom this part myself.


#557

so you are having issues with zigbee lights and motion sensors

So your lights do get added but do not have the option to dim (level)
Are you sure the lights are dimmable?
and your motion sensors do not have a binary sensor for motion (on/off)

What sensors do the motion sensors have? Temperature?


#558

@ptdalen

I don’t think my words went well with you.
My light has no dim option.
Nevertheless, there is an unknown sensor.
The xiaomi motion sensor requires motion and illumination, but nothing has been created for me.

I’ll change the question.
My light switch was recognized and the value did not change when operated at local.
I changed the type of device to ‘switch’ and checked for a change in value.

1

The problem is ‘binary_sensor’ as shown in the picture below.
I don’t know how to change the type of this.

3

Because my light switch is three-gang, I was recognized as three switches and modified device_config as shown in the picture below.
I wonder if the above ‘binary_sensor’ can be modified in this way.

2

In summary, I wonder if there is a way to force HA to recognize a ‘cluster’ value that it does not recognize.


#559

Are you using Zigbee or Zha platform? Can you remove sensitive data and provide your configuration.yaml?


#560

@Quatuor

I am using a zha platform.

Attached is a zigbee.yaml file that stores my configuration.yaml and zha device_config.

configuration.yaml (3.6 KB)
zigbee.yaml (735 Bytes)


#561

Are you defining your devices as a switch? If so you will only get on/off. They need to be a ‘light’ to support dimming.


#562

@drjared88

Thank you for your answer.

But what I want is not dimming.

I want to process all the data on a zigbee device into the type of data I want.

For example, I want to change the type of ‘binary_sensor.zha_0c13f16e_1_6’ to sensor.


#563

I’m afraid it doesn’t work that way. That binary sensor is most likely a “client On/Off cluster” on your zha devices, so zha platform mapped it to “binary_sensor” since binary sensors are used for entities with “binary” states, like On/Off, Open/Closed etc

Post the output of bellows devices and explain “what are you trying to achieve”, then we might figure something.
For xiaomi motion/luminosity sensors I don’t think the quirks were merged into upstream yet, so out of the box those probably won’t work, but @dmulcahey has something in the works to address it.