ZHA Zigbee Tested Devices...Please add your device results


#604

Ok, Maybe the part I am looking for isn’t implemented yet. I see the centralite switch on/off state but I don’t seem to see the actual button press. Before I was seeing them as a zha_event. Should I be seeing those or is that part yet to come?


#605

First I would like to thank for your valuable work here! It has helped me out to get a pretty nice home automation using this Zha-environment with:

RPi/Elelabs ZB Shield/Hass.io/Hass.OS/HA 0.85.1. I have successfully paired 28 devices: Ikea Bulbs, Osram Plugs and Motion sensors, Xiaomi Temp/Hum/Press-; Water leak-, Door/Window-, Human Motion sensors ….

This latest 0.85.1 Update solved almost all the problems I had. Many already working devices got even more features – now I got also for example battery status populated.

So many thanks for your work here!

Couple small issues still exists – I get few of these:

Unexpected response TSN=233 command=1 args=[[<ReadAttributeRecord attrid=1291 status=0 value=28000>]]

12.33 util/async_.py (WARNING)

Unexpected message send notification

12.33 util/async_.py (WARNING)

They must be related to Osram Smart Plugs and power (wattage) measurement. Which does not show the right value. Zigbee.db shows:

Osram smart motion sensor shows entity for battery status but it is unknown.

I have also googled the limitation for number of devices - with no result. Any Idea how many can be paired (Is one device here one ieee address or the number of entities behind that ieee address?)

And finally – I think all the devices are directly connected to my coordinator. Can you use CC2531 with router firmware as a router in ZHA environment, does it work?


#606

Some of those warnings will always be there, depending on network complexity some responses might be delayed which is causing those warnings.

the screenshot is for the zigpy attribute cache data and doesn’t really map to number of the supported devices. One IEEE is one Zigbee device, but one zigbee device have multiple HA entities (at least two: zha. and component entity)

ATM all devices join through coordinator. Any(not Sengleds) Most mains powered devices are Zigbee routers, so once joined through coordinator (need to be close to coordinator for the initial join) they are going to establish mesh connections.
Mostly all battery powered devices are Zigbee end devices -> they need a “parent” router device to communicate. ATM it is going to be the coordinator. Properly implemented zigbee end devices may choose a different parent, it they don’t hear from their parent for a while. Xiaomi end devices are picky about their parent devices. There’s a link on Habiutat forum keeping a list of routers working ok with Xiaomi devices.
So to answer your question:

  • You can use CC2531 as a router, but ATM there’s no way to force Zigbee end devices to join through it, as only coordinator is opened for new joins
  • as about limitation in number of devices, there’s probably a practical limit and number of end devices joined directly to HUSBZB is limited to 32. waiting on a new version of zigpy & bellows gets pushed to PyPi to improve the limit by allowing other routers accept new end devices
    Currently I’m running counting about 65 zigbee devices and most issues I’m having are caused by Xiaomi.

#607

Thanks a lot for a very quick response!


#608

Okay I skimmed the thread and it seems at one point they didn’t work but I also saw there was a few PRs for zha recently but does any one know if the Bosch motion sensors ( ISW-ZPR1-WP13 ) work?

I have some of them connected via smartthings right now along with some sengled lights (which I believe work with zha) and I’d like to move it all over to being directly controlled if it all works.


#609

not with stock zigpy and bellows libs. Need to install github master tree for zigpy and bellows.


#610

Hi,
This is a long thread and I tried to find my answer about the Hue sensors and husbzb-1, but couldn’t find my scenario or question.

I was able to easily pair 4 of them and setup automation using the motion and light sensors. They worked great for about a day and then started to go offline. I reset and reconnected them few times but they keep going offline. I am considering getting a few 45853GE plugs to use as a repeater to hopefully fix this issue. Does anyone know if repeaters would work with these sensors? Or if they know how to make them to stop going offline? Any help would be greatly appreciated. Thank you.


#611

I sure understood this - basically I meant that when we talk about limitations of device number are we talking about device as per one ieee or entities behind that “device” (My Osram 4 way dimmer has 8 entities) So 4 of those would make 32 entities :wink:

Help Please Anyone - I did not find this link? I will buy those Ikea Trådfri Smart Plugs for test in couple weeks when they arrive - 10 €/pcs - they are ZigBee 3.0. So they might work as routers?


#612

@tosion my bad, was writting base on memory. it is a hubitat forum


#613

The warnings can be ignored


#614

Many Thanks!

BTW is there a possibility if I just wait and relax maybe one day with some update I will see that real power consumption for those Osram Smart+ plugs (now only 40W and 2800W)? Or maybe also the battery status for Osram Smart+ motion sensors, now it is unknown but the entity is there.


#615

So I’m running Hue bulbs, GE bulbs, Sengled bulbs, and CREE bulbs. Can’t get the CREE to connect. All others do. Transitions don’t seem to work. Hue bulbs will turn on with transition time but not off. Other bulbs do nothing.

Can anyone else confirm that the GE and Sengled bulbs don’t support transitions or is this something to do with ZHA?

Thanks!


#616

@techoguy do you mean transition to turn off or transition to turn on? “Turn Off transition” was added in 0.85, but the bulb must be dimmable to support transition.
What I can confirm, color Sengled bulbs do not support transition on color change (meh, go for Osram???).


#617

@Quatuor thanks! I’ll upgrade and try again. All the bulbs I’m using are dimmable. Should the Sengled support transitions just to turn on or change the dim level, or they don’t support it at all?


#618

Sengled do support transitions. I have it working. I use both transition parameter and also brightness_pct. One thing I noticed - if the light was at full brightness and turned off, when turning on again and using transition, the light will be at 100% brightness right when turned on. I need to lower the brightness to 0 then turn it off. Then when turning on again, the transition will start from 0. Oddly enough I use light.turn on to set the brightness to 0.


#619

I meant color transitions. With two color bulbs running the same automation transitioning to a random color over 3s, Sengled jumps to the new color immediately and a non sengled bulb smoothly transitions to new color.

For the brightness thing, could you try setting the brightness to 254 (not 255, but 254), turn it off and then turn it on with transition?


#620

Ah my bad; Yeah I’ve only used non-color bulbs.

I’ll give using the brightness parameter (vs brightness pct) a shot tonight when I’m back home.


#621

okay i tested this some more. You’re right if the bulbs are off it ignores the transition but if the bulb is already on, it will transition to the new brightness settings. So if I send “on” first with brightness set to 0, then send “on” with brightness set to 100% and transition to 20 seconds, it works as expected. I can also turn the bulbs off by transitioning to 0% then issue the “off” command to set them off. If you don’t issue the “off” command HA still shows that the bulb is on even though it’s not (this might be a bulb thing). But either way, transitions do seem to work with the GE bulbs and Sengled bulbs just not how I expected them to.


#622

Has anyone had any problems with zha component lately? I noticed that my Xiaomi temp sensors were not updating anymore so I tried to remove them and add them again. But this was not succesful. Eventually I deleted the zigbee.db and tried to add devices again but I only get this error:

2019-01-20 11:01:44 WARNING (MainThread) [bellows.zigbee.application] Unexpected response TSN=8 command=266 args=b'\x00\x00)\xca\t'
2019-01-20 11:01:44 WARNING (MainThread) [zigpy.endpoint] [0xdc10:1] Message on unknown cluster 0x0402

And the devices do not appear in HA. I searched the topic but could not find any answer to this…

I have HA 0.85.1 installed

Edit: This is the real error message when pairing

2019-01-20 11:10:45 DEBUG (MainThread) [bellows.ezsp] Application frame 69 (incomingMessageHandler) received
2019-01-20 11:10:45 ERROR (MainThread) [bellows.ezsp] Exception running handler
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/bellows/ezsp.py", line 194, in handle_callback
    handler(*args)
  File "/usr/local/lib/python3.6/site-packages/bellows/zigbee/application.py", line 139, in ezsp_callback_handler
    self._handle_frame(*args)
  File "/usr/local/lib/python3.6/site-packages/bellows/zigbee/application.py", line 160, in _handle_frame
    tsn, command_id, is_reply, args = self.deserialize(device, aps_frame.sourceEndpoint, aps_frame.clusterId, message)
  File "/usr/local/lib/python3.6/site-packages/zigpy/application.py", line 73, in deserialize
    return sender.deserialize(endpoint_id, cluster_id, data)
  File "/usr/local/lib/python3.6/site-packages/zigpy/device.py", line 97, in deserialize
    return self.endpoints[endpoint_id].deserialize(cluster_id, data)
KeyError: 1

And another one I found from logs:

2019-01-20 11:10:52 WARNING (MainThread) [bellows.zigbee.application] Unexpected response TSN=2 command=32772 args=[<Status.SUCCESS: 0>, 35522, <SimpleDescriptor endpoint=1 profile=260 device_type=24321 device_version=1 input_clusters=[0, 3, 25, 65535, 18] output_clusters=[0, 4, 3, 5, 25, 65535, 18]>]
2019-01-20 11:10:52 DEBUG (MainThread) [zigpy.zdo] [0x8ac2:zdo] Unexpected ZDO reply 0x8004: [<Status.SUCCESS: 0>, 35522, <SimpleDescriptor endpoint=1 profile=260 device_type=24321 device_version=1 input_clusters=[0, 3, 25, 65535, 18] output_clusters=[0, 4, 3, 5, 25, 65535, 18]>]
2019-01-20 11:10:53 DEBUG (MainThread) [bellows.uart] Data frame: b'415ab157546f15b658964e24ab5593499c6cd97e2f449874f5de6783fc7e167be2cfdd5b7e'

Edit: The pairing was solved, I found from Github that the Xiaomi sensor go to sleep too quickly. So I was able to pair them by pressing the button for the whole time it was pairing with zha.

Will monitor if the sensor update their status which was the main problem


#623

It does seem that tha Xiaomi sensor are no longer updated with the zha component for me. They work for a little while after the pairing but will stop and reboot sometimes updates the state but not always.

All the sensors were working fine until yesterday. There are no errors after the updating stops.

Has anyone noticed this behaviour?