ZHA Zigbee Tested Devices...Please add your device results


#624

Did you ever find a workaround for this? I too have this device and it’s driving me crazy.


#625

Can you post bellows devices for the smart plug?


#626

Means the xiaomi device was not fully discovered. run zha.remove service with {"ieee_address": "ieee_address_of_xiaomi"} data to remove it. Give it about 15s before factory resetting xiaomi and joining it again. Make sure it is quite close to the stick during joining time. Currently all xiaomis are using HUSBZ as their parent device, but if the signal is week it may roam to another router and xiaomi are picky about their parent device. They work fine with some, but not the others.


#627

here you go:

Device:
  NWK: 0xff75
  IEEE: 00:0d:6f:00:05:85:56:05
  Endpoints:
    1: profile=0x104, device_type=DeviceType.ON_OFF_LIGHT
      Input Clusters:
        Basic (0)
        Identify (3)
        Groups (4)
        Scenes (5)
        On/Off (6)
        Electrical Measurement (2820)
        Diagnostic (2821)
      Output Clusters:
        Ota (25)

#628

it’s discovered as light because of the device_type is set to light. Working as designed. If you want to see it as a switch, look earlier in this thread how to override device type using configuration.yaml


#629

So this is the second time this is happened to me. I went on a one week vacation. After about 24 hours of no motion or open/close events, for my zigbee devices they all went off-line. Even my wall plug zigbee devices went offline. Since all of my intrusion type automation is tied to these devices they would have failed if i had actually had a break in. I’m on 84.6.

Anyone had any similar issues.


#630

awesome! thanks, it worked for me.


#631

hi , i was able to get this on Zigbee but cannot pair as Z wave transmitter, Can any one help with instructions?


#632

How do i pair this plug as Z wave repeater, i could not get it to pair mode after i setup in Zigbee


#633

I actually don’t remember, off-hand. I recall googling it, though.


#634

Without detailed debug log it is only guesses. But yes, people do report similar problems here


#635

Yeah, totally agree about the debug logs, problem is, I restarted HA when I got home and found that everything was not working. It was not until I restarted before I remember I had recevived an alert letting me know all zigbee devices went offline (6 days before). I had created an automation to let me know when zigbee devices go offline the last time that happened (a few months ago), but forgot that I had received the alert. haha.

I will say the alert came almost exactly 24 hours after I had left. It might be more of a controller error than the devices themselves, not going out of town any time soon, but will try to keep logs next time.


#636

I’m starting hass with --log-rotate-days 7 and --log-file ~/logs/home-assistant.log options which keeps logs between the restarts and I can go back a week into the logs.

for troubleshooting purposes, if you don’t enable debug logging level globally, at least enable debug level for the following components in the logger component:

  • homeassistant.components.zha: debug
  • zigpy: debug
  • zigpy.application: debug
  • zigpy.zdo: debug
  • bellows: debug
  • bellows.ezsp: debug
  • bellows.uart: debug
  • bellows.zigbee.application: debug

but read through bellows issue #124 as it provides information about installing a special version of bellows with more verbose debug looging, just to help to classify the issue. As even though the symptoms were the same, there were at least three different symptoms/causes discovered.


#637

Hi there,

I just paired:

Aqara WXKG11LM Smart Wireless Switch Asia Pacific Version

https://www.gearbest.com/smart-home-controls/pp_009395405312.html?wid=1433363

Nice little device which shows as sensor. Once paired the state in unknown. After first press state changes to Bool.true

That state stays no matter how many times you press. Has anyone tried these? After using a Google - looks like the state stays - event is the key here? Anything I can do to use these in ZHA as a binary sensor?

image


#638

I don’t have this particular switch, I have the older Xiaomi smart button. With mine the state flips from off to on but I also get a zha_event. I would check to see if you are getting a zha_event when you press the button and if so trigger off of that.


#639

@dmulcahey How hard/possible would it be to add quirks for the older Xiaomi Mi sensors? I have the older style motion, button, and flood sensor that would be awesome if quirks were added for.

If there is anyway this is possible or anyway I could help let me know!


#640

Not a difficulty thing… just a time thing. You could always experiment using what’s in the repo as a guide and I’ll help where I can.


#641

OK, I can take a look but I think its a bit over my head haha.

Not really sure where i’d find what I’d have to change to work with the Mija devices.


#642

Thank you very much for a quick response!

I makes sense to look for that zha_event! My only problem is that I do not know where to look for :wink:

In sates there are only these four entities and nothing happens there - I do not see any events there. So please could you give me some coordinates to follow?
image


#643

Has anyone got their Samsung Smartthings button to work? Mine only comes up as a binary_sensor (on/off) and temp and battery sensor. I also don’t see any zha_event logs when pushed.