Home Assistant Community

ZHA Zigbee Tested Devices...Please add your device results

#705

Just wanted to share a basic automation I use to keep track of my zigbee devices online/offline state.

Binary Sensor

 - platform: template
   sensors:
     zigbee_offline:
       value_template: >
         {% set offline = states.zha | selectattr('state','eq','offline') | list %}
         {{ offline | length >= 1 }}
       friendly_name: 'Zigbee Devices Offline?'
       entity_id: zha.bedroom_tv_lights,zha.frog_couch_backlight,zha.motion_sensor_closet,zha.motion_sensor_garage,zha.motion_sensor_hallway,zha.motion_sensor_kitchen,zha.motion_sensor_office,zha.motion_sensor_sensor_living_room,zha.open_close_sensor_back_door,zha.open_close_sensor_front_door,zha.open_close_sensor_garage_door,zha.open_close_sensor_garage_fridge,zha.open_close_sensor_livingroom_window_front,zha.water_sensor_kitchen,zha.zigbee_zwave_repeater_1,zha.zigbee_zwave_repeater_2

And here is the automation

- alias: Zigbee Device Offline
  trigger:
  - platform: state
    entity_id: binary_sensor.zigbee_offline
    to: 'on'
    for:
      minutes: 15
  action:
  - service: notify.pushbullet_notifications
    data_template:
      target:
      - !secret pauls_secret_email
      title: Zigbee Devices Offline
      message: >
          {% set offline = states.zha | selectattr('state','eq','offline') | map(attribute='name') | join(', ') %}
          The following zigbee devices are offline: {{ offline }}
1 Like

#706

I would like to share a piece of info, which at least saved my day today. I am running Elelabs Zigbee Shield and basically I am ok with the setup. It is not perfect; around once a week you have to restart the system because zigbee quit working. I do not know is it Elelabs or something else which causes that …. I would not buy Elelabs again because for instance they just quit selling these without even a chance to buy a spare part, so no future there. (Any recommendation for zha, I have tested CC2531 with zigbee2mqtt, I have on my desk also raspbee which I have not tried yet – anyway so far I like ZHA for me the best)

Last week one of my outdoor Ikea bulbs lost the connection – I tried all the tricks to rejoin it without removing it with no luck. This is one of these winters when there is no lack of snow here. The bulb is located high on the wall – you need ladders and below is lot (I mean lot) of snow and under the snow there are bushes etc. – so not an easy task to remove the bulb, take inside to rejoin etc.

To avoid that work I tried once again. I reset the bulb to factory settings, restarted my Hassio and tried zha.permit – and got it joining to mesh far away from the coordinator in its location.

I have also done that many times inside the house for instance to Aqara door sensors - ¾ sensors rejoin with zha.permit remotely from their locations with factory reset – also my Osram Smart+ plugs do.

I tried this earlier last week with this Ikea bulb with no luck – but today immediately after Hassio restart it worked. So it is worth of trying to do joining ”remotely” – it looks like devices really do not need to be close the coordinator when joining the mesh.

Mostly what I have read it is said that devices has to be very close to coordinator when joining …

0 Likes

#707

Is there a soft or hard limit on the number of zigbee devices you can use before they begin to get less stable. I have 14 devices at the moment, 4 are powered, 10 battery. Seems like after a restart I have to reset one or two of the battery devices usually a quick pull of the battery is fine, just seems like its more often lately.

0 Likes

#708

So how do I change the channel in HA? do i have to edit the code?

Thanks

0 Likes

#709

The first 2 came in yesterday. I should get the other 2 this week or next. I’ll try to get what I can done for the next HA release.

0 Likes

#710

It’s all being worked on… not sure how you came to “not a priority”…

2 Likes

#711

SmartThings made changes to their firmware to account for the fact that Xiaomi devices violate zigbee specs. You can read about it if you search for it. I’m still searching for ways to make this better for ZHA. For now, those routers are the best bet.

0 Likes

#712

Zigbee support has been an issue many have asked about for over a year now (not just Xiaomi non-compliant devices)…that’s all I mean… not a priority for HA as a whole. I certainly don’t mean it as a slight on the great work you or anyone else is doing on the ZHA component! I very much appreciate it!! and hope that one day HA can become my only system. For now, I have to keep Homeseer, Smartthings/Hubitat as my main “production” controllers, and keep playing with HA as my test environment.

0 Likes

#713

I didn’t take it as a slight… just thought it was an odd comment considering how fast it’s starting to change. There will be a lot more coming soon too.

4 Likes

#714

Thanks @dmulcahey for all your efforts on ZHA. I’ve been following the hassle you’re going through in an effort to modernize the ZHA code base. It’s very much appreciated! It’s a new breath of fresh air after ZHA went stale for some time on HA.

Many of us started having zigbee issues starting with v68 of HA hence why some folks became a little bitter towards ZHA and the zigpy/bellows implementation. Primary issue (at least for me) has been the network dying after x amount of time.

Thanks again for all your time and effort that you donate to the project. Your efforts don’t go unnoticed!

4 Likes

#715

I’m also a big fan of zha and the work that has been done over the past few months.

I’ve noticed that I have a couple motion sensors that seem to get “stuck” on every time I restart HA. For most of them I just have to trigger a motion event by walking past them , but I do find myself having to pull the battery on one or two of them much more often that I had in the past. Is anyone else having similar issues. I’m thinking that maybe I need to remove and readd them with all the new updates? If I do go that route, should I also clean up the entity registry?

0 Likes

#716

From my experience removing and re-adding devices, i’ve had to the most success removing the device using the ZHA panel / zha.remove then shutting home assistant down and cleaning up any devices left in the registry.

I’m not sure if this is required but I had some strange issues before when I tried re-adding a device without cleaning up the registry.

1 Like

#717

the next version should fix this hopefully. I implemented the “unavailable” property for HA. Devices should also grab fresh state when they reconnect. Pay attention to the release notes for .88 because there are several breaking changes. Hopefully it will be the only time they are necessary.

2 Likes

#718

Try reconfigure in the config panel instead of remove / re-add. Just make sure to trigger the device right before issuing the command to ensure the device is awake.

1 Like

#719

I’ve had all of my ZHA devices become unavailable twice in the past 24 hours since i upgraded to 87.1. Prior to the upgrade this has never happened unless my system was up for more than a week.
Has anyone else had stability issues with this version?

0 Likes

#720

Reconfigure did seem to help one of my devices that always reported on after a restart, but not all. I just sucked it up and went ahead and removed, cleaned up registry, and readded the devices I have. I’ll report back how it goes. I did find a lot of old junk in the registry.

0 Likes

#721

My devices used to get dropoped fairly often. Did a manual purge of the db, looks fine now. Might be coincidencial as it doesn’t make a lot of sense, but who knows.

0 Likes

#722

( HassOS 1.13, Hass.io 143, HA 87.1, Elelabs ZBS - Aqara WXKG11LM Smart Wireless Switch)

I finally had time to update HA to 87.1. from 85.1 - I tried earlier 86 but I had problems (mostly my inexperience but had not time to clear out) and loaded back 85.1.

Now basically all went ok - some weird naming issues with TP-Link smart plugs (they showed in states UI but not in Lovelance) which was solved by starting with factory reset with the plugs …

Unfortunately this Zha_event does not work any more with couple of my Xiaomi switches. Automations are on and on the other hand I do not see the Zha_event in the logs.

Switches are connected and the state changes with the first press from unknown to bool.true …

Should I remove -> pair (Edit: tried , did not work) ---- or something?

0 Likes

#723

Another question of this very nice feature to edit entity registry with UI (Settings -> Entity registry). I have many times removed unused devices from these device and entity registries but for instance removed Ikea remote controllers have always jumped back - maybe because I use them “locally” to control some lights without joining the zigbee/Ha. (I have stopped -> edited-> restarted -> checked they were really removed)

Now from this nice tool I can see there are plenty (33 pcs) of unavailable entities when all my existing entities are alive in “States view”. So the question is: Can I delete them, should I delete them or just leave as they are?


Then another question - they quit selling Elelabs ZBS and I need few other Zigbee systems. I think hardware as Raspbee is nice, but I would like to use ZHA. Documentation says it would work - has anybody tried that yet?

0 Likes

#724

I just picked up an xbee2 and was hoping to use it as a router (I have a HUSBZB-1 as the coordinator). Any tips?

0 Likes