Zigbee & Aqara motion sensor issue

Tags: #<Tag:0x00007f73b490aba8> #<Tag:0x00007f73b490aa90> #<Tag:0x00007f73b490a9c8> #<Tag:0x00007f73b490a900>

I’m running latest build of Hass.IO core, mosquitobroker, zigbee2mqtt and zigbee2mqttassistant via a CC2531 USB stick. I also have several Xiaomi plugs acting as routers.

Over the past couple of weeks, I’ve found that my Xiaomi Aqara motion sensors aren’t detecting motion when I go past them. Or perhaps they are picking up the motion but not sending the info to Hass.IO. If I restart Hass.IO they seem to work fine again for a bit and then eventually when I walk past them again they won’t trigger. If I don’t restart Hass.IO then some time later when I walk past again I get the response again. This only seems to happen with the Xiaomi Aqara sensors. I have several of the Xiaomi Mija motion sensors and they continue to work without issue.

Thinking it may have been a battery issue (though the battery was reporting as 100% in Hass.IO), I have changed the battery on one of the Aqara sensors with no change to the behaviour.
Just wondering if anyone has any idea what might be happening, or what logs, etc I could provide that may assist. I’m only assuming it may be some update that is causing it as nothing else has changed within the system. All plugs, sensors, etc are in the same place as always.

Cheers.

I have this issue as well, I found an issue on Github for it here.

Some devices do not properly forward zigbee messages from the aqara motion sensor, like Osram light bulbs. For me, when I pair the motion detector close to the zigbee coordinator, the problem is fixed for a while. After a while however, I think they get paired to my ‘problematic’ router again, the osram bulbs I have.

It seems the only real way to fix this for me is get rid of the osram bulbs, because I want to keep my aqara sensors. :sleepy:

Thanks for the response. This has been working for quite a while for me without issue, which is why I was thinking it could have had something to do with an update. But the thread you linked goes back much further. The only routers I have in the zigbee network are the Xiaomi plugs. I’ve restored to a backup (I’m running in a VM) to see if they stop the behaviour. It appears to be improved so far, but of course I would prefer to be running up to date builds of Hass.IO and plugins.

Having a read through the link you provided, it looks to be something to do with the luminance reporting perhaps.Rather than trying to hack one to remove luminance (which I don’t use), I might look at going back to the latest up to date snapshot and trying the debounce setting as mentioned towards the end of the thread. Either that or repairing to the coordinator and seeing if they stay connected to that or go back to a router. When initially setting everything up I’m pretty sure I initially paired everything to the coordinator though and as I added in the switches the sensors eventually reconnected to those which may be closer.