Zigbee2mqtt: getting rid of your proprietary Zigbee bridges (Xiaomi, Hue, TRADFRI)


#834

Unfortunately, according to this issue there are some problems with QBKG03LM as a router. I have not tested this myself.

@Playedin, I’m not entirely sure if you need to repair, but there is a branch of the coordinator firmware that’s optimized for larger networks and supports storing of more routes in the network.


#835

Hi everyone,
I’m new here, I’ve bought all hardware needed to play with this great tool.
I’m already using a zigate and never had another gateway for my xiaomi and tradfri devices.
Actually I’m using :

  • double key aqara wall switch with fire lines
  • aqara motion detector
  • aqara humidity and temp senor
  • the cube
  • aqara wireless switch double key
  • tradfri bulb
  • osram smart plug

everything is running fine in my house even with the large amount of concrete between floors.
The zigate and server are locate on the ground floor and I can receive temp updates from a sensor located on the second floor on the opposite side of the house.

But the activity around this project bring me here, I get the hardware and flash the cc2531. Install zigbee2mqtt in a docker container and connect my first device, one of the three osram plug I do not use.
The plug 0 was on the same floor just behind a wall, great it works.
Then I try to add a second osram plug (plug 1) on the first floor just above the first plug.
The join failed, then the container did not see any other join call I had to restart it.
Finally the join is a success good.
Same procedure for a plug in the second floor (plug 2), same troubles but finally zigbee2mqtt saw it and join it.

Now my issues starts, I can see my devices in hass, I can toggle them but for the device on the second floor more than 50% of the commands are lost.
I tried to see the network map, it shows me that I have something like this:

  • plug 1 connected to coordinator
  • plug 0 and plug 2 connected to plug 1

non sense.

So my question is simple, can my zigbee mesh network from my zigate interfere with the zigbee2mqtt transmission ? I dit not remove my wall switch and other tradfri devices before testing the cc2531 of course.
Or it is just my house and my concrete who are not cc2531 compliant ?


#836

cc2531 range is not as good as zigate, that’s for sure.
osram plugs connected to each others sometimes happens here as well.
you might want to try another zigbee channel. see https://www.metageek.com/training/resources/zigbee-wifi-coexistence.html / https://statusq.org/archives/2018/01/09/8435/


#837

Hey,
first off all - zigbee2mqtt is amazing! Finally a solution without using multiple gateways.

I was able to pair all my xiaomi/aqara devices. But i have two problems.

The first one is that when i restart HA, it seems like the addon isnt working. My components wont get updated. I need to manually restart the addon.

The other one, i tried to create a flow in node-red with my aqara motion detector.
I can see in the logs that there is motion detected and the HA component is updated - but only once to “on”. The thing is, i dont want my lights to be on for 2 minutes when I’m only walking 10 seconds through the floor. But I also dont want it to turn “off” when there is still motion. Since the state wont change/update i cant create a usefull flow.
I tried to use the mqtt node because its always sending an update when motion is detected but i dont know how to extract the occupancy out of the payload.

I hope you can help me :slight_smile:


#838

ok I will try to change the channel as described in your links.
But I’ve no issue with zigate (don’t know if I can change the channel there)

concerning osram plugs connected to each other that’s the idea because they are router, but they need to choose the closest one.


#839

Why don’t you just turn off the Zigate for a while and see what happens, should then be obvious if that’s the problem rather than diving straight in and changing things unnecessarily.


#840

I’m able to pair all my Xiaomi Zigbee sensors except Mijia temperature ones (WSDCGQ01LM).
I have enabled debug messages on module config and followed instructions from https://github.com/Koenkk/zigbee2mqtt/wiki/Pairing-devices unsuccessfully.

But i don’t get any message (nor error neither opposite) when i try to pair these sensors…

Any of you has had similar issue?, do you know what options i have?
I rather to use autodiscover than config all mqtt sensors manually…


#841

I think there was a note in the wiki. On Mija devices you need to keep the device active by pressing the button every second. Otherwise its going to sleep and cant pair.


#842

hi @0rn0lf

That’s what i tried unsuccessfully to do, following instructions from URL https://github.com/Koenkk/zigbee2mqtt/wiki/Pairing-devices :

First long press (4-5 seconds) until the blue light starts blinking, and then one short press every second.
However there is neither pairing nor error messages on mqtt log, so i don’t know what i’m doing wrong…


#843

Yes I can do that but I can’t unwire and remove batteries for all devices connected on zigate.


#844

Finally i’ve been able to solve it…
There were no messages because casually mijia sensors were the first ones that i bought , and batteries had such low energy, so sensors couldn’t been detected by zigbee bridge.
Once replaced by new ones everything is working fine…


#845

So, finally yesterday I received all the bits an pieces to try to make this work - and I did with rather very few complications.

Thank you very much, @Koenkk, for this great piece of software and the instructions on how to make it work!

I now have 2 Aqara temperature sensors connected and am already thinking about many other uses :+1:

One quick question to the people who’ve been using it for a while with these sensors:
How long do you expect the batteries to last?

I have one of the sensors in my fridge, the other one in the freezer. Both have been running for roughly a day now, but the battery-%age has gone down significantly already.
I know it’s a rough environment for the batteries, but I’m still surprised about the battery drain so far.
I also know that the linkquality values of 35ish are probably not ideal either, but short of putting the RPi in the freezer as well :stuck_out_tongue_winking_eye: I’m not sure what to do.


#846

in your freezer the temperature changes will probably make your aqara sensor talks a lot more.
in mine it reports every 5minutes (ish)

about the linkquality, you can extend the range with a router.


#847

Aqara/Xiaomi gives an estimate that batteries in sensors etc. should last at least 2 years in normal conditions. The batteries (e.g. CR2032) are new normally somewhat above 3.00 V and drop during use ~0,3 V after which the drop off accelarates. Under 2.7 V I regard them as not reliable anymore. I didn’t change any batteries in my sensors and switches now in use for over a year.
See pictures in former message.


#848

So I’ve

  • shutdown my wifi on channel 11
  • switch zigbee2mqtt to channel 25
  • remove the zigate from the host
  • pair my 3 osram

Here’s the entire disposition with a side view of this part of my house:
image

And here’s what I have :

Prise 1 is ok
Prise 3 respond sometimes
Prise 2 miss almost all toggle order from ha.

So the network map does not seems to represent reality (prise 1 should not be ok because using prise 2)
And none of this can be use in my house.

Please consider that the concrete between floors is really huge this could explain the problem for 2 and 3…
But again zigate does not look to care about that.
Do I have a bad CC2531 key? Should I forget about this and focus on zigate only ?


#849

Has anyone got this working using ESP8266(EspEasy Ser2Net) and socat? I want to put a CC2530 coordinator in the center of the house without a RPi.


#850

Hi, I am trying to set this up, but having a few hurdles. First problem is that when I have my usb sniffer in an usb port, I get problems with my zwave dongle. My zwave USB dongle changes from ttyACM0 to ttyACM1 when I plug in the sniffer and restarts the computer. Changed the zwave usb path to ttyACM1, but it doesn’t seems to be that easy, since my zwave components is not available when hassio start up. Anyone else have this problem? Running on Intel Nuc with Ubuntu Server and Hassio through docker, and the Hassio add-on.


#851

I’ve updated my instructions for generating a map of your Zigbee network above - it works great now and produces something like this:


#852

Got now a second stick laying around after I don’t get more informations out of the aquara qube.
Now I ask me how to proceed.
I heard that I can include a second cc.
Do I have to flash it with the router firmware or can I use 2 coordinators?

Also - is the new firmware already to use? Or more a alpha?


#853

Is there a way to get this visual graph to work with Hassio?