Home Assistant Community

Zigbee2mqtt: getting rid of your proprietary Zigbee bridges (Xiaomi, Hue, TRADFRI)

#1200

Yes you need to configure zigbee2mqtt via it’s configuration.yaml file, as specified in the instructions.

0 Likes

#1201

yes I did but I don’t see any device in my entities screen in HA

0 Likes

#1202

Use mosquitto_sub to see if zigbee2mqtt’s mqtt messages are being received by your mqtt broker.

  • do you have mqtt discovery set up in home assistant?
  • do you have homeassistant: true set up in zigbee2mqtt?
0 Likes

#1203

You need to reboot HA in order for it to pick up the new entity

0 Likes

#1205

Every time I make a change to the configuration.yaml in the zigbee2mqtt folder this file get overwritten even if I set overwrite to false. Or should I setup mqtt discovery in the normal configuration.yaml file.

0 Likes

#1206

Yes the fact that zigbee2mqtt has it’s config in a file called configuration.yaml which is completely unrelated to home assistant’s own configuration.yaml file is confusing isn’t it.

0 Likes

#1207

So if I put this in the normal configuration file it should work.
But what should be the client id ?

mqtt:
broker: a0d7b954-mqtt
username: !secret mqtt_username
password: !secret mqtt_password
client_id: home-assistant

0 Likes

#1208

Still no devices in my entities.
I don’t know anymore.
I hope anyone has a good suggestion what to do

0 Likes

#1209

Post your config properly. The instructions are at the top of every forum page

0 Likes

#1210

actitudes like yours really discourage contributing in a forum

4 Likes

#1212
homeassistant:
  # Name of the location where Home Assistant is running
  name: xxxxxxx
  # Location required to calculate the time the sun rises and sets
  latitude: 51.85083189038637
  longitude: 5.854850127034183
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 0
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: Europe/Amsterdam
  # Customization file
  customize: !include customize.yaml

# Show links to resources in log and frontend
# introduction:
mqtt:
  broker: a0d7b954-mqtt
  discovery: true
  username: xxxxxx
  password: xxxxxxx

# Password login for api
http:
  api_password: !secret api_password

# Enables the frontend
frontend:

# Enables configuration UI
config:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
# https://home-assistant.io/blog/2016/10/25/explaining-the-updater/
updater:
  # Optional, allows Home Assistant developers to focus on popular components.
  # include_used_components: true

# Discover some devices automatically
discovery:
  ignore:
    - plex_mediaserver

influxdb:
  host: a0d7b954-influxdb
  port: 8086
  database: p1smartmeter
  username: !secret influxdb_user
  password: !secret influxdb_pass
  max_retries: 3
  default_measurement: state
  
input_boolean:
  zigbee_permit_join:
    name: Allow devices to join
    initial: off
    icon: mdi:cellphone-wireless
    
timer:
  zigbee_permit_join:
    name: Time remaining
    duration: 600
  
# Allows you to issue voice commands from the frontend in enabled browsers
conversation:

# Enables support for tracking state changes over time
history:

# View all events in a logbook
logbook:

logger:
  default: info
  
# Enables a map showing the location of tracked devices
map:

# Track the sun
sun:

sensor: !include sensor.yaml


# Text to speech
tts:
  - platform: google

# Cloud
cloud:

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
binary_sensor: !include binary_sensor.yaml

rfxtrx:
  device: /dev/ttyUSB0
  debug: False


# switch settings
switch:
  platform: rfxtrx
  automatic_add: True
  devices:
    0b11000801ea156a01010f60:
      name: KamerLamp
    0b110004012a035a01010f50:
      name: KeukenLamp
    0b11000f012a035a02010f50:
      name: VissenKom
    '0710010047040000':
      name: BootLamp
    0b110008017199920a000060:
      name: InloopKast
    "0710020047050000":
      name: Hoekplant
    0b11000201ea156a02010f70:
      name: Halletje

And this is the one from zigbee2mqtt:

devices:
  '0x90fd9ffffed52d24':
    friendly_name: ikeabootlamp
    retain: false
homeassistant: true
mqtt:
  base_topic: zigbee2mqtt
  password: XXXXXXX
  server: mqtt://homeassistant
  user: XXXXXXX
permit_join: false
serial:
  disable_led: true
  port: /dev/ttyACM0
0 Likes

#1213

Seemed to fix the issue. The user I used was on readonly in the mqtt config. I changed it and I now see an entity coming in. Thnxs for the help.

0 Likes

#1214

You do not need to restart ha for that.

0 Likes

#1215

Anyone selling a preflashed cc2531? Buying the flasher seems a waste. Will give the seller some extra bucks off course.
Ships to Hawaii?

0 Likes

#1216

Not if you ever want to update the firmware on it or flash a few CC2531 with the router firmware too

0 Likes

#1217

True, for me just 1 without router is fine. If I ever want to update or flash others I will buy it.

0 Likes

#1218

I am a beginner, I am a bit confused by the steps. Do I need to pre setup mqtt in hassio. What mqtt broker is recommend. The build in one works fine or I need something like mosquito.

0 Likes

#1220

mosquitto is recommended over the built in broker. It is just better.

0 Likes

#1221

Can somebody help me with zigbee groups on Hass.io?

I have a separate groups.yaml file which I include in the config.yaml. Where should I create the zigbee group?

Also, when I tried to create one, it said “Friendly name” wasn’t a valid thing.

Lastly, to add items to a group do I just publish an mqtt topic?

0 Likes

#1222

If you have a groups.yaml then the logical place to create a group is in that file.

As for the rest of your question, it is probably answered here https://www.home-assistant.io/components/group/ - unless I am missing something.

0 Likes