Zigbee2mqtt on hassOS keeps breaking (2023.6.3 // Supervisor 2023.06.4 // Operating System 10.3)

Hi everybody,

I am using zigbee2mqtt 1.31.2-1 on

Home Assistant 2023.6.3 
Supervisor 2023.06.4
Operating System 10.3
Frontend 20230608.0 - latest 

The entire system is running under Proxmox in a VM. My zigbee coordinator (Texas Instruments LAUNCHXL-CC1352P-2, link) is passed through by the supervisor to the hassOS machine.

This setup has worked for months without issues, maybe even years (not sure when exactly I set this up).

Recently, the zigbee2mqtt addon would stop working. There wouldn’t be any noticeable errors (for example, persistent notifications), it would just stop and I’d eventually realize this when all my zigbee entities where unavailable.

When I’d click on zigbee2mqtt in the sidebar, I’d get an error similar to this (not sure about the exact words, as it is currently running and the error does not show) Add-On is currently not running, please start it.

Then I’d go to https://<my-url>/hassio/addon/45df7312_zigbee2mqtt/info and start the addon. Under logs, I could see that it could not successfully start; again, the error / log is currently not available, so unfortunately, I cannot provide the exact message. But I could see that the USB adapter was not available.

So I would

  • log into proxmox
  • go to hardware settings for hassOS VM
  • disable USB
  • unplug z2m coordinator
  • re-enable USB
  • restart hassOS

Without restarting hassOS, this would not work, even though when I ssh into the machine and lsusb, I’d see that the adapter was available again.

Has anybody experienced this, and knows a fix? This is pretty annoying. Usually, when there is an error, restarting HASS is enough (unless it is one I made manually, but that’s a different situation). In this case, however, it requires me to manually unplug the coordinator, manually edit the hassOS settings in proxmox, then restarting Home Assistant.

I should mentioned that I have quite a large number of zigbee devices (zigbee2mqtt currently displays 96), and just recently added about 4 (so from 92 to 96). These devices I added were mostly smart plugs, so they are powered through mains 24/7 and shouldn’t cause any problems. I have more of these plugs (same vendor and model), so the devices themselves shouldn’t cause this issue, either. While 96 is quite a few devices, it should not be too many for z2m to handle, especially since many of them are smart plugs and light bulbs, which act as routers as well as clients.

Any help is greatly appreciated.

How are you specifying your USB device?

If you are not using serial by id the USB identifier can change.

I am using /dev/ttyACM0 in zigbee2mqtt settings

It has always worked like this, without issues. In proxmox, I am currently passing the entire USB port, not just the device (tested both, this method seems to work better…?)

I just updated the coordinator firmware to 20230507, was still on some 2022 before. Hopefully the firmware update will solve this. I did not change anything to cause this to happen, and everything had previously worked fine for at least a year.

Well, I did update the z2m addon when updates were available… but I doubt they’d update in a way that would break older coordinator firmwares (especially when this firmware was not the latest version, but not outdated, either).

If the error comes up again, I’ll post the details.

You have always been lucky. Until now. It’s a crap shoot. Every time the host restarts there is no guarantee that it will remain the same.

Specify the USB adaptor by serial id. This will not change and you will not lose connection to it.