Zipato Bulb 2 RGBW


#21

As long you do not provide us with detailed steps you performed on your setup we can not help you either. Secondly you early stated you got an error…

You tell us you are running Hassio, with that you can only use zwave.update_config like I said earlier. It is not possible to edit zwave manufactor config files on Hassio, you need Hassbian ( or something else) to do that. So I wonder what you have been trying in the first place…? Otherwise you need to wait till devs from Hassio will update zwave too.


#22

Thanks for helping! I have tried all you can see on this page: dev-tool light turn on red- your tutotrial, copy rgbbulb2.xml file, zwave config update, heal newtwork, heal node, refresh node, test node.
After one update of home assistant, the zwave light broke-wont change color and temperature any more. I have also this light in gropu with zwave me wall controller, to turn on off


#23

That was a workaround back in the past or when you have new bulb where the white value was still on, you had it to turn to zero to enable color. But from what I understand from your info is that colors already worked before for you so then turning the value to zero again does not make any sense I think.

That only works for non Hassio setups, “VMG” already discribed on how to do that.Currently I wonder which setup you have for Home Assistant?

Using zwave.update_config should update from the git repo ( from what I understand) and I also noticed ( running Hassio) it did not work for me either and is why I used Hassbian this time and used VMG info to get my bulb working again. To me it seems you probably forgot some step in configuring rgb2.xml running a non Hassio setup?

Yup, after some update back in the past it did not work for me too. I wonder what you mean by temperature coz to others we could still turn the bulb on/off and also dimm the light only not change colors. It might be worth to check out someway to see if your bulb might be broken, or like VMG already asked…which version/type bulb do you have?


#24

I have Hassio 0.82.1 on raspberry pi 3b+ with zipato zwave bulb 2. Done today factory reset, included again, the light started with warm white - before was cold white, but still can not set color or white temperature. So is the rgb part defect?


#25

@BlintWave any solutions?


#26

Hi @BlintWave, @VMG, @achmed20 and @warcanoid,

I’ve tried many things but still no success.

Manufacturing date code on the bulb: 1711
Home Assistant Version: 0.84.6
OpenZwave Version 1.4.3254

I run Hass.io and don’t want to move to Hassbian just to fix this issue. Since it is not possible to directly edit the config files it seems like I have to use zwave.update_config. I followed the instructions to first stop the server and then delete the node entry in zwcfg_*.xml. I did not find any hint wether the call to update the config from github was successful and what has changed, the log just says that it was triggered. Is there really no way to at least see the current config? When and how is OZW being updated, might it be included in one of the future releases?

Also I tried to manually do the changes in zwcfg_*.xml: no success
Of course I tried to set the white value to 0

When following comments github my problem is also that my node is setup as a multilevel switch and does not have “color capabilities”, at least my ozw log does not show any of the entries about color as mentioned along with this issue: https://github.com/OpenZWave/open-zwave/issues/1647

Did any of you get it fixed in the meantime? Can anybody help how to get this running?
Any idea in which place to raise an issue (does not seem to be an issue within OZW)? Still seems to affect quite a number of people.

Thank you!


#27

@switchbert everyone ignore this error, I opened few issues on github and they closed everything with zwave bulb:( strange


#28

Alright, I finally found a fix for Hass.io which is to specify a local path for the z-wave device config.

Explained step by step:

  1. Download open-zwave as a ZIP-file from Github: https://github.com/OpenZWave/open-zwave and extract it locally
  2. Copy the extracted folder “config” with all of its content into a newly created directory /share/z-wave
  3. add this entry to your configuration.yaml for zwave: config_path: /share/z-wave/open-zwave/config
  4. Shutdown Homeassistant
  5. Delete zwcfg_*.xml
  6. Start Home Assistant
  7. Check Z-Wave devices, Heal Network, wait, nodes and entities are missing…
  8. Restart again
  9. Colors work!

@warcanoid I hope this works for you as well. I don’t think you are being ignored but they way I could fix it also showed that it is not a problem of OZW but related to the way the device config is being updated within Hass.io.


#29

@switchbert Thank you very much. Uff finger crossed that will for me to:) will report.


#30

@switchbert THANK YOU VERY VERY MUCH! IT WORKS!!! After 3 months!! Ufff I own you a beer:)
I only changed the config path to: zwave: config_path: /share/z-wave/config