Zwave GE/Jansco Dimmer - Allow Picture Element/State-Icon to toggle 100%0% (On/Off) and still controlling dimming in more-info

I have a floor-plan picture element in which I had some z-wave switches and light dimmers setup through SmartThings. I bought a Nortek zwave/zigbee usb stick and am trying to transition to 100% HA without SmartThings in the configuration. I successfully added the dimmer switch but when I click on state-icon the action (toggle) isn’t instant, it transitions from off to on and the icon doesn’t refresh properly. On SmartThings it toggled quickly on/off and only dimmed slowly within the more-info (available through hold-action).

Is there a way somehow configure the toggle and more-info/dimmer to behave like it did in SmartThings? I reviewed a great deal of the configurations for the node config parameters (Z-wave Command Dim Step, Z-wave Command Dim Rate, ALL ON/ALL/OFF Dim Step, etc.) and tried playing with them but I haven’t made any progress. I also tried adding this to my configuration.yaml:

zwave:
  polling_interval: 60000
  device_config:
    light.living_room_front:
      refresh_value: true
      delay: 3
    light.living_room_back:
      refresh_value: true
      delay: 3
    switch.living_room_pendants:
      refresh_value: true
      delay: 3
      polling_intensity: 1

Any help would be much appreciated.

Short answer: No.

This is a flaw in home assistant and it’s light polling and it really only affects GE/jasco dimmers. Part of the reason it hasn’t been cared about. When you set a delay to 3 seconds, you’re telling the interface to not look at the state of the light after a state change until 3 seconds pass. Inbetween those 3 seconds, the state may or may not reflect correctly.

Do you means dim to on?

Yes, gradually goes from off to on. Versus just 0%-> 100%.

That is device setting.

In devices properties you change that behavior. I think you can do from zwave menu in HA

That would be great. Can you give me a more detailed example?

I don’t know what @tmjpugh is going on about, this is something you cannot change for the interface. The device itself may dim at a certain rate but the UI will not reflect that. It’s been an issue with these dimmers since day 1.

Confirmation>>zwave>>zwave node management>nodes=GEDimmer

Adjust “node config options” for device

There is ability to have different function zwave vs manual switching

Yes, I have messed with these values and haven’t been able to get the desired effect. Have you configured this type of dimmer in this way successfully? Do you have the settings that worked for you?

Yes but I prefer dim to off

I don’t remember the settings but I can try later

are you referring to how it works in the interface or the hardware? Because I really feel like there is a disconnect here that no one seems to be paying attention to accept me.

@tmjpugh is talking about hardware settings.
@kymnyth appears to be talking about the interactions in the UI.

I feel like I’m taking crazy pills.

@petro I understand that there is a a problem with the ui and it reflecting the setting of the switch. However, I was also wondering if there was a way to get the actual switch to behave in the same way as it did in SmartThings. Once the hardware is working properly (go straight to 100% through the toggle action) wouldn’t the ui show correctly with a delay time set to 2 or 3?

The UI does not show the transitions period. Delay removes the odd on/off behavior but the transitions never show in the UI. It’s always 0% to 100%. No transition displayed.

That is not my experience. I click the light on in the ui, the light gradually increases and then during that process it seems to refresh the light icon and the color is not the fully yellow “On” color but a darker “dimmed” color.

Got a video?

It always freezes the state waits til the 3 seconds are up and refreshes the state in the UI with no transition.

2019-06-05_14-34-45

Interface show slow transition to OFF
Your result may be related to delay. K

I also have issue with off not being off so slider show 0 but switch shows on. I have got this working by changing setting but resulted in dim to off not working so I live with the problem and just off again by switch after 3 seconds

This is my point. You can’t fix this in the UI. I know what’s causing the issue. I’m trying to explain to OP that what he want’s isn’t possible. These devices don’t play well with the interface. Leave them at factory settings and live with the ui not updating with a transition.