ZWave JS UI configuration for existing ZWave JS setup without using MQTT

Need help with setup. Trying to get ZWave JS UI setup with my existing ZWave JS integration + addon but:

  • Not use the MQTT portion of the ZWave JS UI addon
  • Not have to reconnect all my ZWave devices

Everything I am finding on the web seems to be pretty dated and not in a mood to play chat chat with GPT.

Any steps/do’s/don’t would be much appreciated.

Thank you.

Follow the instructions in the official docs. https://www.home-assistant.io/integrations/zwave_js/#how-do-i-switch-between-the-official-z-wave-js-add-on-and-the-z-wave-js-ui-add-on

The ZUI add-on configures it for default use with HA and the integration, so MQTT is disabled to start with.

1 Like

Thank you for the link.

At step #3:

Install and configure the Z-Wave JS UI add-on, including setting the location of your Z-Wave device and the network security keys.

Is this the device referred to? /dev/serial/by-id/usb-0658_0200-if00

At step #5:

Add the Z-Wave integration again (even though it is still installed), and uncheck the “Use the Z-Wave JS Supervisor add-on”. Enter the correct address for the community add-on in the URL field in the next step.

Instead of adding the Zwave integration again, would it work to go to the installed integration and re-configure the server?

Can I run Z-Wave JS UI only for the control panel and nothing else?

Sure, in the settings of Z-Wave JS UI, make sure to enable “WS Server” and disable “Gateway”.

Is there any advantage or disadvantage to using this configuration instead?

Yes.

No that doesn’t work, which is why the instructions tell you to add it again. Installing again results in a re-configuration.

1 Like

Thank you again.

Sorry I was editing my questions as you were replying. Would you please check the last question above and give me some direction on it?

This is the default configuration of the add-on. If you want to use MQTT, you can enable it yourself.

1 Like

Thanks a bunch!

Hi how do I find the correct address for the community add-on? I try to switch from “Z-Wave JS” to “Z-Wave JS UI”

Thank you!

EDIT:
Ok, did find out what I have to do.
In the add-on configuration I have enable the port of let say it better I have to enter a port. I have used 3000 and re-added the z-wave-integration with the checkbox unchecked and the default value displayed