Zwave range/mesh issue?

Hi all :blush: (sorry for the long post) I moved over from smartthings a couple months ago and I’m still learning, but I’m having a problem that seems to be related to zwave range or possibly my mesh. All the devices I’m having trouble with were working fine on ST and were excluded using the ST hub before inclusion was attempted in HA. I’m running HA with zwavejs ui on a Lenovo tinypc with a husbzb-1 stick on a 3’ extension close to the center of my 2500 sq ft wood frame home. There are hard wired GE/Jasco switches and outlets all over my house but I’ve only managed to get 2 (an in wall fan switch and a light switch) to connect on one end of the house. 7 other GE switches, an Aeotec hd switch and 2 iblinds motors all refuse to connect. The iblinds are in the same room as the one fan switch that has connected on this end is the house (still less than 60’ from the hub). I pulled the 2 blinds down and brought them to the hub and was able to connect them easily. When moved back into the room they belong in, the nodes now show as dead. I have factory reset each of these items multiple times with no change. I’ve also tried to heal the network (as well as individual devices) a few times with no change. I was actually able to reconnect the Aeotec to the ST hub again. I then excluded it, but still could not connect to HA (this one actually gets a reaction from the hub that it cannot be included - no reaction of any kind from the other devices). Logs after all these inclusion attempts simply show that the inclusion has ended (timed out). No errors. Any suggestions any one can give are greatly appreciated. TIA!

Brian – I don’t have a solution, but I have two suggestions:

  1. See if you can separate the device not working with HA from the mesh not being good enough. You did that with the blinds, so it seems like they are a network issue, not a compatibility issue. Are any of the GE/Jasco switches close enough to be sure it’s not a network issue?
  2. Try adding more nodes (at least temporarily) as you build out the mesh. For example, get two wall-plug Z-wave units and place them between your hub and the device you’re trying to add to see if that helps. You may need to “heal” the network to get it to find paths.

Good luck. I haven’t had problems with my mesh (almost all Fibaro devices) but I have had issue with network traffic overloads on my mesh…


David - thanks for the reply. I’ve tried placing wall plug units within a 2 feet of the switches that are causing trouble with no effect. There’s actually a working fan switch in the same box as one of the switches in question. This fan switch is also in the same room as the blinds (which no longer work now that they are not in the same room as the hub). I’ve healed the network each time I’ve made changes.
Interestingly, the 2 blinds in question included with security while none of the other 8 that are working in the house did. Not sure whether that is relevant or not, just an observation. I’m planning to make a “test rig” of sorts today with an extension cord and an electrical box so that I can uninstall some of these switches from the wall and install them in the test rig right next to the hub. This would prove whether or not the switches are still good, but not why none of these devices no longer work on that end of the house. It’s funny, I switched over from ST to get local connectivity as well as avoid the few bugs that I encountered with ST and I have spent many, many more times the amount of effort just trying to get HA to work. I love the granularity that’s available, I just question sometimes whether it’s worth it for me. What would the procedure be for determining if I’m seeing network traffic overloads? Just look at the zwave js ui logs?

Brian – I completely sympathize with your frustrations over it not “just working.” I have 7 switches for lights in my kitchen and I wanted a simple “turn them all on at once” but found that it took over 10 seconds to get them all to turn when I first used HA, and only after many updates and switching to broadcast does it now work reliably. I’m sure that if I had used Fibaro’s Home Center I would never have had that problem. (But, the ability to integrate everything and have it run locally and script it has made it my main hobby, which has given me far more joy than frustration over the years. :slight_smile:

The only way I know I was having network traffic problems was that when I tried to do fewer devices at once they went quickly, but many caused problems. You can turn on logging in ZwaveJS and see exactly what is being sent, but I don’t know how to know if it is saturating the network.