Zwave2mqtt not updating Watt meters

Tags: #<Tag:0x00007f73ad5bd0b0> #<Tag:0x00007f73ad5bc8e0> #<Tag:0x00007f73ad5cb958>

I recently switched to zwave2mqtt. I have 2 (socket) switches, ZW132 Dual Nano Switch (AEON Labs) & FGS213 Switch (FIBARO System).

They both have Watt / volt meters but the problem is since the switch to zwave2mqtt the values of those meters are not updating anymore.

Any ideas ?

I don’t have the ZW132, but I have the Smart Switch 6. Couple of things come to mind:

  • If you did something like a factory reset or so, you may need to change some of the configurations within the device to get it to report correctly. For example, in the Smart Switch 6, I had to add the Zstick node-id to its group1 before it would send out reports to the Zstick.
  • Check the z2m Log to see what Zwave2Mqtt is seeing when those devices are updating watt/volts.

For the groups do you mean this:

If i try to do this nothing is displayed with current association

log:

2020-07-31T11:34:26.474Z z2m:Zwave zwave node 10: changed: 50-1-2:Electric - W:0 -> 5.6
2020-07-31T11:34:26.476Z z2m:Zwave zwave node 10: changed: 50-1-256:Exporting:false -> false

“groups” here refers to the zwave reporting groups such as found on the zwave configure tool

I am not getting this config because i use zwave2mqtt now. I disabled the zwave integration

group associations should be available on whatever tool you use to configure your zwave devices. They show up as one of the parameters for a device.

This is good!! This means the device is communicating to your ZWave2MQTT. What is in this log is also similar to what I see from my ZW132.

  • If there are more parameters that you would expect to see from node10 and you don’t see them in the log, then it means the device likely needs more configuration data to generate the reports and send them to your ZStick.

  • If you don’t see, in this case the Watts of 5.6 show up in HA for that device, then there are many things that could go wrong. If you are using the ZWave2MQTT in HA Discovery mode, then I can’t help as I don’t use that (and can’t say that HA supports or doesn’t support that particular energy parameter). If you are not using HA Discovery, then the next best thing would be to snoop on your MQTT broker to see what ZWave2MQTT is sending to the broker for this particular energy parameter.