0.103: Happy Holidays, Service calls, StarLine, GeoNet NZ and Proxmox

Hello, all. I just upgraded to 0.103 (HA on Docker on Ubuntu) and the Overview tab is the only thing that works. Map, Logbook, History, HACS, Developer Tools, Configuration, Notifications, and the Profile button all tell me “Error while loading …” and then a spinner. Has anyone else seen/reported this?

LOL Ok. Well on docker the image was only updated an hour ago https://hub.docker.com/r/homeassistant/home-assistant/tags

You don’t say what installation you have (hassio, hassos, venv etc) but images take time to be built. Patience is a virtue.

As I said, I run the HA docker image on Ubuntu. Today, I upgraded as soon as it was available, as I’ve been waiting on the mobile_app fix to upgrade my IOS clients.

FWIW, those tabs are working now. Not sure what took them so long to start, but will see if it happens next time I restart HA.

Nuts that is a significant problem for me when editing that forces me to use the “CLASSIC” automation option to avoid the editor wiping out my configs.

My response was to @FranMiele, but good to hear you are going OK now.

I’d like to draw everyone’s attention to a useful new option in this release, called snapshot_entities, that simplifies creating scenes on the fly. It was created by Santobert in PR 28939 and is an enhancement to scene.create.

The use-case is when you want to:

  1. Record the current state of several entities before you change them to something else.
  2. Change them to something else.
  3. Restore their states to their previous values.

Using snapshot_entities, you can now simply list the entities in scene.create. Their current state will be stored in the temporary scene.

Example from the documentation:

Save the states of two entities to a new, temporary scene called scene.before.

  - service: scene.create
      scene_id: before
      - climate.ecobee
      - light.ceiling_lights

When the time comes to restore their states, simply turn on scene.before.

  - service: scene.turn_on
      entity_id: scene.before

Clarified the use-case.


Anyone got the proxmox integration working?

I get a :

Package proxmox setup failed. Component proxmox Integration 'proxmox' not found.

when i check my config


Thank you for the WLED white value support


1 Like

From this release every integration based on alarm_control_panel (like this one) won’t work because they introduced an abstract method supported_features.
It’s obviously a breaking change, but it wasn’t listed as such… :frowning:

1 Like

Anyone else seeing an issue with lutron_caseta lights? I’m getting an issue because pylutron doesn’t get installed

Unable to prepare setup for platform lutron_caseta.light: Platform not found (No module named 'pylutron').

I didn’t think anything about the lights portion of lutron_caseta changed, so I’m not sure if this is due to the python package import changes? As far as I can tell, lutron_caseta.light requires pylutron because it imports a couple of things from homeassistant.components.lutron.light and the lutron component uses pylutron. I’m not sure how it was working before this update, but just that import apparently isn’t enough to make homeassistant go off and get the dependencies of the lutron component

Do you know if that works for media_players?

For instance if you are casting an Internet radio station to a Google Mini media_player, will it remember what it was playing/volume, etc, if an open/close door cast alert goes to the speaker?

I have no media_players so I can’t test it. Give it a try and let us know.

Have you tried restarting HA, sometimes it needs to pull it down and install

Awesome release! Thanks for the hard work and Merry Christmas!!!

1 Like

I did raise this earlier this week on the alarm github page. Hopefully a simple fix

It is proxmoxve, please check the documentation. :wink:

The docs say it is set up using proxmox in the configuration.yaml, even though the integration seems to be called proxmoxve

This is what the docs say

# Example configuration.yaml entry
  - host: IP_ADDRESS
    username: USERNAME
    password: PASSWORD
      - node: NODE_NAME
          - VM_ID
          - CONTAINER_ID

You are absolutely correct! PR has already been filed I see :slight_smile:

Thanks, I’m all set. I figured if it was announced that it would be available to all installations. I just had not waited long enough.

Restart the Gateway, this same error occurs for me when I update HA on occasion. Restarting the Gateway, and then HA fixes the issue.