0.118: Grid and logbook cards, quick navigation, native template types



I just tried this in my 0.118.2 config and it works for @mrck use case, so as documented, this is a temporary fix for 0.118.x

  legacy_templates: true

I also note that it is the comma delimiter that causes the result to become a list, if you use, for example, a “|” or a space then it remains a string. Not very useful though.

Wow, this is great update, good work, and the Android companion app is updated as well, with very good updates too.
I am looking very much forward to the development of the GRID card.
It needs ‘columns’ settable by line, so that you can vary between 1-2-3-4-5 cards per line, it should also be able to force the grid size so that it will adapt the card to a fixed size, square doesn’t do it currently, it’s a good start, but if I should use it, I still need a ‘vertical’ stack card, as I have a panelmode setup for my tablet.

1 Like

I agree. I had a play with the grid card today and quickly got an identical card to one I use as a remote for Kodi. However some of my more complex remote cards with buttons that span columns were just not possible.

There wasn’t a huge reduction in the number of code lines between using the grid card and horizontal and vertical stacks. And it becomes less clear where each row starts.

So I’ve abandoned converting them all to the grid card for now.

Hi. I am running Raspbian which still has Python 3.7. I think many people are running this distribution for their HASS setups.

0.118 is still working for me, but I am very worried about the deprecation warning. I cannot use Docker because I am running nftables and Docker does not work in that environment. Do the developers still have us Raspberry Pi users in mind when deprecating Python releases?

Since 118.3 all my automations are doubled on the automation page, with the copy being disabled?! Anybody else experiencing this behaviour?

Forget it, my fault! Has nothing to do with the Update! Sorry!

Keep up the great work!

Exactly the same place I am, because I can’t set the number of fields per line, I had to combine it with other cards, and then I had to put them into vertical/horizontal anyways, as panel mode only allows one card, so it was kind of counterproductive.
Of course if you set up a complete homogenous square button interface, the grid is very good, but it’s a very limited use-case.

@Silicon_Avatar thanks for the pointer on the URL whitelist, that helped me out.

at the same time, I’ve seen a few different URLs I needed to whitelist, while using the ytmusic api. Is this expected during initial setup, or is another method I can use?

- "https://lh3.googleusercontent.com"
- "https://i.ytimg.com"

Yep… can confirm 0.118.3 has fixed issue with Solaredge… all back to normal…

Hi there. don’t know if it comes from 118.x( 2,3,4 ) or from ikea tradfi hub but if any light are setting on FROM ikea tradgri HUB, status is not updated in HA.
But playing with tradfri bulbs from HA is working as usual.
My pb is that i use motion sensor from tradfri, and use bulb status to launch an automation, and i can’t anymore.
Either a bug or a side effect with no more string anymore ?

Not sure that’s a general HA issue…
I’m on 0.118.4 and my status is updating immediately when Tradfri motion sensor triggers a Tradfri bulb on or off.
If you want me to check anything specific let me know :+1:

Thanks Gav-in, i will investigate now i know this is working for you it means something is on my side :slight_smile:

1 Like

since version 0.118 I get following entries in my log:

Logger: homeassistant
Source: helpers/config_validation.py:471
First occurred: 8:18:21 PM (1 occurrences)
Last logged: 8:18:21 PM

Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/device_tracker/legacy.py", line 163, in async_see
    dev_id = cv.slug(str(dev_id).lower())
  File "/usr/src/homeassistant/homeassistant/helpers/config_validation.py", line 471, in slug
    raise vol.Invalid(f"invalid slug {value} (try {slg})")
voluptuous.error.Invalid: invalid slug telefon: samsung sm-g973f (try telefon_samsung_sm_g973f)

Any idea what can cause it?
Thanks in advance

I’m not entirely sure, but its seems to be complaining of an invalid name. Slugify tries to convert a name you provided in the config into a entity-id. For some reason it can’t deal with your samsung telefon name and provides a suggested name for you to use instead: telefon_samsung_sm_g973f

I thought so too, but question, where can I find it?
It does not come from configuration.yaml… seems like android mobile app wchich I use.

I´m not 100 % sure if it´s related to the update to 0.118.4 or the CLI update (at least those´ve been changes I did today), but suddenly a sensor configured in configuration.yaml disappeared:

  - platform: command_line
    name: Pi-Hole Status
    scan_interval: 10
    command: curl -X GET ''
    value_template: >
      {{ value_json.status }}

Can anybody point me into the right direction to debug and fix this?

Does it still appear in developer tools|states?

No it doesn’t :pensive:

Why not use the PiHole Integration?