0.85: ESPHome, Plum Lightpad, OpenSenseMap


#21

So 0.85.0 completely bricks my HA instance. However, I do get a couple errors when I run the upgrade from 0.84.6:

pyowm 2.8.0 has requirement requests<2.19,>=2.18.2, but you’ll have requests 2.21.0 which is incompatible.
locationsharinglib 3.0.6 has requirement requests~=2.19.1, but you’ll have requests 2.21.0 which is incompatible.

I’m not sure how to go about fixing this. I am running on Hassbian.


#22

docker build eta?


#23

What is slugify …

According to google: A slug is a short label for something, containing only letters, numbers, underscores or hyphens. In the case of Home Assistant, no numbers.


#24

It’s technically already there, https://hub.docker.com/r/homeassistant/home-assistant/tags tag 0.85.0b0

If you want to, you can download it and remove your current container and run that instead. I did that last night to get the ESP stuff working.

But yeah, would rather do it the normal way and I’m curious on the ETA as well!


#25

So does that mean all my entities like this:

automation.lounge_lights_to_75pct_at_9pm

Are going to have to be changed to just letters and underscores?

If so it’s going to be a right PITA.


#26

I don’t think so. e.g. I had a sensor.samsung_a5_battery, and it’s still the same name after the update. I can also see the history, etc, of this sensor, so it works fine. I think that the automatic “creation” of entity_id’s has changed a bit. But I have to agree, it’s also not completely clear to me what is exactly changed.


#27

Ambient support advised me the app_key was hard coded in Version 3. I’m stuck at:

Could not connect to weather station API
7:29 AM components/sensor/ambient_station.py (ERROR)

According to the man page, an app_key is still required. Have you setup the ambient sensor yet?


#28

Nope - haven’t managed to yet.
Just received this message from Ambient Support:
snip

You need not request an app key. You simply generate your own User Key
snap


#29

How do you upgrade? I always do the following (from my Pi login) which maybe overkill;

sudo hassbian-config upgrade hassbian-script
sudo hassbian-config upgrade hassbian
sudo hassbian-config upgrade homeassistant

I’ve successfully upgraded from 0.84.6 to 0.85. Do you get anything useful from

sudo systemctl status [email protected]

or see anything in home-assistant.log ?


#30

Without app_key I get:
Invalid config for [sensor.ambient_station]: required key not provided @ data['app_key']. Got None. (See ?, line ?). Please check the docs at https://home-assistant.io/components/sensor.ambient_station/


#31

RE: Ambient, there shouldn’t be an application key per user. According to a conversation I had with their support, every HASS user should use the same application key; it’s the API key that should change.

I have a PR in place to make some architectural adjustments to this platform: https://github.com/home-assistant/home-assistant/pull/19902 – I’ll revise it to hard-code the application key I received and remove that as a required configuration option.


#32

In my small ZHA setup issue seems to be related to having the Hampton Bay Wink fan module connected, if I remove it my 6 other ZHA lights all come back and function correctly. Opened an issue for this…


#33

Hi,
since updating to 0.85 the Service group.turn_on longer works.

019-01-10 15:12:23 ERROR (MainThread) [homeassistant.components.automation] Error while executing automation automation.alarm_fully_armed_turn_off_lights_ect. Service not found for call_service at pos 1: (ServiceNotFound(...), 'Service group.turn_on not found')

#34

OK. I’ll wait for your go ahead before attempting to configure the sensor.


#35

after update to 0.85.0 my file size sensor seems to be broken
but i can’t find anything in the breaking changes?


#36

Is that a valid service? I’m using version 0.80 and it does not show group.turn_on as an available service.

In fact, in the linked post below, petro indicates it is not a valid service and recommends using homeassistant.turn_on to turn on a group.


#37

I run all the commands listed here: https://www.home-assistant.io/docs/installation/hassbian/upgrading/

I do not use the “sudo hassbian-config upgrade homeassistant” method.

I had previously monkeyed around with the locationsharinglib stuff in the past to try to get the Google Maps sharing device tracker to work. I was able to get it working but I have since quit using Google Maps for device tracking.


#38

I think (This is going off memory) that group.turn_on used to be a service and it was removed. If not, it’s always been homeassistant.turn_on. This is dating back to 2015ish. My memory might be alittle off.


#39

The thing is it was working perfectly fine on version 0.84
I’m okay to change it I was just surprised and couldn’t see anything in the changes for .85


#40

Does still work, the breaking changes is marked in the big yellow warning section - just check for an updated entity name in your list.