0.96: Notion, updated sidebar, advanced mode

Having similar issues on my xiaomi vacuum cleaner here too, with the same ImportError about OPENSSL_1_1_1.

xiaomi_miio: Error on device update!
ImportError: /usr/lib/arm-linux-gnueabihf/libssl.so.1.1: version `OPENSSL_1_1_1' not found (required by /srv/homeassistant/lib/python3.7/site-packages/cryptography/hazmat/bindings/_openssl.abi3.so)

I’ve lost the ability to use ‘boost’ for my Hive :grimacing: I can set the device to on (on), off (off), and eco (which seems to map to ‘schedule’ on the Hive) - any ideas @rendili?

nmap_tracker issues with 0.96
I will comment some options and see if it works.

Anyone else got issues trying to update?

My hassio log spits out something along the lines:

19-07-18 11:49:41 INFO (SyncWorker_9) [hassio.docker.interface] Update image homeassistant/qemux86-64-homeassistant:0.95.4 to homeassistant/qemux86-64-homeassistant:0.96.0
19-07-18 11:49:41 INFO (SyncWorker_9) [hassio.docker.interface] Pull image homeassistant/qemux86-64-homeassistant tag 0.96.0.
19-07-18 11:50:33 ERROR (SyncWorker_9) [hassio.docker.interface] Can't install homeassistant/qemux86-64-homeassistant:0.96.0 -> 404 Client Error: Not Found ("no such image: homeassistant/qemux86-64-homeassistant:0.96.0: No such image: homeassistant/qemux86-64-homeassistant:0.96.0").
19-07-18 11:50:33 WARNING (MainThread) [hassio.homeassistant] Update Home Assistant image fails

Reading the “404 - not found” error I thought the image might be taken down, so I tried pulling the image locally (docker pull homeassistant/qemux86-64-homeassistant:0.96.0) but this works just fine.


Unfortunately we had to move the hotwater device from climate to water_heater, and at the moment water_heater does not support any boost functionality and does not have a an auto mode, so for now in the short term we have had to map this to eco.

ASUSWRT stopped working.

Error during setup of component asuswrt
13:51 components/asuswrt/init.py (ERROR)

Thu Jul 18 2019 13:51:35 GMT+0200 (centraleuropeisk sommartid)
Error during setup of component asuswrt
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.7/site-packages/homeassistant/setup.py”, line 153, in _async_setup_component
hass, processed_config)
File “/srv/homeassistant/lib/python3.7/site-packages/homeassistant/components/asuswrt/init.py”, line 45, in async_setup
from aioasuswrt.asuswrt import AsusWrt
File “/srv/homeassistant/lib/python3.7/site-packages/aioasuswrt/asuswrt.py”, line 9, in
from aioasuswrt.connection import SshConnection, TelnetConnection
File “/srv/homeassistant/lib/python3.7/site-packages/aioasuswrt/connection.py”, line 6, in
import asyncssh
File “/srv/homeassistant/lib/python3.7/site-packages/asyncssh/init.py”, line 31, in
from .agent import SSHAgentClient, SSHAgentKeyPair, connect_agent
File “/srv/homeassistant/lib/python3.7/site-packages/asyncssh/agent.py”, line 35, in
from .public_key import SSHKeyPair, load_default_keypairs
File “/srv/homeassistant/lib/python3.7/site-packages/asyncssh/public_key.py”, line 43, in
from .encryption import get_encryption_params, get_encryption
File “/srv/homeassistant/lib/python3.7/site-packages/asyncssh/encryption.py”, line 23, in
from .crypto import BasicCipher, GCMCipher, ChachaCipher, get_cipher_params
File “/srv/homeassistant/lib/python3.7/site-packages/asyncssh/crypto/init.py”, line 27, in
from .ec import ECDSAPrivateKey, ECDSAPublicKey, ECDH
File “/srv/homeassistant/lib/python3.7/site-packages/asyncssh/crypto/ec.py”, line 24, in
from cryptography.hazmat.backends.openssl import backend
File “/srv/homeassistant/lib/python3.7/site-packages/cryptography/hazmat/backends/openssl/init.py”, line 7, in
from cryptography.hazmat.backends.openssl.backend import backend
File “/srv/homeassistant/lib/python3.7/site-packages/cryptography/hazmat/backends/openssl/backend.py”, line 74, in
from cryptography.hazmat.bindings.openssl import binding
File “/srv/homeassistant/lib/python3.7/site-packages/cryptography/hazmat/bindings/openssl/binding.py”, line 15, in
from cryptography.hazmat.bindings._openssl import ffi, lib
ImportError: /usr/lib/arm-linux-gnueabihf/libssl.so.1.1: version `OPENSSL_1_1_1’ not found (required by /srv/homeassistant/lib/python3.7/site-packages/cryptography/hazmat/bindings/_openssl.abi3.so)

have you find a solution?

still looking for it, since I get error during “Check Home Assistant configuration”

Failed config
  General Errors: 
    - Platform not found: device_tracker.nmap_tracker



I’ve never installed or updated numpy, is this something I should attempt to fix or is this something the developers of the IQVIA platform need to address?

IQVIA Platform Error

2019-07-18 06:06:12 ERROR (MainThread) [homeassistant.setup] Unable to prepare setup for platform iqvia.sensor: Platform not found (


Importing the multiarray numpy extension module failed. Most
likely you are trying to import a failed build of numpy.
Here is how to proceed:

  • If you’re working with a numpy git repository, try git clean -xdf
    (removes all files not under version control) and rebuild numpy.
  • If you are simply trying to use the numpy version that you have installed:
    your installation is broken - please reinstall numpy.
  • If you have already reinstalled and that did not fix the problem, then:
    1. Check that you are using the Python you expect (you’re using /srv/homeassistant/bin/python),
      and that you have no directories in your PATH or PYTHONPATH that can
      interfere with the Python and numpy versions you’re trying to use.

    2. If (1) looks fine, you can open a new issue at
      https://github.com/numpy/numpy/issues. Please include details on:

      • how you installed Python
      • how you installed numpy
      • your operating system
      • whether or not you have multiple versions of Python installed
      • if you built from source, your compiler versions and ideally a build log

      Note: this error has many possible causes, so please don’t comment on
      an existing issue about this - open a new one instead.

Original error was: libf77blas.so.3: cannot open shared object file: No such file or directory

Replying to my own problem here.

In case anyone gets this issue, check your disk usage %, after running docker pull homeassistant/qemux86-64-homeassistant:0.96.0 ssh’d onto hassio it told me there is no disk space left.

Sadly the error output from hassio is a bit misleading here.

eq3btsmart error also in 0.96…

2019-07-18 13:56:17 ERROR (MainThread) [homeassistant.components.climate] Error while setting up platform eq3btsmart
Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.7/site-packages/homeassistant/helpers/entity_platform.py", line 126, in _async_setup_platform
  File "/usr/local/lib/python3.7/asyncio/tasks.py", line 416, in wait_for
    return fut.result()
  File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/srv/homeassistant/lib/python3.7/site-packages/homeassistant/components/eq3btsmart/climate.py", line 69, in setup_platform
    devices.append(EQ3BTSmartThermostat(mac, name), True)
TypeError: append() takes exactly one argument (2 given)

In config:

  - platform: eq3btsmart
        mac: !secret salotto_mac

I’m also having the same issue. chrome seems to be doing it as well but only randomly

All my Netatmo sensors only shows “unknown”. Does it work for anyone else?

also having same same issue, also running iPad OS 13 Beta

You guys using a browser for this or the iOS app? I’ve noticed that the app fully hides the sidebar. I’ll be honest. I like the way the iOS app does it over this new shrinking side bar.

Not a fan of the never hiding sidebar on desktop.


If you have issues with climate integrations in 0.96 i suggest logging issue here
after checking if nobody else has logged, if they have add to their issue.

also the more info the better as opposed to “its broke” or “me too”


For all those people with OPENSSL issues, please follow the discussion here.

1 Like

Sorry - what is CCH?

I’ve had a play with the new menu and I am not a fan at all.

  1. It takes up screen real-estate for little benefit. 95% of the time I have the sidebar closed and only open it for config tasks. Why have something taking up screen space when I hardly use it?

  2. Nothing should interact on mouse-over. It’s not a design paradigm anywhere else in home-assistant. I’m a bit shakey on a mouse - and the first thing I did when messing about on the demo screen is try to open the top left camera - overshot a bit and suddenly the sidebar is open. Then over to the right to let it close - and then I did it again!

  3. At the most - if we have to have a slidey sidebar - why can’t it just slide in when you hover over the hamburger top left? Why take up all that space on the main screen?

It really looks like they thought it looked cool and just did it. Is this something somebody could make a custom component for like they did to de-clutter the top banner?


So not really related to the new version (haven’t updated yet)

But on the demo how do you get the weather map? is it just linking to an external site or is it a component I’m not aware of?

@DavidFW1960 It is same on IOS12 on iPad. I have raised a bug report on it on github today

1 Like

Can someone try and open HA 0.96 in Edge?
On the computer I have access to here at work NOTHING is displayed other than a blue bar.
I do not normally use Edge so I do not know how it worked in 0.95. I tried because I noticed issues with the new left bar in Google Chrome on Linux. The Google Chrome issue went away after a yum update on that Centos machine
But when I look at my Home Assistant in Edge in Windows 10 I cannot get the browser to display anything. I never get to the login prompt. Nothing. Can someone here confirm that problem?