2021.1: Happy New Year!

OK Thank you

Sensor of netatmo weather not work

not much HA can do when Netatmo’s service is down…in general if no error in your log (after activating Debug for the Netatmo component) then check http://helpcenter.netatmo.com and you’ll get your answers

1 Like

For me, after updating to 2021.1.3 my ‘weather-card openweather map’ card no longer worked correctly instead of showing MON TUE WEDNESDAY THU FRI always shows the day Monday.

hello i am also in your same situation have you found a solution? At the moment I am back to 2021.1.1, I believe those who developed the weather card have not put their hand on it for some time

@rot Really? Nothing to go on.

Try telling us some useful info. In fact, read this and try again :slight_smile:

What is the last version that worked?

Lol sorry for that. It was battery on mi flora. It stop just after i checked app connection and update. Bad luck.

its probably the integration OpenWeahterMap:


using 3 other weather integrations too here (Darksky, Buienradar and Weatherbit) and they all show correctly.

believe an update was made to the OWM integration in 2021.1.4, so hopefully this has been solved now?

update

yes it has been solved:

Thank You very much!!!

after todays upgrade from 2021.1.1 to 2021.1.4 my reolink cameras stopped to work. I use the https://github.com/fwestenberg/reolink_dev via HACS

These are my errors in the log:

2021-01-17 10:08:11 ERROR (MainThread) [homeassistant.components.camera] The reolink_dev platform for the camera integration does not support platform setup. Please remove it from your config.
2021-01-17 10:08:11 ERROR (MainThread) [homeassistant.components.camera] The reolink_dev platform for the camera integration does not support platform setup. Please remove it from your config.

I have no idea what does it mean and how to solve.

Each HASSIO upgrade is a big adventure. Often I have issues on upgrades from one version to another, but most time there is some information about breaking changes and there are solutions.
Now I even get issues on minor upgrades inside a release.

I get more and more afraid of upgrades, because there are hardly any upgrades without problems. It would be nice if stability got a higher priority than new features. And I would like to see better documentation of breaking changes. Too often there are not or badly documented breaking changes.

Have you updated hacs?

Perfect… :slight_smile:

Reolink is a custom component not dwveloped by the core team, the dev of this component may need to update it (maybe a simple HACS upgrade is also enough) in order to work with the new version. This has nothing to do with the stability of HA, if you use a custom comoponent, you need to be aware that it may break at anytime. This is out of control of the core dev team. You even get a warning in your logs with custom components like

You are using a custom integration for XYZ which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you experience issues with Home Assistant.

Can you name some examples of breaking changes (not of custom components,that’s out of scope) that were not documented?

Also… have you tried restarting HA again. I do find often that immediately after an update to core, HA needs 2 restarts… one the automatic one and then another one before the errors disappear. The component may need to update something after the core update but it starts too fast and hence an error but a second update will fix it.

@Burningstone
My issue was with the custom component reolink_dev which I upgraded at the same time before upgrading hassio. It switched from using config file to using cameras as integration. This is not a hassio issue. Sorry for this.

regarding breaking changes: One major issue was with hass os 4.8
https://community.home-assistant.io/t/hassos-4-8-upgrade-breaks-my-install

Another issue happened a few months ago, I don’t find it now. But there have been some changes not marked as breaking changes.

Even if breaking changes are documented: They are in every update and actions are required nearly every time.

I compare hassio to fhem, which is running in parallel because I still have some Homematic devices integrated via fhem and I don’t know how to integrate them into hassio directly. hassio and fhem are connected via mqtt. In fhem never any upgrade did break anything. It is possible to upgrade and all keeps working fine. That’s why I would like to see a bit more priority for stability using existing configurations over breaking changes also in hassio. I understand that is very hard to be up to date with new devices and to avoid breaking changes. But it is a very big contrast compared to fhem.

In general, I am very happy with hassio: It was easy to setup, it looks good, configuration gets easier with nearly each release.

I don’t use Home Assistant OS, but there seem to be lots of issues with it in the past. However this is separate from Home Assistant Core, the actual software.

First of all, it’s not called hass.io anymore since more than 12 months.
I don’t think that’s a good comparison. FHEM had the last update around a year ago (which is like a century in smart home time xD) and it doesn’t even come close to the 1700+ integrations that Home Assistant provides.
Also, often breaking changes can’t be avoided without making the relevant integration useless. When a manufacturer changes their API or changes the way one needs to authenticate, the integration becomes useless and will not continue to work without the breaking change.
Recently lots of breaking changes have been due to integrations moving from YAML config to UI config to make it more accessible to the masses (good or bad idea, decide for yourself), this is something that can’t be done in one release (remember 1700+ integrations) and will take some time until it is finished.
In addition, I use Home Assistant since version 0.3x, so I lived through quite some releases and breaking changes and it never took me more than 30 mins to adjust my config (and I have a quite “complex” system with more than 100 physical devices) for the breaking changes, most of the time I was done in less than a minute.

2 Likes

Do you have entries in configuaration.yaml for reolink-dev? If so comment them out and set up from the integrations page.

After upgrading to 2021.1.4 from 2021.1.3 I noticed that the snapshots size are way smaller.
Before the size was around 400 MB. and now is only 50 MB.
The db its around 127 MB and hasn’t changed.
Also the snapshot is taken very fast, like 30 seconds, before took around 2 minutes.
Has anybody experienced the same?
(I havent removed addons or custom components).

Edit:
Looks like before the snapshot included addon backups but now it doesnt (only folders):

LOOK in the snapshots and compare them.