A switch stopped working

I have a very simple Home Assistant setup in my house, which has not been updated/changed/etc in many months. One of the controlled devices is a SOnOff relay that is connected to a light switch and it has worked fine for a couple of years; but yesterday, it didn’t work. In an attempt to resolve the issue, I rebooted my Raspberry Pi (the Home Assistant host), but that didn’t help. I then looked on CloudTrax and see the SOnOff device (as a client). I also tried to toggle the switch from the Home Assistant web page, but that didn’t work. However, I was able to turn the light on/off by toggling the physical switch. What on earth is happening and more importantly, how can I make the device work again using Home Assistant?

No one can help you with the provided info. There are so many way’s to integrate Sonoff in to HA…

Read this, please:


To BebeMischa’s point this could be a loose wire, failed relay, something with HA or something in your wireless network. Are all of your other automations working? Do you need to update the software? Is it a problem in the Pi (Bad SD card)? Is it a problem in CloudTrax? Can you see the traffic to the device? Can you ping the device?

So many questions and not able to help without more information.

I power-cycled the circuit the switch is on, via the circuit breaker, and the device started working again.