Actionable notification not working on iPhone

Hi, I have read through the docs on creating actionable notifications here and have done all steps. In spite of this I am not able to see the button on my notification. It simply continues to show the notification as a basic one. Can somebody point out what am I missing here?
My configurations:

    - name: ALARM
      background_color: "#000000"
        text: "Alarm"
        color: "#ff0000"
        icon: alarm
        color: "#ffffff"

I can see the above action in my app configuration properly.
My automation which sends me the notification

alias: Notify I am away from home - iOS
description: Notifies when I go out of my home
  - platform: state
    entity_id: person.vijay
    from: home
    to: not_home
      hours: 0
      minutes: 0
      seconds: 0
      milliseconds: 0
condition: []
  - service: notify.mobile_app_iphonexr_vijay
      message: You are going away from your home
      title: Away from home
          - action: ALARM
            title: Enable alarm
mode: single

Something has happened with actionable notifications on IOS15 that has stopped the notification from putting up the choices. I don’t know if this is fixable in the HA app or if Apple took it away.

oh that’s disappointing!

I spent a bit of time messing with it and I got it to work.

  1. I was using the older “categories” method for my test, which has been depreciated.

  2. The example works, but does not mention that you have to “long press” on the notification for the choices to come up. Here’s what it looked like when I did:

1 Like

oh wow! Thanks , I also tried a long press and I can see the button now. Thanks buddy you saved me a lot of effort. But this seems pretty bad UX flow from iPhone. Why would they add this extra step !!

Apple will Apple. :wink:

I am stuck at the next step now :frowning_face: I am not able to call back an automation as a result of clicking of the button. Can you help me further on this? Below is the automation which listens for this action and toggles a light.

alias: Enable Alarm Action
description: Enables the alarm
  - platform: event
    event_type: ios.action_fired
      actionName: ALARM
condition: []
  - service: switch.toggle
      entity_id: switch.study_light
mode: single

Your event type is wrong
Should be


oh thanks for pointing that out. I think I copied this from an example somewhere , must have changed. Many thanks buddy!

The solution for showing the action buttons with a “long press” does not work on my iphone13. The notification message and title show but I can do nothing after that. My code generated from the Automations UI looks like this.

  • id: ‘1642376820933’
    alias: Garage Notification
    description: ‘’
    • platform: state
      entity_id: input_boolean.test
    • service: notify.mobile_app_iphone13promax
      message: Garage Door open
      title: Garage Door Status
      action: CLOSE_DOOR
      title: Close Door
    • wait_for_trigger:
      • platform: event
        event_type: mobile_app_notification_action
        action: CLOSE_DOOR
        timeout: 00:01:00
        continue_on_timeout: false
    • service: notify.mobile_app_iphone13promax
      message: Door was closed
      title: Door notification
      mode: single

same here and actually upon saving quote marks are disappearing…
tried some examle code buttons are not showing…

  - service: notify.mobile_app_iphone
      message: Ro
      title: Zmywarka
          - action: ARM_AWAY
            title: Away
          - action: ARM_VACATION
            title: Vacation
          - action: NOTHING
            title: Ignore
mode: single

solution here( it was as easy as pressing longer :wink: ):
crosslink with this →

Even the long press for me does not reveal the action buttons. WTF?
iOS 2022.11.2
Home Assistant 2022.11.2

Hi everyone,I think it still doesn’t work. Or am I doing something wrong. I have ios 16.6 on Iphone 13 pro.