🆕[add-on] HassOS I2C Configurator

Have you hard reboot 2 times after running add-on? it’s not enough to restart HA, you have to shut off and remove power then restart 2 times.

1 Like

Thank you very much! I think the step “to plug off power” was the important point.

And now, I have a very noisy fan :smiley: Is yours also noisy?

on default config, yes: i use quiet option of Argon addon, its a linear noise curve and didnt affect cooling much

1 Like

hmm, not so obvious…

ran the add-on with protection mode disabled, results:

ls: /dev/i2c-1: No such file or directory
I don't see I2C.
no sda1 config found
no sdb1 available
adding dtparam=i2c_vc=on to mmcblk0p1 config.txt
adding dtparam=i2c_arm=on to mmcblk0p1 config.txt
This Configurator did it's job. Perform a hard-power-off reboot now.
You will need to reboot twice total, once to place the files, and again to activate the I2C.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.

now in my second host reboot

how to check if this was successful?

btw, though the add-on states it didnt find sda1/sdb1, I do have my partition on an attached SSD. Not booting from it, by via the SD, with configuration on SSD, as per official Partition method

starting the add-on a second time results in

/dev/i2c-1
/dev/i2c-0 /dev/i2c-1 /dev/i2c-10 /dev/i2c-11
Found i2c access!  Nothing to do!  You can remove this add-on.

so I guess this was successful after all…

Why do you do it so complicated? Just burn latest HA image with etcher on SSD (as per HA Instalation, just need SSD attached to another computer), start it from SSD without SD inserted, restore a previosly saved snapshot and all migration is done. I2C addon writes needed data to all drives it can find (or you can use manual method), reboot twice and youre done.

Because that’s not a supported HA install method , and I like to keep support from the dev team…

Besides, it’s not that complicated :wink:

Are you kidding right?

just replace writing to SD with SSD in the install steps; no need for anything more so its as official as it gets. First boot will take care of all partitioning and everything else. You dont need SD anymore after you saved your snapshot to your computer.

well, I’ve been on a lot of core discord chat, and booting from SSD is not officially supported, as far as I understand it. That of course is the reason it is not mentioned in the doc you link to. The partition method is though.

So no, not kidding.
It can be done, there’s a whole thread on it: Installing Home Assistant on a RPi 4b 8GB with SSD boot

The simplicity of your method isn’t discussed there I am afraid? Seems somewhat more complicated than you suggest… :wink:

btw, just started up in my new Argon case:

Schermafbeelding 2021-06-24 om 19.47.27

which is 20C cooler than before the case… wow.
this is without the fan blowing :wink:

First post of the tread you mentioned described with a milion words what i was just said in 3 lines. :grinning:

yah, I know…

just posted what you wrote in that thread and tagged you, so you can chime in if you like.

HI Mate,

Trying to use you addon to fix this issue.
ssd1306_i2c : Unable to initialise I2C:
I2C device failed to open

This is happening on my custom addon to get the OLED working for UCTronics ref: UCTRONICS/U6143_ssd1306 (github.com)

I seem to have everything else working, but issues with I2C, hoping you could offer some guidance?

1 Like

Possible to use DS3231 ?

Hello
I have been trying this addon but without sucess.
I am using debian 11 aarch64 os on RPi4 4GB.

The Protection mode is Disabled. Have tryed with more than 5 reboots. With/without start on boot…

.....
crw-rw-rw-    1 root     root        1,   5 Jul 13 18:29 zero
nothing to do. Is protection mode enabled?  You can't run this without disabling protection mode

some ideas?

Att:
On aarch64 the default directory will be /boot/firmware/config.txt and not /boot/config.txt (This should be a nice update )
Att2:
Should be added the dtparam=i2c_arm=on into config.txt fiile too?

Thanks Adam I am a nubie and that was exactly what I needed to get a grasp on my own system. I am now trying to get the fan to work on an Argon Case.

Can somebody please confirm that an Rasp Pi 4 8g will work with an Argon One for the temperature controlled fan speed. I seem to be having problems getting the i2c portion to work.

Ive performed the installation recently on hassOS latest build. but my cpu never gets hot enough to turn on the fan, so i dont know if it acctually works… my pi is the 4g version. there shouldnt be any difference software wise between the two.

Same here. I’ve rebooted 3 times (power unplugged), but it still doesn’t work.
This is what I have in the logs:

ls: /dev/i2c-1: No such file or directory
I don't see I2C.
mount: permission denied (are you root?)
Detected Protection Mode is enabled. Disable Protection Mode in Info Screen.
no sda1 config found
no sdb1 available
no mmcblk0p1 available
This Configurator did it's job. Perform a hard-power-off reboot now.
You will need to reboot twice total, once to place the files, and again to activate the I2C.

This could well be caused by an issue in Home Assistant Operating System. I followed the official approach, but still the Argon One Active Cooling Addon complains i2c is disabled.

Hi,
I hard rebooted twice (ok it was more because I try it two days ago) but nothing happens.
This is what I see, and this is my notification.
After the reboot addon turns off. I tried it just leav it and I tried turn it back. Nothing.
Can you help me why I am wrong and how can I fix it?
Thanks a lot!

Good day. Please help me.