Add-on Store is broken 'Failed to fetch add-on info'

Both Franck and Paulus are currently doing a livestream on Youtube, so I guess we have to wait for that to end at the very least.

Also experiencing this, didn’t change anything.

Any timeline for this getting fixed?

All, simply make sure you have a repository.json in all subfolders located in usr/share/hassio/addons/git.
ESPhome was missing it, so I manually created the file with the following:
“name”: “ESPhome”,
“url”: “”,
“maintainer”: “Ottowinter”

You then have to reboot completely (not just home assistant).

Looking at vs, you can see that adt-pulse-mqtt contains the file, while esphome doesn’t.
Once I added the file the addons store worked again.


I’m a bit of a noob - when I look in my \hassio\addons it is completely empty. Do I need to make a folder there, or am I looking at the work place? (looking through Samba Share)

I’m not using ResinOS, maybe your solution / path is different!
You must have ssh access to your systems root account (not hassio docker)!

  1. Find the missing repository.yaml . In my case, the esphome one was missing as well.
    ls /usr/share/hassio/addons/git
    Folders with numbers were listed. I tried both folders and looked for the one containing esphome.
    cd /usr/share/hassio/addons/git/NUMBER
    The full path in my case is:
  2. Once you are inside the right folder type
    sudo nano repository.json
    and copy paste the following code. (In damiens code is a slight failure in the path)

“name”: “ESPhome”,
“url”: “”,
“maintainer”: “Ottowinter”

Hit CTRL + X and save.
3. Reboot System (whole system, not only hassio)

Attention: In my first attempt i was not successful. Somehow the file disappeared after reboot. So i copied over the repository.json from the other repository, just to make sure i got the rights correct. I replaced only the strings, not the entire block. Another reboot later everything was working agan.

I did about that yesterday actually. But I didn’t restart HA.
Today I just did:
cd /usr/share/hassio/addons/git/7bce6681
sudo wget
I think that is content the actual file should have. You have a different URL in your self created file, perhaps this will cause issues later on when you want to update the add on.
The above 2 commands fixed it for me.
Nevertheless thank you very much for investigating further.:muscle:


Thank you for this elegant solution :+1:

1 Like

How do I find the maps? I tried searching the ssh acces for root, but couldn’t find anything.

In IDE, I tried to acces the map:

But it won’t find the hassio or addons map…

You are not able to reach /usr/share/hassio/addons/git/7bce6681 from the IDE.
You need to be outside the container. So you should SSH into the system itself and then execute the commands I posted above.

I need to ask this. I have SSHed into the system, got hassio > prompt, executed login changed to directory /usr/share/ and I don’t see hassio subdirectory. What am I doing wrong ???

That’s odd. But you can just search the whole /usr for repository,json files like so:
find /usr -name repository.json | grep addons
(this search won’t show you the exact directory you should add the file into because, well, it doesn’t have the repository.json which is the whole problem. But at least you should find the path to the addons dir.

I’m on raspberry pi … /bin/ash: find: not found. thx
Error message: “Can’t read json from /data/addons/git/18c35ad6/repository.json”

I don’t have a pi at hand to check it myself. Can you do just a rude ls -R /usr | grep addons

For Raspberry Pi folders are located under:

1 Like

Weird thing is that repository.json is not to be located on my system…
I dont have the addons/git folder neither (??)

EDIT: I restored a previous snapshot prior to adding the custom URL, then resolved.

I am having the same issue. Installed on a raspberry pi, but no luck searching in the /mnt/data/supervisor folder. I have documented my logs on reddit.

Anyone get it back working ? I am having the same issues @TheStigh was having, where there repository.json can’t be found on the system…

Looks like it is a bug, and they have closed the issue as “resolved in next release”.

Have you tried my find command or the ls -R command from a few posts back?

Here is some other finding: The file is apparently deleted automatically after some time. Its being deleted as soon as i hit the reload button on the add-on store page. However, if i reboot the system immediately after creating it, i can open the add on store page for some time. I think its some kind of security system wiping it ?

Edit: I disabled protection mode for esphome. Maybe thats a workaround for me until the update.