Add scan interval to Fronius integration

Currently the Fronius integration ( updates every 60 seconds. It would be great to have a customisable update interval so we can get data more (or less) frequently if required.

Try putting scan_interval: whatever in the yaml file.

Doesn’t do anything. I’ve looked at the code for the integration and it seems to be hard-coded to 60

It doesn’t look like that to me. Line 84 seems to set scan_interval to CONF_SCAN_INTERVAL or DEFAULT_SCAN_INTERVAL

 scan_interval = config.get(CONF_SCAN_INTERVAL, DEFAULT_SCAN_INTERVAL)

That seems to me (and I am not completely knowledgeable about what this does) to set it to what you put in configuration.yaml or the default if nothing is set.

When you tried it, did you restart HA after setting in the yaml file?

ah cool, I understand that better now. I did restart HA before, but now I’ve tried again and it seems to be working. thanks

1 Like

Just an FYI, you can also configure the Fronius Push Service to push data into Home Assistant as often as every 10 seconds without the integration. I just wrote a forum post on it: Fronius data without the Fronius Integration

@nickrout , where should I put the scan_interval: so that it applies to the Fronius integration?

You don’t, it doesn’t work.
See New Fronius UI Integration with Multi Inverters - #2 by farmio

1 Like

Are You sure? My update every 2 secs.

And I would like to change it too but can not find the possibility.
Indeed there is one idea/path I should check.

I am using HA 2023.1.5 with the fronius integration, a Fronius Symo 10.0-3-M and a Smart Meter TS 65A-3. I only get an update rate of 60 seconds (or even sometimes longer) for the smart meter and inverter data. In the fronius integration documentation it is written “Cumulative data of the SolarNet system. Updated every 10 seconds.”
Is I understand the option " `scan_interval: " is not longer available?
Is there any other way to speed this up?
Everything is connected via ethernet and pings are <2ms so there should be no connection issue.

Turn that off and create an automation firing homeassistant.update_entity for one entity of each endpoint (power_flow, inverter, meter, etc.) in the interval you want.

You’d be surprised how many connection issues these Fronius Dataloggers yield when you query them too often. No matter how they are connected.
Their API documentation recommends a 4 second delay between 2 consecutive requests.

As you can see on your own system

Fronius Integration Documentation:
When an endpoint is not responding correctly the update interval will increase to 10 minutes (3 minutes for power flow) until valid data is received again.

The 10 second interval is only applied on the power_flow endpoint.

1 Like