Add support for Levoit Classic 300S Smart Ultrasonic Top-Fill Cool Mist Humidifier in the VeSync integration

Thank you very much for working on this! I just got one of these for a gift and am excited to be able to control it and use in automations.

1 Like

Very very new to home assistant (less than 3 months), not a developer. I’ve read this thread and multiple others threads trying to figure out how to install this for a 400s Air purifier but have had no luck.

I’m unable to get past the first step… “pip install pyvesync”
My version of home assistant is on a home assistant blue rasberry pi.
I tired copying the extracted zip file from GitHub - webdjoe/pyvesync: pyvesync is a python library to manage Etekcity & Levoit smart devices to my custom components directory and that didn’t work.
I tried the default VeSync integration (just for fun) but that didn’t work as it doesn’t’ support the 400S. Tried to google the pip install and I know it’s a python command for installing packages but that’s it.

Any help for this newb to get past step one would be greatly appreciated, thanks!


Go here: GitHub - formatBCE/HA_VeSync_Classic300s (this is an integration repo).

Download and extract folder to custom_components.
Reboot HA.
Go to integrations and add VeSync formatBCE there.

Will work :slight_smile:

P.S. pyvesync is Python library, and HA integration works on top of it. Don’t try to install pyvesync directly into HA - you have to use integration instead.


@formatBCE thank you that worked, very very much appreciate your assistance!

NP, welcome to mad and fascinating world of Home Assistant! :slight_smile:

Ok another question. by using the integration you provided above I am now able to turn the fan on and off on my 400S Air purifier through home assistant, but i’m unable to see anything else (air quality, fan speed, etc).

It appears that in this threat Add support in Vesync for Levoit 400s Air Purifier - #14 by helmarw is based on the same python library that your code is based on. If that is true and that threads library exposes the fan speed, air quality, etc. Should I also be seeing the fan speed, air quality etc using your integration or is that threats code: core/homeassistant/components/vesync at dev · home-assistant/core · GitHub different than the code you provided: [GitHub - formatBCE/HA_VeSync_Classic300s]GitHub - formatBCE/HA_VeSync_Classic300s ? Thanks!

As you might see, they’re adding template sensors to see attributes as separate entities.
Short word: there is “fan” entity, created by integration.
It has state switch (on/off) - it’s main property. As entity can have only one main state, other properties are added like “attributes”.
If you navigate to Dev Tools section, and find your fan entity there, you will see attributes with all available info there. They also can be used in automations, for example, as triggers. But to add them to UI, you’ll need to create another entities manually (template sensors), which will use fan attributes as main state property.

Perfect, thank you! I’ll go ahead and start creating some of those template sensors.

1 Like

Hi everyone, I have loaded this custom component, but I am not able to see any entities related to it. I currently have a Dual 200s Humidifier. I noted it shows as supported in pyvesync, and am curious if its simply not supported in HA via this component. If not, am I able to edit anything to obtain basic functionality? Been at it a couple hours now.

Update… It appears as though I had the incorrect version of the component. It is now loading as expected. Thanks!

1 Like

Hello, folks. Anybody else suddenly lost the humidifier?
It worked very well via the @formatBCE integration, and then suddenly in the morning all greyed-out :frowning:

It happens to me time to time, looks like VeSync servers lag or so.
Just delete integration and re-add it - you don’t have to even reboot HA. Should work.
If it’s not, try to delete humidifier from VeSync app, and re-add it there first.

Actually. I apologies. Looks like my humidifier lost wifi connection. Nothing changed about the network. Humidifier kept running, but showed unavailable in the app too. Removing and adding it back in the app solved for it.

1 Like

Thanks for making this custom extension BCE. Works great. Also educational in this thread I learned you can find state names and all possible attributes for a given entity in Developer Tools - which is super super helpful!

1 Like

Also, I’m curious. What is the difference between mist_virtual_level and mist_level?

I can’t really say actually - it’s from pyvesync library, and it takes them from official API.
I can only guess, that one setting is related to mode, and another one is current level. At least for me in auto mode they always differ.

@formatBCE First, I want to say thank you for being so active on this thread. Second, I’ve followed the steps to get this repo installed but I’m not seeing it show in the integrations. Here are my steps.

  1. Download and Extract GitHub - formatBCE/HA_VeSync_Classic300s to /config/custom_components/
  2. Reboot HA

…annnnd that’s where I hit a wall. Cant seem to find your integration in my menu.

Let me know if I’m missing something!

It’s not immediately obvious… I had the same problem seeing the integration.

1 Like

Great Work! But sadly i got a Problem finding my Dual 200S after adding the Integration. I can input my username etc. when setting the Integration up, and the Humidifier also shows up in the app, but there is no entity added. I tried to remove the Integration and also the Device in the App, but nothing shows up, what could also be a possible Problem? I start to feel stupid since its working for everyone else… :confused:

You may try to debug with downloading pyvesync, and running it fromm console. It has good README.
But first try to check HA Core logs right after restart - it should give you an error.
Sometimes vendor API site is slow, and pyvesync can’t get data…