Addon installation


I’m trying to add this : Foscam - Home Assistant (
To my HASS installation, but when “open link” after I put in my ip , I get redirected to:
which shows me “404: Not Found”

I also tried search “foscam” directry from configuration > integration, but I can’t find it…

My HASS version is 2021.1.5, installed on Rasbian, with pip install homeassistant, and virtual env.
python version 3.7.3 and linux version 10
my config looks like this:

# Configure a default setup of Home Assistant (frontend, api, etc)

# Text to speech
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

I also tried adding “my:” right under “default_config:” and then I restarted the server, but I get the same results.

Click the + button in configuration|installations and type foscam

I don’t have “installations” option, but I have “integration” option , and I search there, it doesn’t come up with any result.


Indeed under integrations


I believe you that it works for you, but I don’t have it on my end…

We’re currently at 2021.8.8, so you are far behind. Maybe time to upgrade ?

I have just installed it few days ago with this guide ( didn’t skip any step)

python3 -m pip install wheel
pip3 install homeassistant

why did I get an old version? how can I update please?


Can it be the PIP version? I tried updating it , but it indicated that it can’t because of home assistant…
(from my understanding, it shouldn’t affect it. )

ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

homeassistant 2021.1.5 requires pip<20.3,>=8.0.3, but you'll have pip 21.2.4 which is incompatible.

This is already a problem. Current venv installs need python 3.8 or 3.9

OK, So if I’ll have Python 3.8 and above then I would get the latest home assistant version and it should work?
I stayed with 3.7 because debian 10 (latest version) only supports 3.7 in the stable version…

Debian 11 is already officially released :slightly_smiling_face:

Wow, just a few days ago, excellent, I will try to update, hopefully Raspbian can be updated as well.

Thanks! :grinning:

Ok, I saw raspbian, so a raspberry pi. I don’t think bullseye is available as download yet.

In a console :

sed -i 's/buster/bullseye/' /etc/apt/sources.list
sed -i 's/buster/bullseye/' /etc/apt/sources.list.d/*.list
sed -i 's|bullseye/updates|bullseye-security|' /etc/apt/sources.list
sed -i 's/bullseye/buster/' /etc/apt/sources.list.d/*mosquitto*.list
apt update
apt upgrade
apt full-upgrade
apt autopurge

Thanks, this will take some time… I’ll update once it works.

Good news, I can find it now after the update.

Unfortunately I can’t add any of my cameras … it say “Failed to connect” … any trick to it?
Also, I want to install Z-stick 7 and the guide I found instruct to go into "Supervisor " on the menu, but I don’t have that, am I missing another thing with this installation? : (

See :