ADT Pulse integration


You can shell and try. My apologies I’m not able to provide step by step instructions until the weekend.


Fair enough! Thanks a million!


Thanks for this integration. What is the best way to limit the frequency of requests to After looking at my pihole, it appears it is occurring every couple seconds.

Thank you!


It is set to 5 seconds to check changes - hard coded. However, there maybe multiple connections going on at times to check status of different components.


Would really like to get this working… Is the addon its own container with its own DNS?


Does the 5 second interval imply that updates may be delayed by up to 5 seconds and that short-lived events may be missed?


@digitalcraig. Thank you very much for your work on this add-on. I was using the Envisalink module up till now but have struggled with the 15 to 20 second delay on clearing zones. Your add-on has a better response time that will allow for better automation. I seem to have everything working correctly but i have two important questions.

  1. Is there a way to reduce the zone delay? Looks like its about 5 seconds. I believe some other people have pinged on this question as well.

  2. I am unable to get zone or control panel status after a reboot of HASSIO until the alarm is armed for the first time. Seems to be the issue after every reboot. I have not seen anyone else complain of this issue. Anyhing come to mind?

Add-On config.
“ssl”: false,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”,
“pulse_login”: {
“username”: “xxxxxxxxx”,
“password”: “xxxxxxxxx”
“mqtt_host”: “”,
“mqtt_url”: “”,
“mqtt_connect_options”: {
“username”: “xxxxxxxx”,
“password”: “xxxxxxxx”
“alarm_state_topic”: “home/alarm/state”,
“alarm_command_topic”: “home/alarm/cmd”,
“zone_state_topic”: “adt/zone”,
“smartthings_topic”: “smartthings”,
“smartthings”: false


password: !secret mqtt_password


The update frequency is hardcoded. It could be changed in the source code, but I don’t think it would be a good idea as it would probably be noticed and perhaps shutdown by ADT.

I haven’t experienced a delay after a reboot on zone updates, but I run it as a separate docker container and not as a add-on. Is the status of the panel not “unknown” or just not updated? If it’s unknown, make sure the MQTT broker is configured for persistence.


Thats a good point on the delay interval.

How do i configure MQTT for persistence?


@digitalcraig Think I could get some help on my DNS issue with the plugin? My Hassio instance can resolve the site just fine.


what are you using for an MQTT broker? Mosquitto has a persistence (true/false) setting in mosquitto.conf, a path to the persistence database, and an interval for autosave in the mosquitto.conf.


I don’t use, but how do you know it’s a DNS issue? How do you know hassio can resolve Do you have logs or something you could post?


I was advised that 18-10-18 11:21:32 Pulse: Authentication bad response error:{“code”:“EAI_AGAIN”,“errno”:“EAI_AGAIN”,“syscall”:“getaddrinfo”,“hostname”:“”,“host”:“”,“port”:443}

is a dns error. I have logged into my hassio instance with putty and did an NSlookup on as well as a curl to the url.


Got it all sorted… added a hosts entry in the container. Not ideal, but for some reason the DNS isn’t passing through to the container. Have a new issue… mosquitto_sub -v -t "adt/zone/# is returning nothing. I see the open/close, as well as my zones in the logs when the add-on starts


what about your state (default home/alarm/state) and command (default home/alarm/cmd) topics? Are you seeing anything there or is just the zone topic?


The home/alarm topics work, but the zones don’t. However, I was able to capture my zone names on startup, and everything works well… super happy with this, thanks for all your hard work building this


@haruny wrote the code for the zones and would be able to help better than I could, sorry.


@iva8524 could you provide your addon logs mqtt dump from start to finish in a pastebin or ?


Hi all,

I’m trying to run this on a Raspberry Pi with a docker container, using docker-compose:

     container_name: pulse-adt-mqtt
     image: digitalcraig/adt-pulse-mqtt:latest
       - /home/pi/pulse-adt-mqtt:/data

It say’s it’s starting, but then a ‘docker ps’ does not show it’s running. Are there pre-requisites for it? I’ve installed npm/nodejs.



Are you having trouble with it? Do you have e any logs or console output from docker?