Aeotec door sensor 6

Hi, I’m having the same issue you described, and feeling pretty defeated! I wonder if you could tell me more about your solution with a bit of a step-by-step? I’m running on a RPi3 but also have a desktop PC running Win10.
One other q in particular - you say you tried ozwcp by using your laptop - was that just something you had to do once, then take the laptop out of the equation permanently and everything works fine with RPi? Thanks!

Glad to tell you what I can, but all my computers run Linux, and therefore docker, natively.
I know that docker will run in some form on Windows 10 but I know nothing of the details, or whether it’s possible to do do the USB device pass-through on Win10. I suppose you could run a linux distro via VirtualBox, then install docker in the Linux VM. Come to think of it, if your VM was Centos7, like the docker container from my link, you could probably just cut and paste all the commands from the Dockerfile: and end up with a functional ozwcp.
Still the trick would be figuring out USB pass-though to the guest OS, but I believe VirtualBox supports that.

Anyway, if you end up going the route I did, it would be something like this.

git clone
cd openzwave-controlpanel
docker build --tag “ozwcp” .
docker run -p 8008:8008 --device /dev/ttyACM0 ozwcp

Then open a browser and point it to http://localhost:8008/

EDIT: never mind, I left out the . at the end. Rookie error! If only I could get the copy/paste working! I’m sure I’ll be back with another dumb q soon

Hi, ok I’m getting close! Would love some more help please.
I’m a total Linux newbie but learning slowly - I’ve installed Centos7 running within VirtualBox (incl. extension packs to enable USB passthrough); I’ve tried the commands as above and got this error message:

Hi, I got right through to running OpenZWave successfully in Centos7 on VirtualBox but I don’t think it can see my device. I think this is because the device is not Windows compatible.
As an alternative, could I run some version on Linux on my Pi (using a different microSD to the one that’s currently in it, running, and repeat your process using it?

… or could I boot Centos7 from a USB key, on my PC, and follow your process from there? Just looking to avoid dual-booting Centos7 with Windows10, which I’ve read can be problematic.


CentOS hasn’t been ported to arm as far as I’m aware. But you could try hassbian or raspbian on your 2nd SD card. I’m guessing there are how-to’s out there for compiling openzwave and ozwcp on those OSes. Haven’t done it myself. I’m sorry the VM didnt’ work out. Sounds like you put a good bit of work into it.

In other news, I recently removed and re-added the door sensor to my instance. Apparently, that resets the options. I tried for kicks to see if I could put the setting back using the z-wave console in HA, and it actually worked this time. Might be worth a try.

thanks, it was a lot of work, I don’t mind it though, very educational :slightly_smiling_face:

I’ve tried removing and re-adding, no dice. Trying a new OS on a 2nd SD card sounds tough, might save that option for now.

The device does seem to be detected by VirtualBox but it just doesn’t appear anywhere here:

Looks like you’re nearly there. Try un-checking the usb box ( i know, counter intuitive). Then you need to enter the name of the z-stick device into the “Device name” field and hit “initialize”. The device name in my case is /dev/ttyACM0 but for some folks it’s /dev/ttyUSB0
Run ls /dev/tty* to see if you have one of those device names.

OK I’ve made some progress! I ran the ls /dev/tty* command and the device wasn’t showing up, then I realised I needed to select it from the Devices menu in VirtualBox for it to be seen by the Guest OS. Ran the command again, and there appeared ttyACM0 :slight_smile:

I changed the reporting to Binary, but then immediately after that, ozwcp said my sensor was ‘unknown’ and when I moved the z-stick back to my RPi, it couldn’t see it either. So I removed and re-synced etc.

At the moment I’m trying to get a solution through a different thread - Can't get sensor to act as binary - still not sure if I have a problem or I just don’t know where to look to see the changed value when I trigger the sensor, which value is changing, and how to use that changed value.

I am confused as in my entities I see my zwave.door_sensor_sensor but after changing the reporting to binary sensor I get a binary_sensor.door_sensor_sensor however am confused where you got the sensor.frontd_alarm_level_5_1 as I do not have any sensor.door_sensor_sensor_anything

I didn’t change the reporting to binary, I created a binary sensor using the script in my previous post placed into the file ‘binary_sensors.yaml’. It then reads out as ‘Open’ or ‘Closed’.

It references the “sensor.frontd_alarm_level_5_1” or “sensor.frontd_alarm_level” ( I think it changed) for the status.

Where are “sensor.frontd_alarm_level_5_1” or “sensor.frontd_alarm_level” pulling from as my zwave.door_sensor_sensor does not create any sensor. where as my multi sensor 6 created a sensor.temperature, sensor.burglar, sensor_alarm etc. but the only two I can see for the door is zwave.door_sensor_sensor and the binary.sensor_door_sensor_sensor I created using your template. Thanks in advance!

Can you removed and then re-add the sensor? It doesn’t seem like it configured properly. I cant remember if it needs to be added as a secure device.

@davisj, would you believe, the reason why I couldn’t get my Reporting to switch from Basic to Binary was because I didn’t have my sensor (door sensor) awake when I was making the change? Woke it up, and boom - problem solved.


This is great stuff! I was having this issue with an Aeotec by Aeon Labs ZW097 Dry Contact Sensor on I went into Configuration > Z-Wave and then chose my node, went down to Node Config Options. There I picked Report Type in Config Parameters and then chose Sensor Binary Report from the list. When I went to Set Config Parameter I made sure to hit the trigger button on my sensor a few times to wake it up. After that all is well! Works like a champ!

Thanks again for all the info!


I only read the first dozen replies to this thread so I apologize if this was said already, but I just did this last night using HA, no Open ZWave Control Panel needed. When trying to change the report type to binary you simply need to retry until it sticks. When in the Zwave config menu, wake up the sensor and then try changing the setting. If it doesn’t stick you’ll know because the setting will change back to Basic Set. You’ll know it stuck if Binary Report grays out. Even though you properly wake the sensor up it doesn’t always accept changes every time so again just try again until it works. Sometimes can take 5 times before it sticks, but it will eventually. Being closer to your controller seems to increase the chances of it working. Hope this helps someone.

1 Like

Great to hear, mate! What a pain but very satisfying when you get it sorted. Sums up tech in general!

Anyone having issues on 66.1 I am no longer able to chose between the sensors but it shows all sensors in my states. However binary_sensor.front_door1_sensor stays on(Open) at all times and does not toggle off(Closed) When closed. sensor.front_door1_access_control, sensor.front_door1_alarm_level, sensor.front_door1_alarm_type, sensor.front_door1_sourcenodeid also do not change when door is open or closed. I also noticed I only get parameter #9 now, no longer get the standard 121 and other parameters.

Thanks for this - this was driving me nuts but after 5 retries near the controller it worked - weird we had to do this but as long as its reliable now I dont mind