Again iOS and certificates driving me nuts!


I searched everywhere for 5 days and tried everything I could but can’t figure this out.
I can connect from my work to my HA via Web Browser and inside my home with Browser, Homekit and Home-Dashboard (Android). The only app thank refuses to connect is the official HA App for iOS.
I really don’t know how to solve this. Here’s all my configs and the error my iPhone shows…
I’m usisng Let’s Encrypt.

Could someone please help me?

Sorry about my English, my native language it’s Portuguese.

Thank you!

In the first picture you redirect twice port 80. That is not possible. You better use reverse proxy. Look around in this forum for examples.

I just used the second redirect of 80 because I read that Let’s Encrypt needs it for the certifiicate.
If I remove it I will get the same results that I mention before. Going to remove it but I’ll get the same error at iPhone and iPad.

There are several guides to help you set up a reverse proxy.

Look at:

1 Like