Alexa Media Player as integration where are the email & pass stored?

I installed Alexa media player many months ago and it had been working fine. I changed my amazon password a few days ago then today logged in to HA to try to change the same. My HA installation and Alexa media player have updated to the latest version such that the config is now part of the main integrations page. I can access the config page to enter my information but when I enter it gives me this message:

“Email for Alexa URL already registered”

All I want to do is enter the password but that not an option I have to enter all the info.

So my question is where/how can I find this information to change or reset it?

I have deleted the pickle file and rebooted but arrive back at the same point. It’s not contained in my config yaml.

Any help appreciated.

Solved it, for anyone else stuck in the same infuriating loop I had to manually edit the ‘core.config_entries’ file. Surprisingly the password is stored unencrypted but anyway Alexa is back speaking so problem solved.

6 Likes

FYI… per the above answer, to help clarify for others, the core.config_entries file is in the .storage which is in the HomeAssistant config folder so the full path is:

/config/.storage/core.config_entries

6 Likes

Thank you thank you thank you thank you thank you. Unbelievable to have to do all this to change an email address.

Thanks for this. Should really be added to the GUI somewhere or at least a line in the FAQ.

1 Like

Thanks, that was helpful. I installed home assistant (formerly hassio) on Armbian. For me, the full path was /usr/share/hassio/homeassistant/.storage/core.config_entries
I found it via the locate command (apt install mlocate)

1 Like

how did you save it after change. mine keeps saying file protected. i dont know how to stop that. im using unraid server accessing it via a windows pc. thank you.

Hi Clint, mine runs on a Pi so I just used terminal to edit the file. Your problem has to be a file permission issue rather than anything to do with HA but sorry I’m not familiar with unraid. Good luck!

It’s a permission issue, assuming you’re a sudo user run it as:

sudo nano core.config_entries

enter your sudo password and make the changes inside the file.
To save and exit: CTRL+X, select Yes then Enter