Another component for ZiGate


#204

Hi all,

after some tests, I realize that my current home setup with programmable plug is not the best for Home Assistant enviroment. After removing it all, lights are correctly synced :sweat_smile: So everything solved.

Have a nice new year’s eve!!


#205

Hi, more tests bring me here :sweat_smile:

I have bought 2 aqara bulbs from xiaomi, bulbs are well detected. I can turn them off and on.
I can also change the brightness but not the color_temp, it doesn’t appear nothing to change that.
Those bulbs are capable of 2700K-6500K. I put here some pics just in case someone can help me.

Thanks in advance!!


#206

I’m currently improving a lot light support , including color temperature management.
So you just have to wait a little, fews days, and I think it will works


#207

Thanks @doudz! more than happy to hear that


#208

Hi, I have updated zigate component and I am finding strange behaviours.
I can see this in the log file:

2019-01-10 20:39:24 WARNING (SyncWorker_0) [zigate] No template found for LWB010
2019-01-10 20:39:25 WARNING (SyncWorker_0) [zigate] No template found for LWB010
2019-01-10 20:39:26 WARNING (SyncWorker_0) [zigate] No template found for Plug_01
2019-01-10 20:39:26 WARNING (SyncWorker_0) [zigate] No template found for lumi.light.aqcn02

Previuos paired lights still work, but I have tried to pair another aqara bulb and now is not detected/paired.
Regarding the other aqara bulb paired preivously before updating, it works but stil can control the color_temp.

Should I rollback?


#209

Have you tried to call “discover_device” service on the device ?


#210

You can also “generate_templates” and send files to me in order to include them in the next release


#211

Hi,

I received my zigate this week and tried to play with it this weekend. Using the python zigate librairy I was able to connect some devices.
However I’m unable to use it with Homeassistant, it keeps says ‘Failed to connect, retry in xxsec…’

I don’t know what I’m doing wrong. I updated zigate to firmware version 3.0e and homeassistant is in version 0.85.1


#212

Are you using USB or wifi version?


#213

I’m using the USB version.


#214

Are you sure that you select the right USB port ?


#215

First I didnt specify a port, i then tried to add /dev/ttyUSB0 (it is the one that registered when pluging the zigate), it didnt seem to solve the issue.
I can retry this evening.


#216

When you didn’t specify the port, the plugin will try to find it but it can fails if there’s another USB key that looks like zigate (zwave usb key for example)


#217

It was my understanding that the plug-in will try to detect the port. In fact, with your python library the Key was autodetected using the comand z = zigate.connect(port=None) from the readme !
I have no other USB pluged into raspberry pi3.


#218

Ok guys I figured it out… and I feel very dumb !!

It turns out that I forgot to add the homeassistant user to the dialout group wich is mandatory to read/write to /dev/ttyUSB0 port. I’m now able to connect to the zigate.

Anyway thanks for your help and sorry to have bothered you


#219

Hi @doudz, sorry bit I do not understand. Seems to be something new that it didn’t happen before the code upgrade. Correct me if I am wrong but I didn’t have to add a template for any component.

I mean, I plug two Philips bulbs and a osram plug and they were detected from the scratch. After the upgrade you can see, it says no templates for those components


#220

Just to inform, I update the component with last version in the repository and everything is working ok.
No weird messages in the logs and I can control the colour temperature of the aqara bulbs.


#221

Can you please explain this?
I have a lot of message of missing templates and now zigate entities need a lot more time to be available in hass after a restart.


#222

Missing templates is not really a problem, a template give just a chance to create entities without waiting for a value change.
I don’t notice a slow down, I’m running HA on a Rpi3.
could you explain ?, provide log ?


#223

Here’s what I get after a restart, after 10 seconds, hass ui is available. But for the next 45 seconds I get this:


I did not notice the exact version it happens the first time but probably 0.25.0
Here’s the (sorry) long log of full restart https://pastebin.com/cm6QwKJP