Anyone else having MODBUS issues?

I found this ticket, they claim it will be solved in dev and will be released in 2023.9.2:
Victron/Modbus disconnects/unavailable · Issue #100138 · home-assistant/core · GitHub
That ticket is specifically about the Victron module, but it looks like the tickets I put in the next post talk about the issues with pymodbus and how they will upgrade that package in 2023.9.2. Setting your timeout to be bigger may be a kludge to get it working for now.

These tickets look like they might be more relevant:

For information I can tell that my problems with closed connections were solved in 2023.9.2

Same problem for me now in 2023.9.3.
My charging station is constantly crashing because of this and needed to revert to 2023.9.2 to resolve it.

Oh noooes…! I guess I’m staying with current version for a while…

Has anyone tried the 2023.10 release yet? How is it working?

Hello, is your Modbus configuration working? I’m learning this to access my Modbus, do you have any information to share, thank you

there has been breaking changes in the modbus integration so configurations that were previously working have stopped. It was resolved in 2023.9.2 and was reported broken again in 2023.9.3 by some users. The question is if its working as intended in 2023.10?

Hi Y’all, I’m having Modbus issues too. I have a number of hardwired (RS485) RTU devices with various timings, and I think sometimes they timings coincide causing a network overload. (a timeout error) It looks like the new revision then spends some time cleaning up buffers which causes it to miss the next modbus poll and the whole thing turns to custard for a while. I cannot run update 9.5, and have had to revert to version 8.5.

Hey guys. I have problems with the modbus. I’m noob in it and will be great to have some help. i recive this error:

2024-02-09 20:46:30.444 ERROR (SyncWorker_11) [homeassistant.components.modbus.modbus] Pymodbus: netp: Error: device: 3 address: 30021 → pymodbus returned isError True

And this is my config:

Screenshot_26

Thanks in advace !!!

This is my settings from the convertor