Aqara Lumi EU smart plug in ZHA not reading power consumption

at the end it started work also for me. for anyone interested - i have updated the firmware (you can find a way in post above) and then re-pair the device in ZHA. I did this also before, but somehow now it magically worked and i am able to see the power consumption data

1 Like

Hello,

I do have the same issue. Could not do the firmware update as it seems mine have a more recent one

[2022-08-29 11:28:00.853 DEBUG (MainThread) [zigpy.zcl] [0x7C87:1:0x0019] OTA query_next_image handler for 'LUMI lumi.plug.maeu01': field_control=FieldControl.0, manufacture_id=4447, image_type=24, current_file_version=41, hardware_version=None, model=lumi.plug.maeu01

2022-08-29 11:28:00.863 DEBUG (MainThread) [zigpy.zcl] [0x7C87:1:0x0019] OTA image version: 32, size: 278094. Update needed: False

Signature looks also good:

{
  "node_descriptor": "NodeDescriptor(logical_type=<LogicalType.Router: 1>, complex_descriptor_available=0, user_descriptor_available=0, reserved=0, aps_flags=0, frequency_band=<FrequencyBand.Freq2400MHz: 8>, mac_capability_flags=<MACCapabilityFlags.AllocateAddress|RxOnWhenIdle|MainsPowered|FullFunctionDevice: 142>, manufacturer_code=4447, maximum_buffer_size=127, maximum_incoming_transfer_size=100, server_mask=11264, maximum_outgoing_transfer_size=100, descriptor_capability_field=<DescriptorCapability.NONE: 0>, *allocate_address=True, *is_alternate_pan_coordinator=False, *is_coordinator=False, *is_end_device=False, *is_full_function_device=True, *is_mains_powered=True, *is_receiver_on_when_idle=True, *is_router=True, *is_security_capable=False)",
  "endpoints": {
    "1": {
      "profile_id": 260,
      "device_type": "0x0051",
      "in_clusters": [
        "0x0000",
        "0x0002",
        "0x0003",
        "0x0004",
        "0x0005",
        "0x0006",
        "0x0009",
        "0x0702",
        "0x0b04",
        "0xfcc0"
      ],
      "out_clusters": [
        "0x000a",
        "0x0019"
      ]
    },
    "242": {
      "profile_id": 41440,
      "device_type": "0x0061",
      "in_clusters": [],
      "out_clusters": [
        "0x0021"
      ]
    }
  },
  "manufacturer": "LUMI",
  "model": "lumi.plug.maeu01",
  "class": "zhaquirks.xiaomi.aqara.plug_mmeu01.PlugMAEU01"
}

Any idea what could be wrong ?

Thanks !

Hmm it seems there’s a try with my firmware version : https://github.com/zigpy/zha-device-handlers/pull/1656
I’ll check that and report here if its works !

using this custom quirks do the trick if you have a newer firmware (41). If you have < 32, update to 32 and you’re good to go with official quirks. If you have latest 41 firmware, use custom quirks.

2 Likes

In my system, it shows up without the power usage entity at all.

The device seems to be running FW version 32.

The device signature looks like this:

{
  "node_descriptor": "NodeDescriptor(logical_type=<LogicalType.Router: 1>, complex_descriptor_available=0, user_descriptor_available=0, reserved=0, aps_flags=0, frequency_band=<FrequencyBand.Freq2400MHz: 8>, mac_capability_flags=<MACCapabilityFlags.AllocateAddress|RxOnWhenIdle|MainsPowered|FullFunctionDevice: 142>, manufacturer_code=4447, maximum_buffer_size=127, maximum_incoming_transfer_size=100, server_mask=11264, maximum_outgoing_transfer_size=100, descriptor_capability_field=<DescriptorCapability.NONE: 0>, *allocate_address=True, *is_alternate_pan_coordinator=False, *is_coordinator=False, *is_end_device=False, *is_full_function_device=True, *is_mains_powered=True, *is_receiver_on_when_idle=True, *is_router=True, *is_security_capable=False)",
  "endpoints": {
    "1": {
      "profile_id": 260,
      "device_type": "0x0051",
      "in_clusters": [
        "0x0000",
        "0x0002",
        "0x0003",
        "0x0004",
        "0x0005",
        "0x0006",
        "0xfcc0"
      ],
      "out_clusters": [
        "0x000a",
        "0x0019"
      ]
    },
    "21": {
      "profile_id": 260,
      "device_type": "0x0051",
      "in_clusters": [
        "0x000c"
      ],
      "out_clusters": []
    },
    "31": {
      "profile_id": 260,
      "device_type": "0x0051",
      "in_clusters": [
        "0x000c"
      ],
      "out_clusters": []
    },
    "242": {
      "profile_id": 41440,
      "device_type": "0x0061",
      "in_clusters": [],
      "out_clusters": [
        "0x0021"
      ]
    }
  },
  "manufacturer": "LUMI",
  "model": "lumi.plug.maeu01",
  "class": "zigpy.device.Device"
}

Also, I don’t see any applied quirks in the Zigbee info:

image

Is it enough to click “reconfigure device” until it shows up, or do I need to remove and pair it again?

EDIT: Nevermind, I returned the plug to the store and bought another Frient instead, that has worked flawlessly from the start.

Hi, with firmware #41 pre-installed on the plugs, installing the custom quirks in home-assistant fixed it for me. thanks.

EDIT: The new ZHA quirk for that plug is included with Home Assistant Core 2022.10.5 (and later).
Please remove the custom quirk if you’ve installed it previously.

FYI, the custom quirk should now be compatible with both the old firmware and the new firmware of the MAEU01 plugs. So if you’re having trouble with any of them, try installing the custom quirk and then re-pair the plug.
(Downgrade instructions for the firmware can also be found in the OP of the PR but that should only be required if you’re having issues with IKEA remotes “randomly” toggling the switch.)

Currently, all MAEU01 plugs will have to be re-paired after installing the custom quirk in order to show correct power readings. Hopefully this can be resolved until the quirk makes its way into a later official HA release.

EDIT: The new ZHA quirk for that plug is included with Home Assistant Core 2022.10.5 (and later).
Please remove the custom quirk if you’ve installed it previously.

Thanks for this quirk. After installing it, repairing and restarting HA I got a reasonable Electricalmeasurement reading.
Don’t forget setting permissions for user homeassistant for the new created directory and files

Hey everyone,

The “custom quirk” is now included with Home Assistant Core 2022.10.5 (and later).
It’s recommended to uninstall the custom quirk before you upgrade to that version.
If you’ve already installed 2022.10.5, then just delete the custom quirk, reboot HA, and the “official quirk” should be used by ZHA.

If you didn’t install the custom quirk and have issues with your Aqara MAEU01 or MMEU01 plugs now, please remove the device from ZHA and re-pair it. If you still have issues then, create a new issue here: Issues · zigpy/zha-device-handlers · GitHub and tag me there.

You advised me the same about a week ago, but I found this topic which made me realize this problem has been going on for at least a year. How long does it take to solve this issue?

My topic:

The issue that was discussed has long been solved. Most current cases are completely user-error (e.g. Conbee firmware not being up-to-date, not properly re-pairing the plug, still having installed outdated custom quirks, …)

In fact, I’m using six Aqara Smart Plugs (MAEU) and two Xiaomi Smart Plugs (MMEU01). Both have varying firmware versions and they work without any issues whatsoever.

You also didn’t fill out the issue template in your GitHub issue nor did you provide diagnostic information or what version of Home Assistant Core you’re running. I’ve answered in the issue (and want to continue discussion there), but such issues will generally be closed or ignored.

(Remove the plug from ZHA, allows joins, then reset the plug and let it join the network again. Then attach a load, turn the plug on, and see if the values update after a few seconds/a minute.)

I’m using SkyConnect, not sure how to, if even possible, to update the firmware on this. Assuming they come with the latest firmware. Can’t find an option in ZHA to update firmware for devices nor the diagnostics asked in the template, hence I could not provide them. I will try your suggestion later today, but in general I’m not very happy at all, either ZHA or SkyConnect - not sure which is causing my issues.

1 Like

For anyone el servicio with this issue that uses conbee 2, I hzve just solved it by upgrading the conbee 2 stick firmware following the steps at dresden webpage Update deCONZ manually · dresden-elektronik/deconz-rest-plugin Wiki · GitHub

After that, I removed the aqara plug from home assistant and paired it again. Now i got the power consumption, voltage, energy consumption and even device temperature fully working (not power factor though, but i dont care about it).

Hope that it helps :slight_smile:

2 Likes

Thanks for the update, it seems to work fine now!
Followed the instructions for upgrading Conbee II firmware. Upgraded to version deCONZ_ConBeeII_0x26780700, deleted plug from HA and readded it. Right now I am testing with my notebook and its showing values between 16 and 36 Watt. Will try with the washing machine tomorrow.

Works perfect :sunglasses:

Nothing works, I’m not 2024.04.03. Any idea? Posted on GitHub too.

It’s an Aqara smart plug, app version is 43 (as opposed to reported 32 above) and I use a Sonoff Connect stick.