Are Meross switches compatible with any existing components?


#8

Does this method rely in any way on Meross’ servers? The IFTTT one does and even though the delay is very small in my tests (<5 sec) it would be good if we circumvent Meross’ servers altogether.


#9

As far as I know, responses aren’t yet supported. I think this has to do with the fact that the command feature was a happy accident and isn’t the main focus of the add-on. Maybe add a feature request on the add-ons forum post or github?


#10

Actually, I’m not sure. I would have to test it by denying the switches net access from the router and see if they still respond. Will keep you posted.


#11

Thanks, just got my Raspberry Pi 3B+ and set it up with HassOS over the weekend. I tried the add-on myself and controlling my two Meross switches worked quite well with it. However, I will most likely swap them out for some TP-Link HS110 soon because they are just way more convenient to handle with Home Assistant, plus displaying the energy monitoring values also works perfectly fine.

The Google Assistant method does rely on the Meross servers, that’s the main reason why you need to log in to your account when connecting the switches to your Google Assistant.


#12

Hi, I have 2 Meross 16A switches which I could command via Google Home Mini, but I’d like to use them also in Home Assistant. I’ve installed the Google Assistant Webserver, but I don’t know how to integrate them in Hassio.
Could you please help me with step-to-step instructions?
Thanks a lot!


#13

I apologize in advance as I may not be much help. The addon is currently not working for me and I no longer use the Meross switches. As such, I cannot test the setup to give you a proper step by step, but I can point you in the right direction.

You need to follow the instructions for the addon on its forum thread here: Google Assistant Webserver

One of the first links on that page will send you to these instructions in order to obtain a json file from google that you need to rename to “google_assistant.json” and place in your share folder. You only need that json file, so once you have it stop following those instructions.

Start the addon, go to http://[HASSIO LOCAL IP]:9324 and follow the instructions.

Then we test broadcast to make sure everything is up and working. Enter this into a web browser:

http://[HASSIO LOCAL IP]:5000/broadcast_message?message=check check is this thing on

If it is, then we can setup your switch in HA as a command line switch.

It would look something like this:

switch:
  platform: command_line
  switches:
    living_room_light:
      command_on: "/usr/bin/curl -X GET http://[HASSIO LOCAL IP]:5000/command?message=turn on living room light"
      command_off: "/usr/bin/curl -X GET http://[HASSIO LOCAL IP]:5000/command?message=turn off living room light"

Good luck!


#14

Thanks a lot, I’ll give it a try. I’m a noobs about this… but I’ll study! I’ll write what happens…


#15

Ok, test done (http://[HASSIO LOCAL IP]:5000/broadcast_message?message=check check is this thing on). So Google Assistant Webserver status is on.

I write the command line switch as you wrote, changing IP and name of the switch in “filter”,

switch:
  - platform: command_line
    switches:
      filtro_piscina:
        command_on: "/usr/bin/curl -X GET http://192.168.1.110:5000/command?message=turn on filter"
        command_off: "/usr/bin/curl -X GET http://192.168.1.110:5000/command?message=turn off filter"

Rebooted Hassio, I have the switch, but using it nothing happens

If I write directly into browser: command_on: “http://192.168.1.110:5000/command?message=turn on filter” it works like a charm.

Why???
Help needed…

SOLVED!!!
In command line I must use %20 instead of space, this way it works!!!

command_on: “/usr/bin/curl -X GET http://192.168.1.110:5000/command?message=turn%20on%20filter
command_off: “/usr/bin/curl -X GET http://192.168.1.110:5000/command?message=turn%20off%20filter


#16

Here’s an idea - we could use Wireshark to capture the packets that run to and from the switches upon using the app or ifttt and send/read these directly in Home Assistant. Sadly, I won’t have access to a Meross switch until Christmas (left them at parents’ house).
I am keen to collaborate though, so let me know. :slight_smile:


#17

Hi all
I just got one of this WiFi surge protector MSS425E.

If I can do anything to let this product compatible with HA, let me know.

I don’t know where to start, but I can try… :upside_down_face:

The method described by @mayker is nice, but maybe there is another way to let it work.


#18

I’ve got one of their outdoor 2 outlet WiFi outlets. Happy to work to provide packet captures if you’re interested in trying to reverse the system to make it work without internet access!


#19

I’ve installed Wireshark, so I’ll check too :wink:


#20

Did somebody capture any packets?


#21

I’m working on it…


#22

I’m trying too…! :sunny:


#23

No success till now. Quite a shame!


#24

This meross have now a cheap full line of products


#25

You can get now two Meross smart plugs on amazon for a little more than the tplink hs110 costs. I hope someone will soon write a Hass component for meross. I‘d be super excited…


#26

I was not able to capture packets.
My 2 cents about Meross are these two links I’ve found:
https://github.com/albertogeniola/MerossIot and https://github.com/Apollon77/ioBroker.meross.
I hope someone could implement the Meross switches in HA…:crossed_fingers:


#27

I have never understood what they gain with thislock to the cloud. Iam sure they would sell more if tjey had an open api.