✔️🆒Argon One Active Cooling Addon

Restart the app Will help i have the same

I have the WDgreen m.2 240gb

It would help to see a log of a sensor change. This sensor isn’t registered in HA. It’s an API entity so it might just be that it’s not updated for a period of time and it’s timed out. Try lowering your temp so it kicks on once in a while. If it’s always off it doesn’t report. I could see about making a report on some regular interval. Do you happen to know how long until it goes offline?

I got lost, I always have low temp, perhaps If I change the threshold to a really low, and see if that change?

adamoutler, thanks a lot for your work!
I change to reboot the host on double tap.

I read on other topic a mention about the AMWAYS ON.
Is there a way to manage it with your addon?

Thanks.

I think you’ll need a hardware upgrade as did I. The always-on mode is not available on the original hardware. They did a factory-only firmware upgrade to a relatively small number of V1 devices before releasing a V2 Hardware. The V2 has a physical jumper for always-on mode.

In this picture you can see both v1 and v2. V2 has the full size HDMI ports.

Which version of the Argon One case do you have?
In the newer ones there is simply a jumper pin on the circuit board. In my case it is described on page 6 of the case documentation.

Interestingly I have here a V1 case with the jumper. :slight_smile:

Yeah so there was a v1, with no always on, a v1.1 which was just the firmware mod, then finally a v1.2 that had the header but was still the old power socket/button location on the back. The v2 what had the power button and socket moved to make room for the full size HDMI ports followed very quickly after the 1.2 showed up

(Edit: I don’t know if 1.1 and 1.2 were the actual numbers on the boards, just that that’s how many publicly released distinct versions there were :stuck_out_tongue:)

1 Like

If you want to try the i2c command then you can use the community terminal addon to run:

apk add i2c-tools
i2cset -y 1 0x01a 0xfe

This should take care of it. I’m not keen on adding an extra optional setting that’s only needed and possible on a small number of older boards. I’m trying to keep it lean, mean, and clean.

The revision number is 200402v5
Do you know for this version ?

I didn’t know the community terminal addon, I will look.

Thanks all!

➜  ~ apk add i2c-tools
fetch https://dl-cdn.alpinelinux.org/alpine/v3.13/main/aarch64/APKINDEX.tar.gz
fetch https://dl-cdn.alpinelinux.org/alpine/v3.13/community/aarch64/APKINDEX.tar.gz
(1/1) Installing i2c-tools (4.2-r0)
Executing busybox-1.32.1-r2.trigger
OK: 281 MiB in 198 packages
➜  ~ i2cset -y 1 0x01a 0xfe
Error: Could not open file `/dev/i2c-1': Operation not permitted
➜  ~

I can’t execute the last command, on HASS.IO all updated.
Do you think there is a workaround?

Use the community terminal addon and disable Protection Mode.

This addon is deprecated, so I followed the advice, I installed “SSH & Web Terminal”
I disabled the protection mode (then I have the security alert), but still the same problem.

Well I’ll be. Looks like a bug to me. I guess we gotta do this the more difficult way…

See if this works

docker exec -it $(docker container ls|grep argon|awk '{print $1}') bash -c "apk add i2c-topols; i2cset -y 1 0x01a 0xfe"

If not, then do docker container ls|grep argon. Use the first column of hex chars as your MYID for this command docker exec -it MYID bash. Once in that container, run the apk add and i2cset.

Hummmm, sorry. I forgot to restart the addon after disabling the protection mode.

So I tried again " i2cset -y 1 0x01a 0xfe" then I have this error :

docker exec -it $(docker container ls|grep argon|awk '{print $1}') bash -c "apk add i2c-topols; i2cset -y 1 0x01a 0xfe"

Need I to continue with your other command?

You might try a screenshot. This is what is expected


The fetch is optional. No output if successful.

Pfff, sorry again… wrong copy/past…

The error for " i2cset -y 1 0x01a 0xfe" is :
zsh: command not found: i2cset

Yeah, you’ll need to get into an authorized container to access the i2c bus.

They’re making all kinds of changes to supervisor right now. That’s why the Terminal Addon isn’t working properly. No protection mode should mean access to all devices. But there’s some sort of issue with it.

I tried this :

docker exec -it $(docker container ls|grep argon|awk '{print $1}') bash -c "apk add i2c-topols; i2cset -y 1 0x01a 0xfe"

I get :

fetch https://dl-cdn.alpinelinux.org/alpine/v3.13/main/aarch64/APKINDEX.tar.gz
fetch https://dl-cdn.alpinelinux.org/alpine/v3.13/community/aarch64/APKINDEX.tar.gz
ERROR: unable to select packages:
  i2c-topols (no such package):
    required by: world[i2c-topols]

I don’t understand this :

If not, then do docker container ls|grep argon . Use the first column of hex chars as your MYID for this command docker exec -it MYID bash . Once in that container, run the apk add and i2cset.