Atlas Scientific Wi-Fi Hydroponics Kit example yaml

EE here. The resistor to earth ground has me very curious. When connecting a local reference to earth ground, you generally used a high resistor value (100k - 1M) in parallel with a high voltage ~200pF cap. This acts like a filter to shunt high frequencies out of your ground.
Are you using the isolation that AS has for the EZO? Mentioned above even a battery didn’t provide a good signal, which is surprising unless you’re somehow getting conduction through the probe.
I have been thinking of getting this kit, so its good to know some of the shortcomings. I’ll be interested to throw an Oscilloscope on it to see what noise i see.

I have the pool kit since a year and could not get the ph reading to work. I’ve even changed the probe to a lab version to see if it worked, but still the ph values where not stable jumping ±1. Thinking it was my powersupply I changed that, also tried a powerbank but it would not stabilize. thinking it was interferance I added a copper braid around the ph cable and earthed it. nothing really helped. Today after reading this I tried to earth the pool kit too. This worked!! So I earthed it using the GND terminal, a copper wire a spike in the ground.


See the line! its really stable now. dont mind the values, i have not calibrated it yet.

It also stabilized the orp values too

Glad to hear it @Stefanh . Send some photos of your solution? :smiley:

Yes please show some pictures or diagram how you have done this. I also have a Pool-kit but can’t get pH to be stable to be usable, jumps between 6.9000 - 7.4000 so would be great to see how you managed and if it still works for you. @Stefanh

Its really simple, no resistor or anything like that. just copper wire to earth. about 1 meter from my poolkit I drove down a copper 1 meter spike for earthing electric animal fences. I drilled a hole in the chassi to the poolkit for a copper wire (sealed the hole with hot glue). Connected the GND used to the copper wire thats connected to the spike. I choose GND thats the same used for the 4 pin bus connector that used for the pump. I also, before, wrapped the leads, both orp and ph and connected them with a copper wire to the spike too. My readings are now rock solid.

Great, thanks for your replay. I got help from the Atlas support as well. They wrote me this

"Yes, we know what that issue is.
When you see jumping pH readings, it means you have a very noisy power supply.

It is possible to “fix” the power supply by eath grounding your wifi pool kit.
Try connecting a wire to the GND spot on the terminal block used for an external pump.
Connect that wire to an earth ground.

You also have the option of connecting the Wifi kit to the USB port of a laptop running on its batteries. That should remove the noise. I am not suggesting this is a permanent fix; rather, it is a simple way of verifying the source of the problem.
"

So I tried it out and correctly my pH reading became rock solid. I also have the tri-pump and as soon as I connect that power adapter the reading become unstable again so it seems like the pH readings is very sensative. Atlas proposed to buy earth-grounded USB power supply and try it out. (In US search on Amazon for this “B085TC9N3K”). I have found another one because I’m in europe but will see toninght if it works with both pH reading and the Tri-pump. Will report back here

1 Like