Automation Editor not showing - Uncaught TypeError: localize is not a function

I’ve updated Hassio 0.80.2 today and noticed that the history not loading and found that there is an open issue for it at github

I was gonna use the automation editor, as I click the plus icon, I got an empty screen with the following error in the logs.

      'message':' Uncaught TypeError: localize is not a function'

… and yes I do have automation: !include automations.yaml in my configuration.yaml

Anyone has any idea about this?

Just to say “me too”.

Same issue here

This is the complete error:

Uncaught TypeError: localize is not a function
at HTMLElement.computeName (33edb6cd2a122b3482d9.chunk.js:74)
at runMethodEffect (app-96e769d2.js:1067)
at Object.runComputedEffect [as fn] (app-96e769d2.js:1067)
at runEffectsForProperty (app-96e769d2.js:1067)
at runEffects (app-96e769d2.js:1067)
at runComputedEffects (app-96e769d2.js:1067)
at HTMLElement._propertiesChanged (app-96e769d2.js:1067)
at HTMLElement._flushProperties (app-96e769d2.js:1438)
at HTMLElement._flushProperties (app-96e769d2.js:1067)
at HTMLElement.ready (app-96e769d2.js:1067)

Same here. Seems to me this is a bug that came with the latest update.

There has been a history of automation tab problems with 0.80:

0.80 - the panel came up blank when click on an existing automation or the + button to make a new automation
0.80.1 - all seemed to work
0.80.2 - + button gives a blank page but clicking on an existing automation seems to work correctly.

As far as the history matter is concerned, I suggest we stick to this thread:

same here!

update to 0.80.3

How can I do that (upgrade to 80.3) if it doesn’t show up as an option in Hass.IO>System?

still the same problem after update to 0.80.3
Automation Editor is showing a blank site.

Try clearing your cache (although I didn’t need to).

And as always, post your logged error messages.

I can confirm that upgrading to 0.80.3 fixed the problems.

Thx for the hint with the cache, problem fixed…
Sorry for not posting the log files, forgot about that.