Automation issue - Automation triggers even when its deleted from Hassio!

Hey guys, I have an Aeotec multi-sensor installed at the front door, I automated it so when it detects a motion, it sends an iOS alert to my phone, and turns outside down-lights (Controlled via Aeotec double switch) on, then off after 5 minutes if no motion is detected.

Now, I could not turn off this automation from the Hassio GUI. I wanted to start again, so I’ve deleted all of my automations on my Hassio build (v0.58) but the sensor automation is still getting triggered!

I installed a fresh Hassio 0.69 build (Vanilla config, no changes at all) and again the sensor automation still works! how is this possible, where is this automation getting triggered from!!

I suggest you check in your logbook if the automation is really triggered. If you’ve deleted the automation (and reloaded the autmations or rebooted HA) it should not trigger anymore.
Sounds like either automations have not beed reloaded, HA not restarted, or the automation is running from a different HA instance (in case you have more than 1?)
Also is there any chance you set up an automation/script 3rd party app that could trigger the iOS notification / downlight outside of HA

@lolouk44 HA has been restarted multiple times. This is a fresh install of Hassio on new MicroSD card, and the automation is still getting triggered! I’m so puzzled!

No automation/script on 3rd party apps. My setup is very simple, I have 1 x multi-sensor, 1 x Aeotec switch for outside lights, and 3 x door/window sensors. And I just managed to integrate my Google home assistant.

Sounds to me as if you have associated your multisensor with your light switch in zwave, so you will need to break that association (if that’s what’s happening)


If these are zwave devices, could it be that you’ve got them in a group association and it is setup directly to trigger that light the same way you HA automation was doing?

1 Like

@keithh666 @jolaca you could be right. I just looked at the node group associations, and can see 5 associations. I don’t even remember playing with this, how do I remove it?

Not sure, I think I had it once and deleted the node and added it back, but there may be another way.

Edit you may want to look here…

1 Like

@keithh666 thank you, I’ve just stumbled up on this as well. I’ll give it ago and update you guys.

Hi again, just remember that the ‘Lifeline’ association is the main one that just keeps contact and reports to the zwabe hub. If you have some kind of triggering, as I understand it, it should be inside another group association.

EDIT: However, I’ve stumble upon this thread, talking about zwave/zwave plus compatibility regarding group associations, take a look at it:

“Lifeline” on the Aeotec multi-sensor is the only group that has association. I checked the Aeotec switch and it doesn’t have any associations. Strange! will I break anything if I remove “Lifeline” association?

Found another thread on this, and looks like this has been documented.

Yes, it seems that you should delete node 255 (broadcast) from your node group 1 association: only the aeotec hub should appear there. The thing is that I’ve never done that, so I cannot help there, sorry.

From the document…

Where is zwave.change_association service located?

Broadcast group
Some Z-Wave devices may associate themselves with the broadcast group (group 255). You’ll be able to tell if this has happened if opening a door (or triggering a motion sensor) causes lights to come on, and closing the door (or the motion sensor going clear) causes lights to run off. There’s no way to clear this from the control panel, but you can use the zwave.change_association service:

{“association”: “remove”, “node_id”: 3, “group”: 1, “target_node_id”: 255}
That would remove the broadcast group from association group 1 of the device with node_id 3.

In your image from the other day, you showed a node (don’t know what id), with a group association in group 1 that was including node 255. I would go to the zwave menu, choose first the node id(that you didn’t show in the image), then go to the group association 1 as if you were to add a new node to that association. Then if you select node 255, as it is already in the group you will get the option to remove the node from the group, and that should fix it, I think.

@jolaca node 255 doesn’t exist, it’s a broadcast. Imagine having more than one set of lights switch, my sensors would be turning on all of them :joy: how much fun would that have been.

I’m gonna try a few things this weekend, if all fails I’ll just remote and reset my sensor and add it again.

I know it does not exist but it’s the way it is represented. The JSON you displayed the other day :
{“association”: “remove”, “node_id”: 3, “group”: 1, “target_node_id”: 255} exactly represents the process I told you. So I understand that you have tried it from the zwave menu from the node of your lights and in group association 1 you could not select 255 as it is not a node!?(it appeared represented as a node in your screen shot) Then, yes, just exclude your node with the broadcast issue and problem solved, :wink:

1 Like

@jolaca nothing is working for me. Even tried the documented process. Might have to reset the multi sensor, then add it again

@jolaca it worked! Ran that command multiple times, and restarted Hassio host, not just HA (As part of another issue I’m having (Can’t add any Fibaro switch modules :tired_face:) anyhow, now node 255 is not in group 1 of the multisenser. Tested it and it’s working, it’s no longer turning on my lights on motion detection.

1 Like

Great to hear that!! I’m glad you solved it!! :wink:

1 Like