Automation triggered but does not run actions (since last update? 2022.10.4))

True, throught the graphical UI, it produces the following code:

  - service: switch.turn_on
    data: {}
      entity_id: switch.toilet_fan

Yeah, that’s the newer, fuller syntax, but what I suggested should still work. Either way.

But does this make it work now?

Strange, I’m really not sure then. So when you press the button on the remote you see the blue “triggered” in the UI but nothing happens? Or you don’t see the blue “triggered” and nothing happens at all?

If it’s the second one what I would probably do to debug is go to Developer Tools → Events and see if I can capture the raw event. Unfortunately device triggers hide what the actual event type is which makes this a bit tricky. But what you can do is put * as the event type to listen to since that will listen for any and all events. Click “start listening”, press the button on the remote and then immediately press “stop listening” before you get flooded with events. Make sure you can find one in the list that comes from your deconz remote to see that it’s working, if not then that’s your issue.

If it’s the first one (you see a blue “triggered” but nothing else happens) then I’m at a loss. I don’t really understand how that could occur. Maybe debug logs can give some clue but it makes no sense why the actions wouldn’t fire if the automation was triggered without an error in the logs.

Yeah, something is missing here.

@Vahaldor I’d still suggest adding the debug logging I suggested above (and then restart HA.) Everything the automation is doing should go into home-assistant.log which should allow you to better understand what’s happening (or not happening.) I’d be happy to help interpret the messages if you’re not familiar enough with this logging output. I pretty much overhauled the automation/scripting infrastructure, but I haven’t touched it in a while, so I don’t know if something has recently changed that could be causing your issues. Also, I wasn’t involved with the tracing support that was added and have never used it, but I would think that should help, but don’t really know.

Thank you ALL for your care here! But given the fact that disabling/enabling the automation made it working again without possibility to replicate the problem, I think we won’t be able to move on here .)

To @CentralCommand I SAW the blue box but as I said I cannot replicate it, I now see the bluebox but the actions are executed.

I did not have anything in logs, so there’s nothing to dig here.

Good idea is to capture the raw event. I will try that if the problem surface again.

@pnbruckner Thanks for the idea. I will run this debug and see whether the problem surface or not.

Thanks all for your time and ideas!

Folks, when I see passionate people here, what about to solve this? There are already 4k views but still not a solution. I control my projector using com port by a remote HA on Rapsberry PI. Sending commands works well but I haven’t figured out how to read the response, which is good when you need to get the state, especially whether it is powered on or off.

Send a serial command and read the response as a sensor - Configuration - Home Assistant Community (

Is the trigger an Ikea or in general a Zigbee button?
I have your same issue since the upgrade and I think I saw a discussion regarding Ikea buttons stopped working after the update.

It is the tradfri ikea button:

What update you have on your mind? I have connected it to Deconz ConBee II

thats really weird, button on zigbee should still trigger events. Did a bump on version change the event content or did the event disappear? I have a hue button event automation… can check if that still works if that helps

I just had the same thing occur. Going to the automation page literally said “triggered” on the trigger every time I pressed the button. Yet nothing happened. Manually running the action worked as expected. Disabled and then re-enabled the automation and it works again.

I assume it is caused by improper set-up of triggers of deconz, but this happens occasionally and should be classified as a bug.

The following error ocurred prior to this issue ocurring:

Logger: homeassistant.components.automation.new_automation_4
Source: components/automation/
Integration: Automation (documentation, issues)
First occurred: 3:34:08 PM (1 occurrences)
Last logged: 3:34:08 PM

Got error 'No deconz_event tied to device "TRÅDFRI remote control" found' when setting up triggers for New Automation

I believe it happens if a Tradfri device is temporarily unavailable (e.g. due to battery having run out, or bad signal reception) when triggers are set up (e.g. when HA is restarted after an update).

The subsequent log entries when trying to trigger the automation of course act as if the automation does not properly exist and do not give any meaningful extra information, but included here for completeness:

2022-12-05 17:01:14.373 DEBUG (MainThread) [pydeconz.websocket] {"attr":{"id":"16","lastannounced":"2022-12-05T14:50:33Z","lastseen":"2022-12-05T16:01Z","manufacturername":"IKEA of Sweden","modelid":"TRADFRI remote control","name":"TRÅDFRI remote control","swversion":null,"type":"ZHASwitch","uniqueid":"xx:xx:xx:xx:xx:xx:xx:xx-xx-xxxx"},"e":"changed","id":"16","r":"sensors","t":"event","uniqueid":"xx:xx:xx:xx:xx:xx:xx:xx-xx-xxxx"}
2022-12-05 17:01:14.383 DEBUG (MainThread) [pydeconz.websocket] {"e":"changed","id":"16","r":"sensors","state":{"buttonevent":5002,"lastupdated":"2022-12-05T16:01:14.369"},"t":"event","uniqueid":"xx:xx:xx:xx:xx:xx:xx:xx-xx-xxxx"}
2022-12-05 17:01:14.392 DEBUG (MainThread) [homeassistant.core] Bus:Handling <Event deconz_event[L]: id=tradfri_remote_control, unique_id=xx:xx:xx:xx:xx:xx:xx:xx, event=5002, device_id=xxxxxxxxxxxxxxxxxxxxxxxxxxxx>

Just to add to this I am (and have had for some time) the same issues as mentioned above.

I am running 2023.1.7 with a conbe2 via ZHA.

I have been having issues recently with zigbee and had tried all the usual usb change, extension cable, checking channels, etc and to no avail.

I tried doing some testing today and the results led me to this post.

Pretty much all zigbee buttons not responding.

I have checked via event listener that there is no unwanted or excessive traffic. Every button press is received loud and clear instantly.

Every automation shows the triggered (blue box) but no actions are ever run and therefor no trace is created.

If I run the automation via run it works perfectly and I have manual control over all the actions, as in I can switch every zigbee plug on via voice command (google) or via home assistant. So zigbee inputs and commands all working correctly.

If I create a new automation with exactly the same triggers (and actions) the new automation works perfectly.

If I reload automations the original automations still don’t work.

However if I disable and enable to original automations they then work correctly again.

Some button are smarthings and others are ikea, same issue.

I can’t get my head round why simply disabling and enabling the automation fixes the issue (but only temporarily it seems) yet reloading automations does not.

As I have now enabled them all, they are currently all working again, so limited for testing at present.

1 Like

Also got this with Deconz devices for several months.
I never thought it was a bug until I saw this thread.

I’m suffering the same issue since a couple of months ago.

If I look at the automation page when I push the zigbee button, the blue banner says it has received the event, but the actions of the automation don’t run.

If I execute the automation manually, all the steps complete flawlessly.

Looking at core logs, lines like these show up when reloading automations:

2023-02-17 20:43:33.851 ERROR (MainThread) [homeassistant.components.automation] Automation with alias 'Interruptor luz habitación azul - alternar - apagar' failed to setup triggers and has been disabled: deCONZ trigger ('remote_button_short_release', 'turn_on') is not valid for device DeviceEntry(area_id=None, config_entries={'3e876c9d42e4428b613d614a22680349'}, configuration_url=None, connections={('zigbee', '84:b4:db:ff:fe:7a:54:9c')}, disabled_by=None, entry_type=None, hw_version=None, id='34346d513ac49363cd0480fab4553d36', identifiers={('deconz', '84:b4:db:ff:fe:7a:54:9c')}, manufacturer='IKEA of Sweden', model='Remote Control N2', name_by_user=None, name='Styrbar 001', suggested_area=None, sw_version='1.0.024', via_device_id='3cafd0fbf8ed7e9b05c25fbe2f4deb09', is_new=False) (34346d513ac49363cd0480fab4553d36)

Restarting HA may or may not resolve the issue. I mean, sometimes HA boots with the issue, some other times boots without it.

However, if the automation doesn’t trigger on button push, and I duplicate the trigger definition within the automation, then it runs successfully. Yep, just by defining something like “when (button1 is pushed) or (button1 is pushed)” the automation starts to fire. And, if you look at the automation page while pushing the button you can see 2 banners, one over every button pushed trigger condition.

I’m on Deconz with a ConBee 2 since Jan 2021.

Same issue here.
Push a button and see the triggering blue confirmation box but the action doesn’t run…
No trace.
Disable and enable the automation helps but the issue comes back every another week.
I put up an automation just to disable and enable the list of automations that aren’t working every day…
I hope there is a better way to resolve it.

Nice, I see I am not alone. Let me add. I am having same behavior with Aqara motion sensor. It detects motion but the light does not switch on. You wait 5mins, go back and the light switches on. In both occasions, the motion sensor detects motion.

Another behavior is that motion sensor blink blue (so it detects motion) but does not send any message to coordinator over zigbee network.

So I guess this might be more complex problem in zigbee networks in general. I do not have this automation problem in automation that do not involve zigbee.

Has anybody reported this behavior as a bug on github?

I updated to 2023.3.1

All of my automations stopped working (only showing the blue box that they got triggered)

Deactivated and activated all automations

Everything works again (for now), Thanks @rossk

Same here. All my automations with deConz show as triggered but action don’t run, then automations work after a disable and re-enable… Seems to have been an issue since around October like originally reported.

+1, same issue for me :man_facepalming:

I have something similar that I have been tracking down the last week. Disable/Re-Enable gets things working again. Happened again this morning. I am wondering if it is something with the previous run never completing and so it won’t trigger another run. How many of you with this issue have the Automation “Mode” set to “single” (which is the default mode)?

If I can reproduce the issue more reliably, vs just over time, I may set it to “parallel” to see if that masks the issue, and no longer occurs, but that still isn’t a fix, since some of the things in my automation shouldn’t be used in parallel executions.